cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

13848
Views
0
Helpful
11
Replies
dluff4343
Beginner

Help ! Unable to Launch ASDM from XX.XX.XX.XX

Hello, 

we have:

ASA version:   8.0(4)23
dev mgr ver:   6.1(5)51

trying to use  ASDM launcher:   1.5.50,   running  Java 6u7 on pc.

Able to telnet and ssh to device fine.

I am getting the error  Unable to Launch ASDM from  XX.XX.XX.XX.

After launching the ASDM, and putting in credentials,  accept security cert and then gets the error

when I try to https to the same ASA insde IP,   page never loads.

here is some of the config.    I belive I have everything enable to access via  asdm and https.  but still not working.

hostname# sh ver

Cisco Adaptive Security Appliance Software Version 8.0(4)23
Device Manager Version 6.1(5)51

Compiled on Tue 03-Feb-09 20:20 by builders
System image file is "disk0:/asa804-23-k8.bin"
Config file at boot was "startup-config"

up 95 days 12 hours

Hardware:   ASA5510, 256 MB RAM, CPU Pentium 4 Celeron 1600 MHz
Internal ATA Compact Flash, 64MB
BIOS Flash AT49LW080 @ 0xffe00000, 1024KB


hostname# sh disk0:
--#--  --length--  -----date/time------  path
  152  13842432    Mar 28 2009 18:55:42  asa804-23-k8.bin
  156  7605252     Jan 12 2009 11:20:58  asdm-61551.bin


hostname# sh run
asdm image disk0:/asdm-61551.bin

http server enable
http 172.16.0.0 255.255.0.0 Inside

11 REPLIES 11

Hi,

172.16.0.0/16 is the only range allowed to access ASDM to the inside of the ASA according to your configuration (I assume you're trying the connection from an IP in that range).

Also, can you try opening a browser and typing https://IP_ASA (instead of using the ASDM launcher).

Federico.

Yes, thanks.     that is the only net we need to access this from.

we also have:

ssh 172.16.0.0 255.255.0.0 Inside

and that works fine. I can get to via ssh on that same network I am trying the asdm/https

when using https,     on IE it gets the cert error and then you accept then page just does not load.

firefox does the same.

According to the release notes, ASDM 6.1 should work with ASA version 8.0(4), so no problems here.

Have you tried from a different machine?

The reason I ask you this is to make sure the problem is not Java on this computer.

Check this please:

http://www.cisco.com/en/US/docs/security/asdm/6_1/release/notes/rn615.html

Federico.

Check this link: https://supportforums.cisco.com/docs/DOC-13012

Make sure to run through the check list under unable to access asdm.

-KS

Denis Spichkin
Beginner

By the way this issue could be related with Java problem.
To check this you need (as it was mentioned) just try to open https://172.16.0.1
and if you get offer to load ASDM and then you can't execute ASDM that defently releted with JAVA.

Thanks all,

KS,  I will check that link out.

Denis,

I have java 6u7,  which I have know to be good for the ASDM.    I have used the same pc w/ this java version and same ASDM launcher to get into other ASA's, but can't access this one. 

When I can I am going to reload the ASA,   I saw some post about an issue with over 1 yr uptimes,   this is only at  96 days or so, but I'm out of ideas

I met the same problem.I didn't work it out yet.maybe the OS/ASDM image upgrade will help.

I spent some time last night and wrote this document: https://supportforums.cisco.com/docs/DOC-13012

Pls. take a look and run through the check list.

Let me know if this helps.

-KS

Hi Derek,

When u get the box for entering your credentials in the ASDM launcher, there will be a java button at the bottom right corner in the shape of a cup telling show java console. Click on that and u will get a display of java console . On that press 5 to set the trace level. Now enetr your credentials in the ASDM launcher and click ok. can you copy and paste the logs that come on the java console so that we can see if there is any exception. From the java logs we should be able to tell if there is java compatibility problem

Regards

Rahul

Felix Bowman
Beginner

Hello.

I remembered when we had just received our ASAs and I tried to access them I had a similar problem.

What I did to get it working was to update to the next minor version of the ADSM. There was a minor version upgrade on Cisco's site that went with the same version os the IOS on the ASA.

This did the trick for me. From there, I fully upgraded to the latest IOS and ADSM through the web interface.

I hope this helps.

If it still does not work... Try to delete the ASDM cache. Under the current users user profile, there is a .asdm folder. Delete it and try again:)

// Roger

Content for Community-Ad