cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1290
Views
0
Helpful
1
Replies
Casperdegeus
Beginner

Only 30Mb/s throughput on Cisco881

Hi,

I have a Cisco 881 (without wifi model) connected to a 100Mb unmanaged switch and a cable modem with a 120Mb down, 10Mb up connection. When I connect the modem directly to my laptop, I can reach the 120Mb/s down and 10Mb/s upload speed.

When I connect the modem to the 881, the max download is about 30Mb/s. Upstream 10Mb is no problem.

I've been trying to change the duplex and speed settings on the FastEthernet4 interface, but this has only a worsening effect. Does anybody have an idea? I should be able to get about 100Mb/s (since switch is only 100) right?

Config is below. Thx! Regards Casper.

JAAPROUTER_HQ2#sh ru
Building configuration...

Current configuration : 3515 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname JAAPROUTER_HQ2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication ppp default local
aaa authorization exec default local
aaa authorization network default local
!
!
aaa session-id common
memory-size iomem 10
clock timezone CET 1
!
crypto pki trustpoint TP-self-signed-1787137493
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1787137493
revocation-check none
rsakeypair TP-self-signed-1787137493
!
!
crypto pki certificate chain TP-self-signed-1787137493
certificate self-signed 01
  30820251 308201BA A0030201 02020101 300D0609 2A864886 F70D0101 04050030
make it shorter...
  CF09D9C8 F733A8B8 789D190B E8C1E208 E51A1EA3 06
        quit
ip source-route
!
!
no ip cef
no ip domain lookup
ip domain name jaap.local
ip name-server 8.8.8.8
ip name-server 8.8.4.4
no ipv6 cef
!
!
!
!
username admin privilege 15 secret 5 $1$/Dwj$/ezjp55VoalzZyzfzHoDI.
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
ip address XXX.XXX.36.186 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 10.2.0.252 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 XXX.XXX..36.185
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 101 interface FastEthernet4 overload
!
access-list 101 permit ip 10.2.0.0 0.0.0.255 any
!
!
!
!
!
control-plane
!
!
line con 0
password 7 062C0E205C7C0C140C16
no modem enable
line aux 0
line vty 0 4
privilege level 15
transport input telnet ssh
!
scheduler max-task-time 5000
end

1 REPLY 1
Shrikant Sundaresh
Cisco Employee

Hi Kasper,

Kindly try the following:

1. enable Cisco Express forwarding (ip cef)

2. Test speeds with PC----- switch ----- modem ----- internet to eliminate switch from being source of problem

3. hardcode speed and duplex as 100 and full respectively on both switch and router.

Hope this helps.

-Shrikant

Create
Recognize Your Peers
Polls
Which of these topics should we host an event in the Community?

Top Choice: pxGrid (39%)

Content for Community-Ad