cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

760
Views
0
Helpful
6
Replies
Highlighted
Beginner

server looses network access when vpn is active

When I start a VPN-session my server looses internet access. The server is host for a few virtual machines and they have internet access.

using 5505 and asa is version 8.4(2).

The nat-setup is like this:

3 (inside) to (outside) source static any any   destination static NETWORK_OBJ_10.10.10.0_28 NETWORK_OBJ_10.10.10.0_28 no-proxy-arp route-lookup translate_hits = 0, untranslate_hits = 0

4 (inside) to (outside) source static any any   destination static NETWORK_OBJ_192.168.1.128_27 NETWORK_OBJ_192.168.1.128_27 no-proxy-arp route-lookup translate_hits = 0, untranslate_hits = 0

5 (inside) to (outside) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24   destination static NETWORK_OBJ_192.168.254.0_28 NETWORK_OBJ_192.168.254.0_28 no-proxy-arp route-lookup translate_hits = 37, untranslate_hits = 63771

6 (outside) to (outside) source dynamic NET-VPNPOOL interface

Did some testing on the host server, since I can access it through one of the guests.

When trying to wget some public website, I am getting connection timed out.

I also tried apt-get upgrade with the same result. So it seems as if the network out is blocked for the host server, but not for any of the guest servers.

Command output: show cry ipsec sa

interface: outside

    Crypto map tag: SYSTEM_DEFAULT_CRYPTO_MAP, seq num: 65535, local addr: 193.90.162.212

      local ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)

      remote ident (addr/mask/prot/port): (192.168.254.2/255.255.255.255/0/0)

      current_peer: 80.213.169.7, username: foobar

      dynamic allocated peer ip: 192.168.254.2

      #pkts encaps: 5663, #pkts encrypt: 5663, #pkts digest: 5663

      #pkts decaps: 10371, #pkts decrypt: 10371, #pkts verify: 10371

      #pkts compressed: 0, #pkts decompressed: 0

      #pkts not compressed: 5663, #pkts comp failed: 0, #pkts decomp failed: 0

      #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0

      #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0

      #send errors: 0, #recv errors: 0

      local crypto endpt.: outside.ip.address.12/4500, remote crypto endpt.: 80.213.169.7/64919

      path mtu 1500, ipsec overhead 82, media mtu 1500

      current outbound spi: 962B0E81

      current inbound spi : DAFE47BE

    inbound esp sas:

      spi: 0xDAFE47BE (3674097598)

         transform: esp-aes esp-sha-hmac no compression

         in use settings ={RA, Tunnel,  NAT-T-Encaps, }

         slot: 0, conn_id: 335872, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP

         sa timing: remaining key lifetime (sec): 16271

         IV size: 16 bytes

         replay detection support: Y

         Anti replay bitmap:

          0xFFFFFFFF 0xFFFFFFFF

    outbound esp sas:

      spi: 0x962B0E81 (2519404161)

         transform: esp-aes esp-sha-hmac no compression

         in use settings ={RA, Tunnel,  NAT-T-Encaps, }

         slot: 0, conn_id: 335872, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP

         sa timing: remaining key lifetime (sec): 16271

         IV size: 16 bytes

         replay detection support: Y

         Anti replay bitmap:

          0x00000000 0x00000001

configuration is as following:

show config

: Saved

: Written by john at 22:28:54.262 CEDT Thu Sep 27 2012

: Call-home enabled from prompt by enable_15 at 00:05:43 UTC May 4 2012

!

ASA Version 8.4(2)

!

hostname ciscoasa

domain-name inside-sport.no

enable password foobarbaz encrypted

passwd foobarbaz encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

speed 100

duplex full

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

switchport access vlan 12

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address dhcp

!

interface Vlan12

no forward interface Vlan1

nameif DMZ

security-level 50

ip address 192.168.2.1 255.255.255.0

!

ftp mode passive

clock timezone CEST 1

clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00

dns domain-lookup inside

dns domain-lookup outside

dns domain-lookup DMZ

dns server-group DefaultDNS

name-server 193.75.75.75

name-server 192.168.1.11

name-server 192.168.1.12

name-server 193.75.75.193

domain-name inside-sport.no

same-security-traffic permit intra-interface

object network obj_any

subnet 0.0.0.0 0.0.0.0

object network inside-net

subnet 192.168.1.0 255.255.255.0

object network NETWORK_OBJ_10.10.10.0_28

subnet 10.10.10.0 255.255.255.240

object network NETWORK_OBJ_192.168.1.128_27

subnet 192.168.1.128 255.255.255.224

object network NETWORK_OBJ_192.168.1.0_24

subnet 192.168.1.0 255.255.255.0

object network NETWORK_OBJ_192.168.254.0_28

subnet 192.168.254.0 255.255.255.240

object network dmz-ftpserver

host 192.168.2.101

description FTP server Host Object

object network dmz-webserver

host 192.168.2.100

description Web Server Host Object

object network ftp-server

object service FTP

service tcp source eq ftp

object service WWW

service tcp source eq www

object-group protocol TCPUDP

protocol-object udp

protocol-object tcp

object-group network NET-VPNPOOL

network-object server.public.ip.0 255.255.255.0

access-list outside_access_in extended permit tcp any host 192.168.2.101 eq ftp

access-list outside_access_in extended permit tcp any host 192.168.2.100 eq www

access-list VPN-INSIDE-SPORT_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

mtu DMZ 1500 

ip local pool VPN-Pool 192.168.254.1-192.168.254.10 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

nat (DMZ,outside) source static dmz-webserver interface service WWW WWW

nat (DMZ,outside) source static dmz-ftpserver interface service FTP FTP

nat (inside,outside) source static any any destination static NETWORK_OBJ_10.10.10.0_28 NETWORK_OBJ_10.10.10.0_28 no-proxy-arp route-lookup

nat (inside,outside) source static any any destination static NETWORK_OBJ_192.168.1.128_27 NETWORK_OBJ_192.168.1.128_27 no-proxy-arp route-lookup

nat (inside,outside) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static NETWORK_OBJ_192.168.254.0_28 NETWORK_OBJ_192.168.254.0_28 no-proxy-arp route-lookup

nat (outside,outside) source dynamic NET-VPNPOOL interface

!

object network obj_any

nat (inside,outside) dynamic interface

object network inside-net

nat (inside,outside) dynamic interface

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 server.public.ip.212 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

aaa authentication enable console LOCAL

aaa authentication http console LOCAL

aaa authentication ssh console LOCAL

aaa authorization command LOCAL

aaa authorization exec authentication-server

http server enable

http 192.168.1.0 255.255.255.0 inside

http 192.168.1.1 255.255.255.255 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504

    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31

    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b

    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20

    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65

    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420

    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329

    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365

    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7

    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597

    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777

    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969

    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b

    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973

    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30

    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603

    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355

    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

    6c2527b9 deb78458 c61f381e a4c4cb66

  quit

crypto ikev1 enable outside

crypto ikev1 policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh 192.168.1.0 255.255.255.0 inside

ssh 0.0.0.0 0.0.0.0 outside

ssh timeout 30

console timeout 0

no vpn-addr-assign aaa

no vpn-addr-assign dhcp

dhcpd domain inside-sport.no

dhcpd auto_config outside

!

dhcpd address 192.168.1.20-192.168.1.49 inside

dhcpd dns 192.168.1.11 192.168.1.12 interface inside

dhcpd domain inside-sport.no interface inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

group-policy VPN-INSIDE-SPORT internal

group-policy VPN-INSIDE-SPORT attributes

dns-server value 192.168.1.11 193.75.75.193

vpn-tunnel-protocol ikev1

split-tunnel-policy tunnelspecified

split-tunnel-network-list value VPN-INSIDE-SPORT_splitTunnelAcl

default-domain value inside-sport.no

username john password foobarbaz encrypted privilege 15

username paul password 8foobarbaz48 encrypted privilege 15

username ringo password foobarbaz encrypted

username ringo attributes

service-type remote-access

username ringo password foobarbaz encrypted privilege 0

username ringo attributes

service-type remote-access

tunnel-group VPN-INSIDE-SPORT type remote-access

tunnel-group VPN-INSIDE-SPORT general-attributes

address-pool VPN-Pool

default-group-policy VPN-INSIDE-SPORT

tunnel-group VPN-INSIDE-SPORT ipsec-attributes

ikev1 pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

call-home reporting anonymous

call-home

profile CiscoTAC-1

  no active

  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService

  destination address email callhome@cisco.com

  destination transport-method http

  subscribe-to-alert-group diagnostic

  subscribe-to-alert-group environment

  subscribe-to-alert-group inventory periodic monthly

  subscribe-to-alert-group configuration periodic monthly

  subscribe-to-alert-group telemetry periodic daily

Cryptochecksum:7e3279f0263f6400a6dffdda38b32198

Everyone's tags (4)
6 REPLIES 6
Highlighted

server looses network access when vpn is active

Hello Trond,

few queries,

when you say server loose internet access when you connect VPN. Could you give bit clarity on that ? is it site to site VPN you are settign up and also what is the IP of the server

regards

Harish

Highlighted
Beginner

server looses network access when vpn is active

I connect with VPN from my laptop to the office.

The IP of the server is 192.168.1.8. The other servers are also in the 192.168.1-range.    

Highlighted

server looses network access when vpn is active

Hello Trond,

ok so once you connected with the VPN, you are able to reach server 192.168.1.8. but server can not reach internet is it ?

in normal scenario when you are not connecting to the VPN, is server reachable to internet ?

regards

Harish

Highlighted
Beginner

server looses network access when vpn is active

when on vpn I cannot reach server 192.168.1.8 - it's on the inside, but I can reach for instance 192.168.1.11 which is also on the inside.

1.8 cannot access or reach internet. It is not reachable for outside (which is ok, I have a dmz for that - 192.168.2.x)

When not on vpn - as in I am at the office - the server can reach the internet.

Very odd that this is only affecting this server...

Highlighted

server looses network access when vpn is active

i couldnt fine any reason why you were not able to reach 1.8.. .but for server o reach internet, can you add the following and see how does it goes

nat (inside,outside) source static NETWORK_OBJ_192.168.1.0_24 interface

regards

Harish.

Highlighted
Beginner

Re: server looses network access when vpn is active

I tried the command but got some warnings and since nothing really didn't change, I removed it.

This question has been answered here:

https://supportforums.cisco.com/message/3746862#3746862