cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
746
Views
5
Helpful
7
Replies

Setting up RDP between 2 internal networks

stevedryer
Beginner
Beginner

My issue is simple I think but I have been unable to come up with a solution.   We have 2 seperate networks in our office.   A production network (192.168.254.0/24) and a testing network (192.168.250.0/24)  No connection between them at all.  The 192.168.250 network has no internet access and really is just 4 servers connected to a switch so they can talk to each other.   I woud like the two networks to be able to access each other via RDP (tcp/3389) only.  I setup a ASA 5505 (ver 8.2.5) between the two networks with the 192.168.254.0 on the inside interface and the 192.168.250.0 on the outside interface.   Factory defaulted the ASA to be sure it is clean and ran through the setup.  see the config below.   To start I want only 192.168.254.154 to be able to RDP to 192.168.250.100.   As I would expect that works just fine,   Inside to outside.  No problem.  Next I try and setup a access rule to alllow 192.16.250.100 to RDP to 192.168.254.154.  ( outside in) and nothing I have done for the last 2 weeks seems to work.  I setup port forwarding just as I have done in the past for email and other things and nothing will work.   Infact as soon as I do the RDP stops inside to ouside. 

The config below is a clean one with no extras. 

Any ideas????

ASA Version 8.2(5)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.254.2 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 192.168.250.2 255.255.255.0
!
ftp mode passive
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.254.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.254.6-192.168.254.133 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:6cdc7d5f3b37603cde60d7709aa97097
: end

1 ACCEPTED SOLUTION

Accepted Solutions

Hello Steve,

Great to hear that, Please mark the question as answered and remember to rate all of the helpful post ( To rate a post just mark the 5 start on the bottom of each answer, 1 being bad 5 being good)

Regards

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC

View solution in original post

7 REPLIES 7

Julio Carvajal
Advisor
Advisor

Hello Steve,

static (inside,outside) 192.168.254.154 192.168.254.154

access-list Outside_in permit tcp host 192.16.250.100 host 192.168.254.154 eq 3389

access-group Outside_in in interface outside

Regards

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC

That almost works.   Inside can still access the outside.  (192.168.254.154 can RDP to 192.168.250.100) but not back.   That has been what I have had most of the time.  Could it be something with the route on the 192.168.250.100 server and it not knowing how to find the other server?

Ip 192.168.250.100

MASK 255.255.255.0

GW 192.168.250.2

Hello Steve,

looks like the ipconfig on the server is okay so route is not an issue,

do the following:

packet-tracer input outside tcp 192.15.250.100 1025192.168.254.154 3389

I would say the configuration is the one required already so it seems to be something else,

Please paste the output of the packet tracer ( full output)

Remember to rate all of the helpful posts

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC

Result of the command: "packet-tracer input outside tcp 192.15.250.100 1025 192.168.254.154 3389"

Phase: 1
Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:
MAC Access list

Phase: 2
Type: UN-NAT
Subtype: static
Result: ALLOW
Config:
static (inside,outside) 192.168.254.154 192.168.254.154 netmask 255.255.255.255
  match ip inside host 192.168.254.154 outside any
    static translation to 192.168.254.154
    translate_hits = 4, untranslate_hits = 15
Additional Information:
NAT divert to egress interface inside
Untranslate 192.168.254.154/0 to 192.168.254.154/0 using netmask 255.255.255.255

Phase: 3
Type: ACCESS-LIST
Subtype:
Result: DROP
Config:
Implicit Rule
Additional Information:

Result:
input-interface: outside
input-status: up
input-line-status: up
output-interface: inside
output-status: up
output-line-status: up
Action: drop
Drop-reason: (acl-drop) Flow is denied by configured rule

Hello Steve,

Post the following:

show run access-group

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC

Well I finally got this working.   Thanks for the help.   Below is the final solution.

From the factory default config

no global (outside) 1 interface

access-list Outside_in extended permit tcp host 192.168.250.100 host 192.168.254.154 eq 3389

static (inside,outside) 192.168.254.154 192.168.254.154 netmask 255.255.255.255

access-group Outside_in in interface outside

Thanks Again

S

Hello Steve,

Great to hear that, Please mark the question as answered and remember to rate all of the helpful post ( To rate a post just mark the 5 start on the bottom of each answer, 1 being bad 5 being good)

Regards

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: