Showing results for 
Search instead for 
Did you mean: 

static nat on asa 5512-x version 9.5.2

Level 4
Level 4

hi all,

i am trying to configure the static nat on the cisco asa which is not working.

in 8.2 version this is the code

nat(inside) 2 x.x.x.x netmask

global(outside) 2 y.y.y.y

for the above commands i converted to 9.5.2 code which is

object network obj-x.x.x.x

host x.x.x.x

nat(inside,outside) static y.y.y.y

after configuring the above from x.x.x.x server there is no internet connection, but for the same server i confgiured the portforwarding with the same external IP y.y.y.y which is working. when i try to make the outgoing traffic also through the same Ip which is not working. please help me to solve the issue.

2 Replies 2

Level 1
Level 1

you need to do dynamic PAT

object network obj-x.x.x.x

host x.x.x.x

nat(inside,outside) dynamic y.y.y.y ====>dynamic instead of static.

hi sarabsin,

i have changed the same but still no internet access in that server,

here my config,

object network mail-nat-outside
 nat (Internal,External) dynamic Mail-Server

in this mail-server is the y.y.y.y and mail-nat-outside ip is x.x.x.x

for the subnet nat it is working

object network Data-network
 nat (Internal,External) dynamic interface

Data-Network -- x.x.x.0/24

here my port forwarding,

object network smtp-server
 nat (Internal,External) static Mail-Server service tcp smtp smtp
object network https-mail-server
 nat (Internal,External) static Mail-Server service tcp https https
object network imap-server
 nat (Internal,External) static Mail-Server service tcp imap4 imap4

i am attaching the config. i have tried above configuration and static as well both are not working. even the port forwarding also not working. initially  i mentioned it is working but its not.

Review Cisco Networking for a $25 gift card