cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
244200
Views
200
Helpful
47
Replies
Beginner

Hi Anthony,I had this same

Hi Anthony,

I had this same issue. I resolved it by opening Java (Windows - Control Panel Java - Select Security Tab Select Manage Certificates. Select Certificate Type and choose Secure Site) on a known working ASDM installed computer.

Export the "Trusted Site" cert and import it on the computer with ASDM issue.

Highlighted
Beginner

This resolved the issue for

This resolved the issue for me.  I exported the self-signed certificates from each of my ASAs and then imported them into the "secure site" section in Java console (the "trusted certificates" section did not work).  I have seen this previously for another java application as well.  This was with ASDM 7.1(5)100 and Java version 7 update 51.

Highlighted
Beginner

@ Joel Asaro:thanks man. you

@ Joel Asaro:

thanks man. you saved my day...

Highlighted
Beginner

Thanks nypizzar0x and Joel

Thanks nypizzar0x and Joel Asaro.  You guys helped me out too.

Highlighted
Beginner

This one is the solution!

This one is the solution! Thanks :)

Highlighted
Beginner

Tried everything, but this

Tried everything, but this worked. Thanks!

Highlighted
Beginner

The solution works. Thank you

The solution works. Thank you very much.

Highlighted
Beginner

thanks mate!! you people

thanks mate!! you people saved my day.. its working fine for me..

Added username and password and changed the security level to medium in java control  panel in windows 7.

Now need to explore ASDM.. :-)

Highlighted
Beginner

hi guys, would you please

hi guys,

 

would you please explain to me how to export the self signed ssl certificate from the ASA (CLI) in order to import it in Java secure web site?

 

Many thnaks in advance

Highlighted
Beginner

This worked for me. Thanks!

This worked for me. Thanks!

Highlighted

Run: asdm-launcher.jar on C:

Run: asdm-launcher.jar on C:\Program Files (x86)\Cisco Systems\ASDM
Windows 8.1 64 bit

ASDM 6.1
JRE 8 Update 20

Highlighted
Beginner

Thanks nguyenxuanthuyet  :)

Thanks nguyenxuanthuyet  :) that worked for me.

Highlighted
Beginner

I ran into a VERY similar

I ran into a VERY similar problem and was loading all the certificates into Java with no luck. For those of you like me, please be aware that if you're using AES-256 encryption ASDM will not work unless you have JCE version of Java installed. After installing it came right up! 

https://supportforums.cisco.com/discussion/12729756/asdm-aes-256-not-supported#comment-11388121

http://www.cisco.com/c/en/us/support/docs/security/adaptive-security-device-manager/110282-asdm-tshoot.html#prblm13

Highlighted
Beginner

Mybe your device has been

Mybe your device has been update by high version IOS. The ASDM access link has been changed in the new version IOS. You can input javaws https://xxx.xxx.xxx.xxx/admin/public/asdm.jnlp in the Start - Run to open the ASDM console.

www.eumarine.com

Highlighted
Beginner

Re: Mybe your device has been

I have been going through this with every Java update for the last few years.   I set the security for the site to trusted, security to high (lowest it will go).

 

Problem is, every version defaulted to the non-export-grade encryption.  You want to use "unlimited" grade (search for it).  Oracle says that starting with 8_162 they now default to unlimited.

 

https://golb.hplar.ch/p/JCE-policy-changes-in-Java-SE-8u151-and-8u152

 

Note that the actual files you need to replace have not changed since 2013 or 2014.

 

http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html

 

I am on .151, and can tell you I had to do it manually again.  Once files moved, closed and reopened application and it worked fine.

So, Java settings that work for me are high, added IP to trusted (it was a local), and made sure I had the unlimited files in the security directory.

 

Hope this helps someone...