cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

17716
Views
0
Helpful
5
Replies
Highlighted
Beginner

Upgrade AIP-SSM-10 on ASA 5510

Hi,

I want to upgrade the IPS module in an ASA 5510 and have a few questions. The AIP-SSM is running 6.2(1)E3 479.0 and I have a valid CCO account etc for this.

  1. Does the Software version on the ASA matter?
  2. When I look in software downloads < IPS there are .pkg and .img files. I want to upgrade to 6.3(3)E4. Do I have to re-image the IPS module?
  3. As far as I know re-imaging will wipe teh device so I just reload the config after, right?
  4. I presume I can apply any upgrades after going to E4?
  5. Can you give me any links for this upgrade?

cheers

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted

Let me provide some clarification on a few points:

2. You do not need to re-image the device using the .img file.  You can upgrade the device, maintaining your existing configuration using the .pkg file.  This is the recommended method for upgrading all of Cisco's IPS appliances/modules.  The .img re-image file should only be used to restore the device to factory defaults.

5. Here are links for upgrading the sensor using a .pkg file.  For upgrades via the IDM GUI:

http://www.cisco.com/en/US/docs/security/ips/6.2/configuration/guide/idm/idm_sensor_management.html#wp2126670

  For upgrades via the CLI:

http://www.cisco.com/en/US/docs/security/ips/6.2/configuration/guide/cli/cli_system_images.html#wp1142504

  Another point of clarification; the current releases of IPS software supported on the AIP-SSM-10 are (taking into account you are currently running 6.2(1)E3):

6.2(3)E4

7.0(4)E4

  You can upgrade directly to either release.

Scott

View solution in original post

Highlighted

You selected the file for the SSC-5 platform.  It will not work on the SSM-10 platform.

In the download site you needed to have selected the "Cisco ASA Advanced Inspection and Prevention (AIP) Security Services Module " instead of "Cisco ASA Advanced Inspection and Prevention Security Services Card".

Then selecting the Upgrades link and 6.2(3)E4 you would have come to this file which can be used on the SSM-10:  IPS-K9-6.2-3-E4.pkg

View solution in original post

5 REPLIES 5
Highlighted
Cisco Employee

To answer your questions

1. Does the Software version on the ASA matter?

As long as the ASA is in 7.2.x or higher it does not.

2. When I look in software downloads < IPS there are .pkg and .img files. I want to upgrade to 6.3(3)E4. Do I have to re-image the IPS module? 
You would need a bin file to get to 6.3.3
3. As far as I know re-imaging will wipe teh device so I just reload the config after, right?
Correct
4. I presume I can apply any upgrades after going to E4?
Correct
5. Can you give me any links for this upgrade?

https://supportforums.cisco.com/docs/DOC-5668 shows how to do it with an CSC module. You will do the same thing but you will use the AIP image.

I hope it helps.

PK

Highlighted

Let me provide some clarification on a few points:

2. You do not need to re-image the device using the .img file.  You can upgrade the device, maintaining your existing configuration using the .pkg file.  This is the recommended method for upgrading all of Cisco's IPS appliances/modules.  The .img re-image file should only be used to restore the device to factory defaults.

5. Here are links for upgrading the sensor using a .pkg file.  For upgrades via the IDM GUI:

http://www.cisco.com/en/US/docs/security/ips/6.2/configuration/guide/idm/idm_sensor_management.html#wp2126670

  For upgrades via the CLI:

http://www.cisco.com/en/US/docs/security/ips/6.2/configuration/guide/cli/cli_system_images.html#wp1142504

  Another point of clarification; the current releases of IPS software supported on the AIP-SSM-10 are (taking into account you are currently running 6.2(1)E3):

6.2(3)E4

7.0(4)E4

  You can upgrade directly to either release.

Scott

View solution in original post

Highlighted

ThanksGuys,

When I try to upgrade to IPS-SSC_5-K9-6.2-3-E4.pkg from the GUI and CLI I get "cannot upgrade the software on the sensor. This package cannot be installed on the SSM-IPS10 platform" I am downloading it from under the ASA modules section

This is the latest .pkg file available to me. Any ideas ?

Highlighted

You selected the file for the SSC-5 platform.  It will not work on the SSM-10 platform.

In the download site you needed to have selected the "Cisco ASA Advanced Inspection and Prevention (AIP) Security Services Module " instead of "Cisco ASA Advanced Inspection and Prevention Security Services Card".

Then selecting the Upgrades link and 6.2(3)E4 you would have come to this file which can be used on the SSM-10:  IPS-K9-6.2-3-E4.pkg

View solution in original post

Highlighted

Hi,

I go to Products < Security < IPS < IPS Modules for ASA < and the only option is Cisco ASA Advanced Inspection and Prevention Security Services Card

Must be a link missing using the software download tool on the site. I followed your link and can see what I want

thank you

Content for Community-Ad