cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
41713
Views
94
Helpful
7
Comments
ashirkar
Level 7
Level 7

Last week, I was going through customer cases and what I see is that users are bit confuse on configuring EIGRP in name mode. So here is a blog gives you glimpse of EIGRP name mode configuration.

 

In traditional way we were configuring EIGRP like this,

 

We go to configuration mode and defining EIGRP with process number

 

R1#conf t

R1(config)#router eigrp 1

R1(config-router)#

 

After that if we have to run EIGRP on the interfaces then we have to specify each network with wildcard mask for every interface:

 

R1(config-router)#network 10.1.1.0 0.0.0.3

R1(config-router)#network 1.1.1.1 0.0.0.0

 

 

And for some the command like EIGRP authentication, defining Bandwidth to control EIGRP packets or to define EIGRP next-hop you have exit Router config mode and switch to interface mode as shown below:

 

R1(config-router)#exit

R1(config)#int fa0/0

R1(config-if)#ip authentication mode eigrp 1 md5

R1(config-if)#ip authentication key-chain eigrp 1 cisco

R1(config-if)#ip bandwidth-percent eigrp 1 75

 

This was what we discussed for IPv4 Eigrp. Now to run EIGRP for IPv6 we have to configure in different way define the IPv6 router process and run Eigrp under interface mode.

 

ipv6 router eigrp 1

eigrp router-id 10.1.1.1

no shut

!

Interface f0/0

ipv6 enabe

ipv6 eigrp 1

!

 

So In traditional way for every address family (IPv4/VRF/IPv6) you have to configure EIGRP separately .You have to switch config mode to interface mode, also another interesting point is that there was no way to configure VRF in traditional IPv6 EIGRP implementation but in “EIGRP Name Mode configuration” you can config all in one place, plus you have the option to run IPv6 Eigrp for VRF

 

Let’s discussed EIGRP name mode configuration in detail.

 

EIGRP named configuration is available in following IOS release and onwards:

 

15.0(1)M

 

12.2(33)SRE

 

12.2(33)XNE

 

Cisco IOS XE Release 2.5

 

If you are running any of the above IOS versions then you will see 2 options after you do question mark as shown. 

 

R2(config)#router eigrp ?

  <1-65535> Autonomous System

  WORD       EIGRP Virtual-Instance Name

 

To define Name mode configuration define word option as show below:

 

R2(config)#router eigrp CISCO

 

Unlike traditional way, EIGRP instance not create or it doesn't start running the moment following is configured on the router. The instance will be created when address-family and autonomous system number is configured for e.g.:

 

 

For IPv4:

 

R2(config-router)#address-family ipv4 unicast autonomous-system 1

 

For IPv4 VRF:

 

R2(config-router)#address-family ipv4 unicast vrf Customer_A autonomous-system 1

 

For IPv6:

 

R2(config-router)#address-family ipv6 unicast autonomous-system 1

 

For IPv6 VRF

 

R2(config-router)#address-family ipv6 unicast vrf site_A autonomous-system 1

 

With this Named mode, we can create a single Instance of EIGRP, which can be used for all address family type as shown above.

Another simplicity is if want to turn off the entire AS, you can use “shutdown” command under address-family to turn off the entire instance.

 

 

Named EIGRP has 3 configuration modes. These are:

 

    1) address-family configuration mode - (config-router-af)#

    2) address-family interface configuration mode - (config-router-af-interface)#

    3) address-family topology configuration mode - (config-router-af-topology)#

 

A) Address-family configuration mode:

 

In this mode, you can configure networks, EIGRP neighbor, EIGRP Router-id, metric etc. From this mode you can access the other two configuration modes used in EIGRP named configuration.

 

R2(config-router)#address-family ipv4 unicast autonomous-system 1

R2(config-router-af)#?

Address Family configuration commands:

  af-interface         Enter Address Family interface configuration

  default              Set a command to its defaults

  eigrp                EIGRP Address Family specific commands

  exit-address-family  Exit Address Family configuration mode

  help                 Description of the interactive help system

  maximum-prefix       Maximum number of prefixes acceptable in aggregate

  metric               Modify metrics and parameters for address advertisement

  neighbor             Specify an IPv4 neighbor router

  network              Enable routing on an IP network

  no                   Negate a command or set its defaults

  shutdown             Shutdown address family

  timers               Adjust peering based timers

  topology             Topology configuration mode

 

R2(config-router-af)#

 

B) Address-family interface configuration mode:

 

This mode takes all the interface specific commands that were previously configured on an actual interface (logical or physical) and moves them into the EIGRP configuration. EIGRP authentication, Bandwidth-percentage, split-horizon, and summary-address configuration are some of the options that are now configured here instead of in interface configuration mode.

 

R2(config-router-af)#af-interface fa0/0

R2(config-router-af-interface)#?

Address Family Interfaces configuration commands:

  authentication      authentication subcommands

  bandwidth-percent   Set percentage of bandwidth percentage limit

  bfd                 Enable Bidirectional Forwarding Detection

  dampening-change    Percent interface metric must change to cause update

  dampening-interval  Time in seconds to check interface metrics

  default             Set a command to its defaults

  exit-af-interface   Exit from Address Family Interface configuration mode

  hello-interval      Configures hello interval

  hold-time           Configures hold time

  next-hop-self       Configures EIGRP next-hop-self

  no                  Negate a command or set its defaults

  passive-interface   Suppress address updates on an interface

  shutdown            Disable Address-Family on interface

  split-horizon       Perform split horizon

  summary-address     Perform address summarization

 

R2(config-router-af-interface)#

 

In traditional way if we want run EIGRP on all interface we use "network 0.0.0.0 0.0.0.0" command. Here you can use “af-interface default” to function same.

 

R2(config-router-af)#af-interface default

R2(config-router-af-interface)#

 

C) Address-family topology configuration mode:

 

This mode provide several options which operates on EIGRP topology table .here you can define content like redistribution, distance, offset list, variance etc. To enter this mode, we need to go back to address-family configuration mode:

 

R2(config-router-af-interface)#exit

R2(config-router-af)#topology base

R2(config-router-af-topology)#?

Address Family Topology configuration commands:

  auto-summary         Enable automatic network number summarization

  default              Set a command to its defaults

  default-information  Control distribution of default information

  default-metric       Set metric of redistributed routes

  distance             Define an administrative distance

  distribute-list      Filter entries in eigrp updates

  eigrp                EIGRP specific commands

  exit-af-topology     Exit from Address Family Topology configuration mode

  fast-reroute         Configure Fast-Reroute

  maximum-paths        Forward packets over multiple paths

  metric               Modify metrics and parameters for advertisement

  no                   Negate a command or set its defaults

  offset-list          Add or subtract offset from EIGRP metrics

  redistribute         Redistribute IPv4 routes from another routing protocol

  snmp                 Modify snmp parameters

  summary-metric       Specify summary to apply metric/filtering

  timers               Adjust topology specific timers

  traffic-share        How to compute traffic share over alternate paths

  variance             Control load balancing variance

 

R2(config-router-af-topology)#

 

Comparison chart between Eigrp “traditional Configuration” and “Name mode Configuration”:

 

EIGRP Tradition way of Configuration

EIGRP Name Mode Configuration

int fa0/0

ip add 10.1.1.1 255.255.255.252

ip authentication mode eigrp 1 md5

ip authentication key-chain eigrp 1 cisco

ip bandwidth-percent eigrp 1 75 

ip hello eigrp 1 10

IPv6 enable

IPv6 eigrp 1

 

 

 

 

router eigrp 1

network 10.1.1.0 0.0.0.3

redistribute connected

 

 

ipv6 router eigrp 1

eigrp router-id 10.1.1.1

no shut

 

 

router eigrp 2

address-family ipv4 vrf CUST_A

network 0.0.0.0 0.0.0.0

 

 

"No IPv6 EIGRP support for VRF"

int fa0/0

ip add 10.1.1.1 255.255.255.252

IPv6 enable

 

 

router eigrp CISCO

!

address-family ipv6 unicast autonomous-system 1

  !

  topology base

  exit-af-topology

  eigrp router-id 1.1.1.1

exit-address-family

!

address-family ipv4 unicast autonomous-system 1

  !

  af-interface FastEthernet0/0

   authentication mode md5

   authentication key-chain cisco

   bandwidth-percent 75

   hello-interval 10

  exit-af-interface

  !

  topology base

   redistribute connected

  exit-af-topology

exit-address-family

!

address-family ipv6 unicast vrf CUST_B autonomous-system 2

  !

  topology base

  exit-af-topology

exit-address-family

!

address-family ipv4 unicast vrf CUST_A autonomous-system 2

  !

af-interface default

!

  topology base

  exit-af-topology

exit-address-family

 

If you enjoy reading this blog and find it informative, please share your comments with us and also let us know what Technical topic you want to see on the community

7 Comments
Rob Miller
Level 4
Level 4

Thank you!!!

 

This did a MUCH better job of explaining configuration of eigrp named than what I was able to get from the official documentation.  Was looking for how to redistribute (static specifically), and I could only find classic AS redistribution examples elsewhere.

dionilde.costa
Level 1
Level 1

It's a good explanation. Thanks for posting!

I can´t setup af-int commands for an interface, member of the same vrf.

interface TenGigabitEthernet0/0/0.714
 encapsulation dot1Q 714
 vrf forwarding cisco
 ip address 10.2.100.1 255.255.255.252
router eigrp cisco
 !
 address-family ipv4 unicast autonomous-system 10
  !
  topology base
  exit-af-topology
 exit-address-family
m-3(config-router-af)# af-interface TenGigabitEthernet0/0/0.714
%EIGRP: Interface TenGigabitEthernet0/0/0.714 not a member of this routing table

Thanks

Guido

my fault. EIGRP wasn't on the same VRF.

This is the correct way:

router eigrp virtual-cisco
 !
 address-family ipv4 unicast vrf cisco autonomous-system 1

 af-interface TenGigabitEthernet0/0/0.714
  summary-address 10.60.0.0 255.255.0.0
  summary-address 192.168.0.0 255.255.0.0

I'm using Named EIGRP and i need to redistribute from an AS to another but I´m not getting the redistribution done!. For this example I have the network 10.10.6.0 on AS 1 VRF GRE and need the route to be redistributed to AS 110 VRF MPLS.

 

What i'm missing??

 

here is my configuration.

 

router eigrp MPLS
!
address-family ipv4 unicast vrf MPLS autonomous-system 110
!
af-interface GigabitEthernet2
summary-address 10.10.0.0 255.255.0.0
exit-af-interface
!
topology base
redistribute connected
redistribute static
redistribute eigrp 1
exit-af-topology
network 10.8.3.0 0.0.0.7
exit-address-family
!
address-family ipv4 unicast vrf GRE autonomous-system 1
!
topology base
redistribute eigrp 110
exit-af-topology
network 192.168.189.0
network 192.168.190.0
exit-address-family

 

 

MPLS_1#show ip route vrf GRE 10.10.6.1

Routing Table: GRE
Routing entry for 10.10.6.0/24
Known via "eigrp 1", distance 90, metric 38160000, type internal
Redistributing via eigrp 1
Last update from 192.168.189.14 on Tunnel23, 00:14:09 ago
Routing Descriptor Blocks:
* 192.168.189.14, from 192.168.189.14, 00:14:09 ago, via Tunnel23
Route metric is 38160000, traffic share count is 1
Total delay is 55000 microseconds, minimum bandwidth is 512 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
MPLS_1#
MPLS_1#
MPLS_1#show ip route vrf MPLS 10.10.6.1

Routing Table: MPLS
% Subnet not in table
MPLS_1#

MPLS_1#show ip route vrf MPLS 10.10.0.0

Routing Table: MPLS
% Subnet not in table
MPLS_1#

salmaan
Level 1
Level 1

Hi ashirkar

 

router eigrp CISCO

!

address-family ipv6 unicast autonomous-system 1

  !

  topology base

  exit-af-topology

  eigrp router-id 1.1.1.1

exit-address-family

 

 

In the above example why do we enter topology base and then exit from it immediately ??

 

 topology base

  exit-af-topology

 

What purpose does it serve ? I am still trying to learn this stuff .. 

 

Any explanantion would be highly appretiated 

 

Regards

Salmaan

 

 

 

 

You can configure a lot of stuff inside of the topology base section and if you have nothing in there it show the configuration as you said.

 

example:

!

topology base
redistribute connected
redistribute static
redistribute eigrp 1
exit-af-topology

!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: