cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

MPLS unable to ping from CE1 to CE2 but route is OK

293
Views
0
Helpful
2
Comments
Beginner

I cannot ping from R5 to R6 but Routing table have the route to go. What could be the issues?

 

R3 (PE1)

mpls label range 300 399
mpls ip
mpls ldp router-id Loopback0

 

ip vrf ygn
rd 100:1
route-target export 100:10
route-target import 100:20

interface FastEthernet0/0
ip vrf forwarding ygn
ip address 10.1.1.2 255.255.255.0
duplex full
!

router bgp 100
bgp router-id 3.3.3.3
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 192.168.4.1 remote-as 100
neighbor 192.168.4.1 update-source Loopback0
!
address-family ipv4
neighbor 192.168.4.1 activate
exit-address-family
!
address-family vpnv4
neighbor 192.168.4.1 activate
neighbor 192.168.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf ygn
redistribute eigrp 1
exit-address-family


router eigrp 1
!
address-family ipv4 vrf ygn autonomous-system 1
redistribute bgp 100 metric 1 1 1 1 1
network 10.1.1.0 0.0.0.255
exit-address-family
!

--------------------------------------------------------------------------------------
R4(PE2)
mpls label range 400 499
mpls ip
mpls ldp router-id Loopback0

ip vrf mdy
rd 100:2
route-target export 100:20
route-target import 100:10
!

interface FastEthernet0/0
ip vrf forwarding mdy
ip address 10.1.5.1 255.255.255.0
duplex full
!

router bgp 100
bgp router-id 4.4.4.4
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 192.168.3.1 remote-as 100
neighbor 192.168.3.1 update-source Loopback0
!
address-family ipv4
neighbor 192.168.3.1 activate
exit-address-family
!
address-family vpnv4
neighbor 192.168.3.1 activate
neighbor 192.168.3.1 send-community extended
exit-address-family
!
address-family ipv4 vrf mdy
redistribute eigrp 1
exit-address-family
!

router eigrp 1
!
address-family ipv4 vrf mdy autonomous-system 1
redistribute bgp 100 metric 1 1 1 1 1
network 10.1.5.0 0.0.0.255
exit-address-family
!

 

Verification the LDP work

R3(config-router)#do traceroute 192.168.4.1
Type escape sequence to abort.
Tracing the route to 192.168.4.1
VRF info: (vrf in name/id, vrf out name/id)
1 10.1.2.2 [MPLS: Label 103 Exp 0] 68 msec 116 msec 96 msec
2 10.1.3.2 [MPLS: Label 203 Exp 0] 64 msec 44 msec 108 msec
3 10.1.4.2 192 msec 96 msec *

 

Verification the MP-BGP

R3(config-router)#do sh bgp vpnv4 unicast vrf ygn
BGP table version is 27, local router ID is 3.3.3.3
Route Distinguisher: 100:1 (default for vrf ygn)
*> 10.1.1.0/24 0.0.0.0 0 32768 ?
*>i 10.1.5.0/24 192.168.4.1 0 100 0 ?
*> 172.16.1.0/24 10.1.1.1 156160 32768 ?
*>i 172.16.2.0/24 192.168.4.1 156160 100 0 ?

 

Verification Redistribution

R4#sh bgp vpnv4 unicast vrf mdy
BGP table version is 23, local router ID is 4.4.4.4
Route Distinguisher: 100:2 (default for vrf mdy)
*>i 10.1.1.0/24 192.168.3.1 0 100 0 ?
*> 10.1.5.0/24 0.0.0.0 0 32768 ?
*>i 172.16.1.0/24 192.168.3.1 156160 100 0 ?
*> 172.16.2.0/24 10.1.5.2 156160 32768 ?

 

 

R5#sh ip route eigrp

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.5.0/24 [90/30720] via 10.1.1.2, 00:55:18, FastEthernet0/0
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 172.16.2.0/24 [90/158720] via 10.1.1.2, 00:55:18, FastEthernet0/0

 

R6#sh ip route eigrp

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.1.0/24 [90/30720] via 10.1.5.1, 00:49:19, FastEthernet0/0
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D 172.16.1.0/24 [90/158720] via 10.1.5.1, 00:49:19, FastEthernet0/0

 

 

2 Comments
Beginner

Routing tables look good.

When you ping from R5 to R6, are you using a particular source IP address or interface instead of 10.0.5.x or 172.16.1.x?
Can you post the output of the ping failure?
If possible, can you do a packet capture on the R5-R3 link?

I'll be brief.

 

Can you do a do traceroute 192.168.4.1 vrf ygn (this is where YGN is the source vrf as an example)

I think you're missing the VRF statements to specify the source of the traffic.

See how you go utilising the source and destination VRF's

 

another easy one could be:

ROUTER(config)do traceroute

It will prompt you for the source, destination, vrf's etc.

Same thing for ping.

 

Hope it helps!

Alex Schoneveld


Content for Community-Ad