cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

3 ways to redistribute default static route into EIGRP in Nexus 7000

14296
Views
14
Helpful
0
Comments

Default static route redistribution into EIGRP in Nexus 7000

3  different ways of redistribution static default route into EIGRP with  Nexus 7000 is outlined here. Just can be used as a quick reference guide  to answer simple customer queries.

My topology is back to back Nexus switches.

Master (Eth7/16) ------(Eth3/16) N7K-1

EIGRP is running between then and here are the configs.

Master Nexus

interface Ethernet7/16

  ip address 99.1.1.1/24

  ip router eigrp 1

  no shutdown

master# sh run eigrp

!Command: show running-config eigrp

!Time: Fri Apr 19 01:54:52 2013

version 6.1(3)

feature eigrp

router eigrp 1

  default-information originate

interface loopback0

  ip router eigrp 1

interface loopback7

  ip router eigrp 1

interface Ethernet7/16

  ip router eigrp 1

master# sh ip eigrp neighbors

IP-EIGRP neighbors for process 1 VRF default

H   Address                 Interface       Hold  Uptime  SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   99.1.1.2                Eth7/16         14   00:44:10  1    200   0   17

master#

master# sh runn | i "ip route"

ip route 0.0.0.0/0 172.17.7.254

master#

master# sh ip route eigrp

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

2.2.2.2/32, ubest/mbest: 1/0

    *via 99.1.1.2, Eth7/16, [90/130816], 00:46:24, eigrp-1, internal

master#

N7K-1 Nexus Configs

N7K-1# show runn inter eth3/16

!Command: show running-config interface Ethernet3/16

!Time: Fri Apr 19 05:13:14 2013

version 6.1(2)

interface Ethernet3/16

  ip address 99.1.1.2/24

  ip router eigrp 1

  no shutdown

N7K-1#

N7K-1# sh run eigrp

!Command: show running-config eigrp

!Time: Fri Apr 19 05:13:18 2013

version 6.1(2)

feature eigrp

router eigrp 1

interface loopback0

  ip router eigrp 1

interface loopback7

  ip router eigrp 1

interface Ethernet3/16

  ip router eigrp 1

N7K-1#

N7K-1# sh ip eigrp neighbors

IP-EIGRP neighbors for process 1 VRF default

H   Address                 Interface       Hold  Uptime  SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   99.1.1.1                Eth3/16         13   00:46:11  1    200   0   17

N7K-1#

N7K-1# sh ip route eigrp

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

1.1.1.1/32, ubest/mbest: 1/0

    *via 99.1.1.1, Eth3/16, [90/130816], 00:46:18, eigrp-1, internal

N7K-1#

Option 1 (using default-information originate command)

In the above setup you can see in ‘master’ Nexus I have a default  static route “ip route 0.0.0.0/0 172.17.7.254” and show ip route static  will show that it is installed in the ip routing table as below.

master# sh ip route static

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

0.0.0.0/0, ubest/mbest: 1/0

    *via 172.17.7.254, [1/0], 00:15:14, static =è Route installed fine in RIB

master#

At this point of time there is no EiGRP default route in ‘N7K-1’ Nexus switch.

N7K-1# sh ip route eigrp

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

1.1.1.1/32, ubest/mbest: 1/0

    *via 99.1.1.1, Eth3/16, [90/130816], 00:46:18, eigrp-1, internal ======è No ‘0.0.0.0’ route present in the RIB table

Now, I will go ahead and add a default-information originate command to EIGRP on ‘master’ Nexus.

master(config)# router eigrp 1

master(config-router)# default-information originate

As soon as I add it, you can see a default route present in the peer EIGRP table.

N7K-1# sh ip route eigrp-1

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

0.0.0.0/0, ubest/mbest: 1/0

    *via 99.1.1.1, Eth3/16, [170/51456], 00:01:42, eigrp-1, external ================è A static default route is present now.

1.1.1.1/32, ubest/mbest: 1/0

    *via 99.1.1.1, Eth3/16, [90/130816], 00:52:13, eigrp-1, internal

N7K-1#

Option 2 (using default-information originate always command)

Now I will go ahead and remove the default-information originate command and the static route.

master(config)# router eigrp 1

master(config-router)# no default-information  originate

master(config-router)# no ip route 0.0.0.0/0 172.17.7.254

Now, we will see that the default route will be removed from the peer EIGRP table.

N7K-1# sh ip route eigrp-1

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

1.1.1.1/32, ubest/mbest: 1/0 ======================è No 0.0.0.0 route present.

    *via 99.1.1.1, Eth3/16, [90/130816], 00:54:56, eigrp-1, internal

N7K-1#

I will go ahead and add the default-information originate always command.

master(config)# router eigrp 1

master(config-router)# default-information originate always

Now, I will see that the default route will be populated in the peer EIGRP table fine.

N7K-1# sh ip route eigrp-1

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

0.0.0.0/0, ubest/mbest: 1/0 ======================================è Default route came back again.

    *via 99.1.1.1, Eth3/16, [170/51456], 00:00:09, eigrp-1, external

1.1.1.1/32, ubest/mbest: 1/0

    *via 99.1.1.1, Eth3/16, [90/130816], 00:55:52, eigrp-1, internal

N7K-1#

The difference between the command ‘default information-originate’  and ‘default-information originate always’ is that the first one will  redistribute a default route only if it is configured in the switch and  the second one will advertise a default route even if there is not one  configured. So, depending on our situation we can use either or the  command to suit our needs.

Option 3 (Using a redistribute and route-map/prefix-lists)

If you do not want to use the above option and want to be very  specific about choosing which default route to get redistributed, then  this option will work best for you. In Nexus, unlike the native IOS we  have to use a route-map always to redistribute the route. In the  route-map we need to use a prefix-list to match our default route and  get it redistributed. I believe ACL cannot be used.

Now, I will go ahead and remove the above commands, add the ip  default route again and configure a prefix-list to match a default route  and configure a route-map to match the prefix-list. Then use the  redistribute command in EIGRP to advertise the route to its peer.

master# conf

Enter configuration commands, one per line.  End with CNTL/Z.

master(config)#

master(config)# ip route 0.0.0.0/0 172.17.7.254

master(config)#

master(config)# router eigrp 1

master(config-router)# no default-information originate always

master(config)#

master(config)#  ip prefix-list static-default seq 5 permit 0.0.0.0/0

master(config)# route-map static-default permit 5

master(config-route-map)# match ip address prefix-list static-default

master(config-route-map)#

master(config-route-map)# router eigrp 1

master(config-router)# redistribute static route-map static-default

master(config-router)#

master#

Now, you will see the default route again in the peer router.

N7K-1# sh ip route eigrp-1

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

0.0.0.0/0, ubest/mbest: 1/0

    *via 99.1.1.1, Eth3/16, [170/51456], 00:02:20, eigrp-1, external =====è Static route seen again.

1.1.1.1/32, ubest/mbest: 1/0

    *via 99.1.1.1, Eth3/16, [90/130816], 01:06:55, eigrp-1, internal

N7K-1#

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards