cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco 2911 Stuck in ROMMON After CF Format

2441
Views
0
Helpful
2
Comments

So I believe I know what I did that caused this issue, however I don't know how to resolve this. After attempting to reset a 2911 router, I was to change the registry to rommon once and login in. After some initial configurations, I saved the config twice and reloaded. To my surprise, the router reset in its factory defaults, thus my settings had disappeared. I couldn't figure out the issue, so I tried formatting flash0:, the only CF that came with the device.

Now, every time i reload the router I'm forced into rommon mode. I've tried confreg 0x2142 and 0x2102 to yield no results. My guess is there is no longer a startup file save on the router, so it is unable to boot to any image.

Can I find a backup default startup-config on the machine, or where can I find one? Or am I just approaching the issue incorrectly?

Any help is dearly appreciated.

Comments

Hi ,

 

If you change your config register as 0x2142 then router will bypass NVRAM content and boot with default config . so you dont see running config as your saved configuration .. If you do write memory then default configuration will replace your start-up config. thats why even with 0x2102 also router boots with default configuration.

 

So right method is first change your config registor to 0x2102  and apply the configuration what your require and do write memory.

 

Reload the router and see if this fix the issue .

Community Member

Hello Ty

 

It looks as though you have deleted the system IOS image on the CF - this would have been done when you formatted the Flash using the format flash command.

 

As there is no IOS image on the router it is booting straight to Rommon mode. You can recover from this provided that you have a backup of the ios image on your computer. You will need to setup you computer as a tftp server (download TFTP32 - a free tftp server software deamon for windows) - place the IOS of your router in the TFTP root directory of TFTP32. Connect your pc to the 2911 using a crossover ethernet cable.

Set your computers lan interface to a fixed ip address (say 10.0.0.1/24), then from the Rommon of the router carry out the following commands =

 

rommon 16 > IP_ADDRESS=10.0.0.254
     rommon 17 > IP_SUBNET_MASK=255.255.255.0
     rommon 18 > DEFAULT_GATEWAY=10.0.0.254
     rommon 19 > TFTP_SERVER=10.0.0.1
     rommon 20 > TFTP_FILE= type in full file name of your IOS here (inc .bin extension)
     rommon 21 > tftpdnld

 

provided that you have full connectivity then you should see the file start to go across from your computer to the router.

 

when complete issue the reload command, then once loaded you can change the config register from within the ios (0x2142), reload again, and hopefully your original config should be their ready and waiting.

 

good luck, if you have any more problems post here and we will try and trouble-shoot it together.

 

Paul

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards