cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

CISCO SD-WAN Software Upgrade (cEdge/vEdge)

327
Views
0
Helpful
0
Comments

CISCO SD-WAN

Steps to upgrade cEdge/vEdge routers

 

In the next document, we'll explain the steps to be able to upgrade cEdge/vEdge devices.

It is very important to consider that to upgrade the operative system, we must verify the version of the controllers. (vManage,vBond,vSmart).

In the next link we can verify the compatibility matrix depending on the version in which we have our controllers

https://www.cisco.com/c/en/us/support/routers/sd-wan/products-release-notes-list.html

 

 

For example, if we have the controllers running on release 19.3.x, we must have the Edge devices on the following versions.

Important: If we do not have the versions according to the compatibility matrix, we can generate operational problems.

 

 

Compatibility Matrix.png

 

Important: If we do not have the versions according to the compatibility matrix, we can generate operational problems.

 

For upgrade process we will need to use the next steps


Add New Software Images to the Repository of vManage
Upgrade the Software Image
Upgrade a Software Image from the CLI

 

If we need to upgrade the controllers, is necessary to follow the best practices:


1.- vManage

2.- vBond

3.- vSmart

4.- vEdge/cEdge

 

Best Practices for Software Upgrades

Upgrade the software from the vManage NMS rather than from the CLI.

If you are upgrading the software image on a remote vManage NMS, the overlay network must already be up and operational. If you are upgrading all devices in the overlay network, you must perform the upgrade in the following order: 

  1. Upgrade the vManage NMSs.
  2. Upgrade the vBond orchestrators.
  3. Upgrade one-half of the vSmart controllers.
  4. Have the upgraded vSmart controllers run for at least 1 day (24 hours) to ensure that the Cisco vEdge devices and the overlay network are stable and running as expected.
  5. Upgrade the remainder of the vSmart controllers.
  6. Upgrade 10 percent of the vEdge routers. For multi-router sites, it is recommended that you upgrade only one router per site.
  7. Have the upgraded vEdge routers run for at least 1 day (24 hours) to ensure that the Cisco SD-WAN devices and the overlay network are stable and running as expected.
  8. Upgrade the remainder of vEdge routers.

If the new software images are located on an FTP server, ensure that the FTP server can handle concurrent file transfers.

If the new software images are in the image repository on the vManage NMS, ensure that the WAN in which the vManage NMS is located has sufficient capacity for concurrent file transfers.

You cannot include the vManage NMS in a group software upgrade operation. You must upgrade and reboot the vManage server by itself.

When you are setting a software image to be the default software image, activate it first, before making it the default image

 

To upgrade the software running on the devices in the overlay network, you must first obtain the new software packages from the Cisco SD-WAN website.

https://www.cisco.com/c/en/us/support/routers/index.html

 

For more details about upgrade best practices, please use the next link:

https://www.cisco.com/c/en/us/td/docs/routers/sdwan/configuration/sdwan-xe-gs-book/hardware-and-software-installation.html

 

 

 

Frequently Asked Questions (FAQs)

 

1.- Q: How often do I need to upgrade my SD-WAN devices?

 

There is no specific date to perform the upgrades, but it is important to validate that the version is not declared as "Deferred".

When Developer team detects a version with many software issues, in the download section is placed in the differed releases section.

When this happens, it is not possible to download and we can see a banner with this notification.

 

For more more details, please visit the following link and select the hardware in order to validate the available releases, https://www.cisco.com/c/en/us/support/routers/index.html

 

2.- Q: How should I upgrade my cEdge/vEdge and controllers?

 

We need to follow the next best ptractice

1.- vManage

2.- vBond

3.- vSmart

4.- vEdge/cEdge

 

For more details please visit the following link

 

https://www.cisco.com/c/en/us/td/docs/routers/sdwan/configuration/sdwan-xe-gs-book/hardware-and-software-installation.html

 

 

 

 

3.- Q: If i running a Deferred release, my network could be impacted?

 

Yes, running a deferred release is not recommended and can cause that device has an abnormal behavior caused by a software defect.

The latest versions on download section, have improvements and are more stable.

 

4.-  Q: If i running old version 16.2.10, it possible to upgrade directly to 19.2.2?

 

No, it’s not possible to do one upgrade directly to 19.2.2

It’s necessary to first upgrade to an intermediate release like 17.2.10 and then upgrade to 19.2.2

 

 

 

5.- Q: Do I need specific hardware to install SD WAN software?

 

Yes, not all Cisco routers support SD-WAN software.

 

You can do the migration from traditional IOS-XE to IOS-XE SD WAN software on the following devices,

 

ISR1000

ISR4000

ASR1000

 

For example, SD-WAN is not supported on CISCO 2900 or 3900 series.