cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

OSPF "INIT/DROTHER" error

1720
Views
0
Helpful
7
Comments

Hi everyone.

I have a problem in my Network.

So i have 3 routers and a firewall in my topology. I have configured OSPF and all routers works expect R3 (see in the image below)

When I watch my neignbor in R3 it says :

192.168.7.7 1 INIT/DROTHER 00:00:37 10.0.20.1 FastEthernet0/0.

Can someone help me with this ? 

Thanks in advance.

Comments
VIP Mentor
Can you post the configuration of R3 ? talso R1 neighbour interface information to look how you configured. sh ip ospf int brief sh ip ospf neigh sh ip protocol
Beginner

Sure. Here R2 configuration

hostname R2
!
logging queue-limit 100
enable secret 5 $1$D3HU$a/MZeLDNmwHl6giKk89bT1
!
ip subnet-zero
!
!
ip domain name tiko.lan
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
ip address 192.168.2.2 255.255.255.0
!
interface FastEthernet0/0
description Link vers R1
ip address 10.0.20.2 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
description Link vers LAN
no ip address
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1.20
description LANSB VLAN20
encapsulation dot1Q 20
ip address 192.168.20.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/1.25
description LANSB VLAN25
encapsulation dot1Q 25
ip address 192.168.25.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/1.30
encapsulation dot1Q 30
ip address 192.168.1.253 255.255.255.0
ip nat inside
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 2
router-id 192.168.2.2
log-adjacency-changes
network 10.0.20.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.25.0 0.0.0.255 area 0
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip http server
ip classless
!
!
!
access-list 1 permit 192.168.20.0 0.0.0.255
access-list 1 permit 192.168.25.0 0.0.0.255
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 172.16.1.0 0.0.0.255
access-list 1 permit 10.0.16.0 0.0.0.3
access-list 1 permit 10.0.17.0 0.0.0.3
access-list 1 permit 10.0.18.0 0.0.0.3
access-list 1 permit 10.0.19.0 0.0.0.3
access-list 1 permit 10.0.20.0 0.0.0.3
access-list 1 permit 10.113.23.0 0.0.0.255
access-list 1 permit any
!
!
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
password cisco
login
line aux 0
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end

 

R1#sh ip ospf interface brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Gi0/2 2 0 10.0.20.1/30 1 DR 0/0
Gi0/0 2 0 10.0.19.1/30 1 DR 0/1
Gi0/1 2 0 10.0.18.1/30 1 BDR 1/1

 

R1#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.6.6 1 INIT/DROTHER 00:00:33 10.0.19.2 GigabitEthernet0/0
192.168.3.3 1 FULL/DR 00:00:32 10.0.18.2 GigabitEthernet0/1

R1#sh ip protocols
Routing Protocol is "ospf 2"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 192.168.7.7
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.0.18.0 0.0.0.3 area 0
10.0.19.0 0.0.0.3 area 0
10.0.20.0 0.0.0.3 area 0
Routing Information Sources:
Gateway Distance Last Update
192.168.5.5 110 00:43:25
192.168.3.3 110 00:43:25
192.168.2.2 110 01:18:19
192.168.7.7 110 00:43:25
Distance: (default is 110)

Cisco Employee

Hi,

 

From the topology provided, I believe OSPF between R1 and R3 is not coming up. If this is the case, then can you provide with the following

 

From R1

ping 224.0.0.5

ping <R3-IP> size 1500 df 

show interface x/y --- for interface connecting to R3

show ip ospf interface

show ip ospf nei

Interface and OSPF configuration

 

From R3

ping 224.0.0.5

ping <R1-IP> size 1500 df 

show interface x/y --- for interface connecting to R1

show ip ospf interface

show ip ospf nei

Interface and OSPF configuration

 

FROM R2

ping 224.0.0.5

ping <R1-IP> size 1500 df

show interface x/y --- for interface connecting to R1

show ip ospf interface

show ip ospf nei

Interface and OSPF configuration

 

Regards

 

 

 

 

Beginner

Sure :

R1#ping 224.0.0.5

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:

Reply to request 0 from 10.0.18.2, 1 ms
Reply to request 0 from 10.0.20.2, 1 ms

 

R1#ping 10.0.20.2 size 1500 df-bit

Type escape sequence to abort.
Sending 5, 1500-byte ICMP Echos to 10.0.20.2, timeout is 2 seconds:
Packet sent with the DF bit set
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 

R1#show interfaces gigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up
Hardware is BCM1250 Internal MAC, address is 0014.f1f5.3819 (bia 0014.f1f5.3819)
Description: Link vers R2
Internet address is 10.0.20.1/30
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, media type is RJ45
output flow-control is XON, input flow-control is XON
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:05, output 00:00:06, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
292373 packets input, 30322432 bytes, 0 no buffer
Received 132 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 74656 multicast, 0 pause input
0 input packets with dribble condition detected
363720 packets output, 306413229 bytes, 0 underruns
50 output errors, 0 collisions, 2 interface resets
0 babbles, 0 late collision, 0 deferred
50 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

 

R1#show ip ospf interface
GigabitEthernet0/2 is up, line protocol is up
Internet Address 10.0.20.1/30, Area 0
Process ID 2, Router ID 192.168.7.7, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.7.7, Interface address 10.0.20.1
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:09
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 2
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
GigabitEthernet0/0 is up, line protocol is up
Internet Address 10.0.19.1/30, Area 0
Process ID 2, Router ID 192.168.7.7, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.7.7, Interface address 10.0.19.1
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:09
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
GigabitEthernet0/1 is up, line protocol is up
Internet Address 10.0.18.1/30, Area 0
Process ID 2, Router ID 192.168.7.7, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.7.7, Interface address 10.0.18.1
Backup Designated router (ID) 192.168.3.3, Interface address 10.0.18.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:09
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.168.3.3 (Backup Designated Router)
Suppress hello for 0 neighbor(s)

 

R1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.6.6 1 INIT/DROTHER 00:00:32 10.0.19.2 GigabitEthernet0/0
192.168.3.3 1 FULL/BDR 00:00:39 10.0.18.2 GigabitEthernet0/1

 

interface Loopback0
ip address 192.168.7.7 255.255.255.0
!
interface GigabitEthernet0/0
description Link vers Pfsense
ip address 10.0.19.1 255.255.255.252
ip nat outside
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
description Link vers R3
ip address 10.0.18.1 255.255.255.252
ip nat inside
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/2
description Link vers R2
ip address 10.0.20.1 255.255.255.252
ip nat inside
duplex auto
speed auto
media-type rj45
negotiation auto
!
router ospf 2
router-id 192.168.7.7
log-adjacency-changes
network 10.0.18.0 0.0.0.3 area 0
network 10.0.19.0 0.0.0.3 area 0
network 10.0.20.0 0.0.0.3 area 0

 

R3#ping 224.0.0.5

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:

Reply to request 0 from 10.0.16.2, 1 ms
Reply to request 0 from 10.0.18.1, 1 ms

 

R3#ping 10.0.18.1 size 1500 df-bit

Type escape sequence to abort.
Sending 5, 1500-byte ICMP Echos to 10.0.18.1, timeout is 2 seconds:
Packet sent with the DF bit set
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 

R3#show interfaces g0/1
GigabitEthernet0/1 is up, line protocol is up
Hardware is BCM1250 Internal MAC, address is 0012.440a.341a (bia 0012.440a.341a)
Description: LINK VERS R1
Internet address is 10.0.18.2/30
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is RJ45
output flow-control is XON, input flow-control is XON
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:02, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 7000 bits/sec, 2 packets/sec
5 minute output rate 5000 bits/sec, 2 packets/sec
425564 packets input, 313071353 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 65204 multicast, 0 pause input
0 input packets with dribble condition detected
383417 packets output, 65495683 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
0 babbles, 0 late collision, 0 deferred
4 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

 

R3#show ip ospf interface
GigabitEthernet0/0.100 is up, line protocol is up
Internet Address 192.168.1.253/24, Area 0
Process ID 2, Router ID 192.168.3.3, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.3.3, Interface address 192.168.1.253
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Index 5/5, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
GigabitEthernet0/0.15 is up, line protocol is up
Internet Address 192.168.15.254/24, Area 0
Process ID 2, Router ID 192.168.3.3, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.3.3, Interface address 192.168.15.254
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Index 4/4, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
GigabitEthernet0/0.10 is up, line protocol is up
Internet Address 192.168.10.254/24, Area 0
Process ID 2, Router ID 192.168.3.3, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.3.3, Interface address 192.168.10.254
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
GigabitEthernet0/2 is up, line protocol is up
Internet Address 10.0.16.1/30, Area 0
Process ID 2, Router ID 192.168.3.3, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 192.168.5.5, Interface address 10.0.16.2
Backup Designated router (ID) 192.168.3.3, Interface address 10.0.16.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.168.5.5 (Designated Router)
Suppress hello for 0 neighbor(s)
GigabitEthernet0/1 is up, line protocol is up
Internet Address 10.0.18.2/30, Area 0
Process ID 2, Router ID 192.168.3.3, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 192.168.7.7, Interface address 10.0.18.1
Backup Designated router (ID) 192.168.3.3, Interface address 10.0.18.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 192.168.7.7 (Designated Router)
Suppress hello for 0 neighbor(s)

 

R3#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.5.5 1 FULL/DR 00:00:39 10.0.16.2 GigabitEthernet0/2
192.168.7.7 1 FULL/DR 00:00:34 10.0.18.1 GigabitEthernet0/1

 

interface Loopback0
ip address 192.168.3.3 255.255.255.0
!
interface Tunnel1
ip address 172.16.1.3 255.255.255.0
ip mtu 1400
ip nat inside
ip tcp adjust-mss 1360
tunnel source 10.0.18.2
tunnel destination 10.0.17.2
!
interface GigabitEthernet0/0
description LAN
no ip address
ip nat inside
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.254 255.255.255.0
ip nat inside
!
interface GigabitEthernet0/0.15
encapsulation dot1Q 15
ip address 192.168.15.254 255.255.255.0
ip nat inside
!
interface GigabitEthernet0/0.100
description VLAN SRV
encapsulation dot1Q 100
ip address 192.168.1.253 255.255.255.0
ip nat inside
!
interface GigabitEthernet0/1
description LINK VERS R1
ip address 10.0.18.2 255.255.255.252
ip nat outside
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/2
description LINK VERS DMZ
ip address 10.0.16.1 255.255.255.252
ip nat outside
duplex auto
speed auto
media-type rj45
no negotiation auto
!
router ospf 2
router-id 192.168.3.3
log-adjacency-changes
network 10.0.16.0 0.0.0.3 area 0
network 10.0.18.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
network 192.168.15.0 0.0.0.255 area 0

 

R2#ping 224.0.0.5

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:

Reply to request 0 from 10.0.20.1, 1 ms

 

R2#ping 10.0.20.1 size 1500 df-bit

Type escape sequence to abort.
Sending 5, 1500-byte ICMP Echos to 10.0.20.1, timeout is 2 seconds:
Packet sent with the DF bit set
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

R2#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
Hardware is Gt96k FE, address is 0015.fac3.7770 (bia 0015.fac3.7770)
Description: Link vers R1
Internet address is 10.0.20.2/30
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:08, output 00:00:07, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1049 packets input, 151909 bytes
Received 987 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
1067 packets output, 131329 bytes, 0 underruns
0 output errors, 0 collisions, 6 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

R2#show ip ospf interface
FastEthernet0/1.25 is up, line protocol is up
Internet Address 192.168.25.254/24, Area 0
Process ID 2, Router ID 192.168.2.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.2.2, Interface address 192.168.25.254
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:04
Index 4/4, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
FastEthernet0/1.20 is up, line protocol is up
Internet Address 192.168.20.254/24, Area 0
Process ID 2, Router ID 192.168.2.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.2.2, Interface address 192.168.20.254
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
FastEthernet0/1.30 is up, line protocol is up
Internet Address 192.168.1.253/24, Area 0
Process ID 2, Router ID 192.168.2.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.2.2, Interface address 192.168.1.253
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
FastEthernet0/0 is up, line protocol is up
Internet Address 10.0.20.2/30, Area 0
Process ID 2, Router ID 192.168.2.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.2.2, Interface address 10.0.20.2
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:02
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)

 

R2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
192.168.7.7 1 INIT/DROTHER 00:00:37 10.0.20.1 FastEthernet0/0

 

interface Loopback0
ip address 192.168.2.2 255.255.255.0
!
interface FastEthernet0/0
description Link vers R1
ip address 10.0.20.2 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
description Link vers LAN
no ip address
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1.20
description LANSB VLAN20
encapsulation dot1Q 20
ip address 192.168.20.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/1.25
description LANSB VLAN25
encapsulation dot1Q 25
ip address 192.168.25.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/1.30
encapsulation dot1Q 30
ip address 192.168.1.253 255.255.255.0
ip nat inside
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 2
router-id 192.168.2.2
log-adjacency-changes
network 10.0.20.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
network 192.168.25.0 0.0.0.255 area 0

 

Regards.

Beginner

have you tried changing the OSPF interfaces from broadcast to point to point


@MrMaregaTech wrote:

Hi everyone.

I have a problem in my Network.

So i have 3 routers and a firewall in my topology. I have configured OSPF and all routers works expect R3 (see in the image below)

When I watch my neignbor in R3 it says :

192.168.7.7 1 INIT/DROTHER 00:00:37 10.0.20.1 FastEthernet0/0.

Can someone help me with this ? 

Thanks in advance.



Cisco Employee

 

From the outputs , you shared I can see the following

1. OSPF between R1 and R3 is Up and working fine
2. OSPF between R1 and R2 is down. It is showing as INIT state on R2 but nothing on R1
3. OSPF between R1 and FW is down. It is showing as INIT state on R1

ON R1
=====


R1#ping 224.0.0.5

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:

Reply to request 0 from 10.0.18.2, 1 ms
Reply to request 0 from 10.0.20.2, 1 ms

1. We get a response to multicast ping from R2 and R1
2. We do NOT get response from firewall. This means either our UDP packets are not reaching the firewall or the firewall is dropping teh UDP packets being received from r1
3. Also we see that R1 is showing in INIT state for OSPF neighorship with FW. This means UDP hellos orignated and coming from FW are reaching us

Check for any policy that is blocking UDP connectivity between R1 and FW

4. Unicast and multicast ping from R1 to R2 is working fine

 


ON R2
=====

1.Unicast and multicast ping from R2 to R1 is working fine. This means that there is no L1/L2 issue between R1 and R2
2. OSPF is showing as INIT state on R2. This means that the OSPF hellos from R1 are reaching R2
3. There is no OSPF state on R1 for R2. This means OSPF hellos from R2 are not processed by R1 or are not received by it.

You can try to chnage the mode to "point-to-point" between R1 and R2 and check it it helps

Can you provide with the following from R1,R2 and R3

show running
show version

Is there any option of running the OSPF debug like "debug ip ospf adj".

 

 

 

 

 

 

Beginner

Remove the "ip nat outside" statement from the OSPF interfaces and test again