Showing results for 
Search instead for 
Did you mean: 

Resetting router to factory default (removing the startup configuration file)



To resolve this issue, perform these steps:

  1. To erase the configuration file, issue the erase nvram: command.

    Reload the router by issuing the reload command.

  2. If this does not solve the problem, attempt to break into ROM Monitor (ROMmon) by issuing the break  sequence (usually Ctrl and break from the Hyperterminal) from a console connection.

    Refer to the Standard Break Key Combinations section of Standard Break Key Sequence Combinations During Password Recovery.

    You should see this ROMmon prompt:

    rommon 1>

  3. Change the configure register value to ignore the startup configuration by issuing the confreg command, as shown in this example:

    rommon 2> confreg 0x2142

  4. To reload the router, issue the reset command, as shown in this example:

    rommon 3> reset

  5. After the router boots, issue the enable command at the Router > prompt. The prompt changes to Router#, indicating that the router is now in privileged mode.
  6. To enter config mode, issue the config terminal command. You should now see a Router(config)# prompt.
  7. To change the configure register to recognize the startup configuration, issue the config-register command, as shown in this example:  
    Router (config)# config-register 0x2102

    To break out of configuration mode, press Cntl and Z.

    To save the blank configuration, issue the copy-running config-startup config command.

Zach Ljungren

copy running-config startup-config not copy-running config-startup config

Otherwise it worked great.


Thank you!


Thanks for the save!


After step 4 it will ask to configure, select no

copy running-config startup-config is correct

keith Kress

I recently obtained a used UC520, i followed these steps but i am still not able to connect CCA to the UC520 because it is not issuing IP

After those commands i no longer get a startup basic configuration dialog. but the unit simply will not issue IP.

Are there any guides on what minimal setup i would need to preform to get the UC520 to a state where i could connect it to CCA? i am not familiar with the CLI at all.

thank you

Mark Brown

Is there a way to reset units to factory default where:

1. The POST is successful as indicated by status lights

2. Access via the Console is not possible due to unknown settings changed from the default 9600/8/N/1

3. No SSH or other IP address management is available

Cisco 3700 Multi Service Router.

No problems.

The console cable no more are com....the newest mothers are usb interface...

Remenber thats...

I see you later.

Ciro G Mele.


Works great except for the last command copy running-config startup-config 

thank you a lot, it's help me a lot.



I followed this steps but I lost my IP phones registration 


i was trying to reset my password, so I followed your steps here 


but after more search, I found this


how to solve this issue ??