cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr

UK BT ADSL2+ Annex A - Cisco 877

23783
Views
0
Helpful
47
Comments

UK is currently going through a nationwide migration from ADSL, ADSL2 and ADSL2max to ADSL2+.

Most British Telecom (BT) MSANs are configured for Annex A, though we know that some LLU suppliers are using Annex M (with UK mask) which Cisco currently doesn't support.

Our issues are that all out Cisco 877s and there are 100s deployed that are subject to a line upgrade, or a new installs on ADSL2+ fail.

We have used the latest IOS that will runn on the older 128M DRAM units 12.4(15)T11 I think, and 12.4(24)T1 on newer units.  We have also played with DSL Modem firmware 3.0.33 and more recently 4.0.015 (which incidently works very well on UK ADSL2 Annex A).  None have helped.

The connectivity in UK is PPPoA

Symptoms:

It appears to be dependent on the amount of data through the DSL interface.

So a 24Mb/s connection will fail in hours, whereas a 9Mb/s will fail in days.

'sh int atm0' will show drops

'sh buffers' will show the middle and big buffers failing in particular.

Small packets such as ICMP and SSH will continue to work, so we can log on to the router(s) remotely.

But large packets such as those used for normal data will not pass the router reliably if at all.

Replace the router with a $100 item and the connection speed is normally better and there are no issues.

All these routers are similarly configured, have CBAC inspect code and a single IPSEC VPN.

MTU and MSS sizes are reduced to support IPSEC.

(though I hear the same problem from other UK deployments)

I have placed some info on the NetPro forum, seach for ADSL2+ and you should find it.

I have calls out to BT, large UK distributors and ISPs without any resolution or identification of the problem.

I think this is a significant issue given the value of Cisco DSL real estate in UK.

HELP!!!!

Ian Cowley

Comments
Beginner

Ian , not clear how to reply to your original document re issues of interoperability of Cisco ADSL with UK DSL, so I hope this gets to you.

We are experiencing very similar symptoms, except perhaps we have get longer periods of stability with the ADSL2 but only after significant tuning with the ISP. - However still by no means the required level of stability.

I am sorry i can't be of any specific help in this matter, but perhaps we can use this as an opportunity to keep some sort of open dialog on this to share what is obviously a very painful experience !

Beginner

ADSL2 works reasonably well especially with latest DSL firmware. but a fully loaded 877 (with IPSEC VPNs, CBAC/inspect/audit, NAT, etc) is completely unstable.

Cheap resendential class units work fine

Community Member

Hello Ian

We have a DMVPN network where each 877 spoke uses BT ADSL to come in. The ADSL2+ rollout has so far hit a small number of our remote sites. One of those sites was having problems which may or may not be related to the ones you're having: even though the traffic is quite low, the ATM interface was flapping constantly and the router even crashed a few times. All the 877s had identical software and configuration, and if I recall correctly the only commonality amongst the ones that worked was that Noise values (from a show dsl int atm0) were in the same ballpark, where the failing router had higher values.

At first we managed to make the line usable by having BT throttle the line back to ~2Mb/s, which is perfectly sufficient for our normal throughput requirements, but of course is not a viable long-term solution.

On October 23rd Cisco released a new firmware which I recently loaded onto the affected router along with the latest IOS, then got BT to remove the cap. We see the Reed-Solomon errors immediately ramp up to quite high values the moment the ATM line is connected, but the connection quickly goes stable and subsequent disturbances to the line produce only modest increases in error rates across the board.

We are still monitoring this router but the early signs are good. The line has shown pretty much no outages* since the new software was installed two days ago; on the old IOS/firmware the line would have been unusable long before now.

Hope this helps!

* there was an outage overnight on the first evening, but this also occurred on another test line we had installed at the same site, so we put it down to some tomfoolery at the exchange.

Beginner

Brian

Many thanks for your update and your scenario(s) correpond directly with ours.  We had ADSL2+ knocked back to ADSL2 and though there were errors its was E-11 so not an issue and from client perspective stable.

I am waiting for my own line to be upgraded this month to play with my own 877 as suprisingly 21CN doesn't come to our part of the City(London) til next year.  The clients are less than for us to use them as guinea pigs!

I have spoken to a number of ISPs who use Cisco kit for Business connections; typically DSL to private MPLS.

They have seen no problems, but they don't run inspect or IPSEC.

When you mention software are you talking IOS and/or  dsl firmware.

Have seen that dsl 4.0.18 has been released for the 877 and was going to try this.

Regards

Community Member

Ian

We did both the IOS update to 12.4 (24) T1 and the new 4.0.018 firmware. I'm quite certain that it was the firmware that did the trick, although the IOS update didn't hurt the site either.

Regards

Beginner

Hopefully it is the firmware that's sorted it as 12.4(15) and onwards need lots of flash and DRAM, that isn't available on the earlier boxes.

Community Member

I hope it sorts your problem out Ian. I'd be interested to know if it does work, and what IOS you're using.

Regards

Community Member

Hi Ian

Did it work?

Regards

Brian

Beginner

I am please to let you know that firmware 4.0.018 appears to sort out the issues.

Unfortunately my line only goes to 4M even with ADSL2+, but it is stable.

Next report will be on a geater than 12M line

IanC

Hi,

I work for a managed services partner and we too are seeing this issue with Cisco kit on ADSL2+ connections, we have applied this 877 fix and it seems to be working so far but we have many routers out there which dont have this fix.

EG:

Cisco 1801

Cisco 1841 with WIC-1ADSL cards

I've been looking and there doesnt seem to be a fix issued for the 1801 or ADSL WIC card, are Cisco going to release a patch for these models as the issued patch only seems to be for the 877 and 857 models.

Regards

Chris

Beginner

Further Update re BT ADSL2+

I have 2 877Ws connected to different exchanges in London; my own in SW and a clients in Docklands, both areas of which have some copper cabling issues due to minor disturbances in 1944.

Both run ADSL firmware 4.0.018, mine runs 12.4(24)T2 and the other 12.4(15)T10 (there's method in my madness!).  Both are attached to BT Exchanges with  IFTN, Infineon (Huawei) MANs.  I have no experience with other MANs at this time.

Mine runs as described before at 3.8M and is reasonably reliable though perhaps as expected with DSL on overhead lines drops out occasionally, but is far better than with earlier firmware.

The clients syncs up to 11Mb but collapses randomly, continually.  However the standard BT router, probably a 2Wire, connects at 12Mb and running continuously without problem.

We know knocking the line back to 9M will solve the problem, but Cisco should have an answer.  Unlesss its a hardware defect across their DSL processor.

Since posting here last year I've had feedback from numerous sources claiming the same problem with the DSL WICs too.

Cisco???

Community Member

I have a customer on an LLU connection over Tiscali network and apparantly the 877 is not compatible with their hardware. It did sync at 16Mb for a while but now will not connect.

Other routers still seem to work but I cannot make the 877 work. We are moving it to a Cable and Wireless c onnection to try that.

I'm having a somewhat similar issue with my 1841 and HWIC-1ADSL over here in Canada. The connection is unstable, where with a cheap D-Link ADSL modem, the connection is rock stable and won't go down for MONTHS.

I've tried firmware versions 4.0.018 and currently trying 3.0.33.....

Beginner

Y'all

We are still having problems with ADSL2+ lines in UK even with the 4.0.018 firmware.

The routers not only barely achieve 12M, while cheap domestic routers exceed 15M, the routers remain unstable with line drops or no traffic passing until reboot.

The lack of apparent attention by Cisco is an ongoing concern.

Community Member

Since installing the 4.0.018 firmware and 12.4.24(T1) IOS on the router that was affected we've had no worrisome issues. We upgraded all our routers thus and BT have now upgraded the lines to ~80 of our routers up to ADSL2+ with no complaints so far.

I know that Ian couldn't upgrade his 877s to a later IOS because of a lack of flash. How about your 1841 Chris?

Regards

Brian Gillespie

#sh dsl int atm0
ATM0
Alcatel 20190 chipset information
           ATU-R (DS)               ATU-C (US)
Modem Status:      Showtime (DMTDSL_SHOWTIME)
DSL Mode:      ITU G.992.5 (ADSL2+) Annex A
ITU STD NUM:       0x03                     0x3 
Chip Vendor ID:      'STMI'                     'TSTC'
Chip Vendor Specific:  0x0000                0x0510
Chip Vendor Country:   0x0F                0xB5
Modem Vendor ID: 'CSCO'                     'TSTC'
Modem Vendor Specific: 0x0000                0x5100
Modem Vendor Country:  0xB5                0xB5
Serial Number Near:    FHK121225Z2
Serial Number Far:     0000000000Chip ID:       C196 (0)
DFE BOM:      DFE3.0 Annex A (1)
Capacity Used:      73%                     41%
Noise Margin:      14.5 dB                20.0 dB
Output Power:      18.5 dBm                11.5 dBm
Attenuation:      23.5 dB                11.0 dB
FEC ES Errors:       0                      0
ES Errors:       0                     705
SES Errors:       0                     18
LOSES Errors:       0                     140
UES Errors:       0                     140
Defect Status:      None                            None                        
Last Fail Code:      None
Watchdog Counter: 0x5D
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:      0x00 
Interrupts:      8292 (0 spurious)
PHY Access Err:      0
Activations:      1
LED Status:      ON
LED On Time:      100
LED Off Time:      100
Init FW:      init_AMR_4.0.018.bin
Operation FW:      AMR-E-4.0.018.bin
FW Source:      external
FW Version:      4.0.18

            DS Channel1       DS Channel0     US Channel1       US Channel0
Speed (kbps):               0            15346              0              448
Cells:                    0           988375              0        109124567
Reed-Solomon EC:          0              179              0                0
CRC Errors:               0                0              0             1167
Header Errors:               0                0              0              351
Total BER:            0E-0           0E-0
Leakage Average BER:       0E-0           0E-0
Interleave Delay:         0                0              0               28
               ATU-R (DS)     ATU-C (US)
Bitswap:            enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0