Showing results for 
Search instead for 
Did you mean: 

UK BT ADSL2+ Annex A - Cisco 877


UK is currently going through a nationwide migration from ADSL, ADSL2 and ADSL2max to ADSL2+.

Most British Telecom (BT) MSANs are configured for Annex A, though we know that some LLU suppliers are using Annex M (with UK mask) which Cisco currently doesn't support.

Our issues are that all out Cisco 877s and there are 100s deployed that are subject to a line upgrade, or a new installs on ADSL2+ fail.

We have used the latest IOS that will runn on the older 128M DRAM units 12.4(15)T11 I think, and 12.4(24)T1 on newer units.  We have also played with DSL Modem firmware 3.0.33 and more recently 4.0.015 (which incidently works very well on UK ADSL2 Annex A).  None have helped.

The connectivity in UK is PPPoA


It appears to be dependent on the amount of data through the DSL interface.

So a 24Mb/s connection will fail in hours, whereas a 9Mb/s will fail in days.

'sh int atm0' will show drops

'sh buffers' will show the middle and big buffers failing in particular.

Small packets such as ICMP and SSH will continue to work, so we can log on to the router(s) remotely.

But large packets such as those used for normal data will not pass the router reliably if at all.

Replace the router with a $100 item and the connection speed is normally better and there are no issues.

All these routers are similarly configured, have CBAC inspect code and a single IPSEC VPN.

MTU and MSS sizes are reduced to support IPSEC.

(though I hear the same problem from other UK deployments)

I have placed some info on the NetPro forum, seach for ADSL2+ and you should find it.

I have calls out to BT, large UK distributors and ISPs without any resolution or identification of the problem.

I think this is a significant issue given the value of Cisco DSL real estate in UK.


Ian Cowley



Please note included in the trail above that when connecting to INFN Infineon MSAN equipment 018 doesn't behave above about 9Mb download speed.

As others have noted that if you connecting to other MSAN kit there's no problem, but its a lottery as to which MSAN you get.




Recent update

In the last few weeks it would appear BT have done something to the Infineon MSAN on my local exchange (BALham).  I guess there's been a firmware update.  The result is 4.0.195 is no longer stable.




Hi Ian,

I have given up on the cisco 877, the disconnects were becoming more and more regular.
In the meantime I have reverted back to using a thomson speedtouch 585v7 which has been very stable.

In the last fortnight I have moved from Zen (BT) to AAISP (BE LLU). I gave the 877 another chance as I am now connected to a broadcom MSAN, but it soon started disconnecting and I have stopped using it since.

The new 877 replacement model 887VA look promising as cisco seem to be moving away from the st micro to a broadcom based chipset.



Mine randomly behaves sketchily as well as of late, and seemingly right out of the blue. I ended up switching back to using the ISP provided Comtrend modem (OCCAM), which is the same brand as their DSLAM.


We are also having similar problems and not getting anywhere fast - Cisco don't seem interested, our ISP aren't much good and BT just blame the Cisco routers and land us with call-out charges for their site visits!

As per previous discussions on this thread, we have alleviated the issues by installing the 4.0.195 firmware and "fixing" the DSL mode to "adsl2+" rather than "auto" and while this does seem to help greatly, it certainly hasn't eradicated the problems completely. 

It's becoming very frustrating - if you look at when this thread started, it was back in 2009 yet still problems are being experienced.

Does anyone have any further suggestions on how to make inroads into this issue?

Community Member


We just had an update from our Cisco SE who confirmed that the 887VA has indeed ditched the STMicro chipset due to firmware issues.  Also note there is a new firmware update for 877 to be used with AnnexM in the UK.


Well i have been reading this with interest im in Perth Australia and am having the same issues you guys are. i was using it before with big issues one it wouldnt even connect at adsl2+ speeds always adsl1 and unstable and now with firware upgrades it finally connected higher speed then the crappy billion modem but then bombed out over night again im going to try the 4.10.9 firmware for some reason i ddint see there before its not in latest releases but is in the 4 folder see if this helps here but seems its not just the UK having all these issues as mentioned before it seems amazing that a expensive (well cheap model) Cisco router cant deal with something a 20 dollar special can.

ill keep u posted on the new firmware


Ian any idea where can I get the AMR-E-4.0.195.bin? I'd like to test it on a customer site.

Does anyone know if there is a later  more stable release?  My Customer is using Cisco 1841 with a HWIC-1ADSL-M on Infineon DSLAM in the UK.




WE are having th same issue as above.

Tried AMR-E-4.0.18.bin suggested by BT.

Can anyone send me the link for AMR-E-4.0.195.bin or a later versions.

Will try anything at the moment.

Really need an answer from Cisco if a fix is available, I would log this with TAC but dont have an account





4.0.195 is relatively stable, though slow, and still not perfect.

I suspect that Cisco have an issue with the ADSL hardware that cannot be truly fixed with firmware.

I think that the later routers (eg 887) and WICs have new hardware that overcomes the problem,

But I haven't used any of these in the wild.




Thanks for the reply...can you point me in the right direction for the firmware.




I'll pull it off one of the 877 routers email me;


Hello All,

I'm seeing the same issue on a number of 877 installs we've made here in the UK and there is a version 223 update available.  There is a marginal improvement on stability and speed but I stress marginal as BT's DSL migration and Cisco is still a concerning combination.

DFE BOM:         DFE3.0 Annex A (1)

Capacity Used:   85%                             99%

Noise Margin:    17.5 dB                         12.0 dB

Output Power:    17.0 dBm                        12.0 dBm

Attenuation:     31.0 dB                         16.0 dB

FEC ES Errors:   358798                           0

ES Errors:       64163                           42482

SES Errors:      1670                            3474

LOSES Errors:    26                               1

UES Errors:      58                              200987

Defect Status:   None                            None

Last Fail Code:  None

Watchdog Counter: 0xF4

Watchdog Resets: 0

Selftest Result: 0x00

Subfunction:     0x00

Interrupts:      8350 (0 spurious)

PHY Access Err:  0

Activations:     4

LED Status:      ON

LED On Time:     100

LED Off Time:    100

Init FW:         init_AMR_4.0.223.bin

Operation FW:    AMR-E-4.0.223.bin

FW Source:       external

FW Version:      4.0.223


Thanks for the info on the new 4.0.223 firmware release - have managed to obtain it through our Cisco partner so will give it a go to see if it leads to any improvement!


I had similar problem.

I added


under th PVC section.

Worked for me..

scroll to the bottom.....

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards