cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

USB Console Driver and Windows 7

126242
Views
20
Helpful
32
Comments

I just purchased a USB to Mini-USB console cable to use with the 2960s switches we just bought.  I download the current(?) driver Ver. 3.1 loaded it on my Win 7 64-bit laptop.  It installs ok but when I try to use it with Putty, Putty comes back saying it can't access the port.  I noticed the driver says it's for Win XP and Win Vista.  Is there a newer driver for Win 7?  Any other ideas?

Comments
VIP Advisor

Under Win7 Device Manager can you see the new COM port listed?

Community Member

Yes, It maps it as COM3.  It shows the driver as enabled and working properly.  But when I try to access that port via Putty, Putty errors with 'Unable to open connection to COM3. Unable to open serial port.'

Community Member

The way to tell the installation of the Cisco USB driver is good and the connection is good is as follows:  Open the Windows Device Manager, navigate to the Ports (COM & LPT) section and open the section so you can view the indivicual Ports, plug the cable into the PC and the Cisco router and you'll see a new port appear, typically COM4 which is the default as setup by the Cisco USB Console driver.  If you unplug the cable, the port will no longer be listed, plug it back in, and it will be listed.  The response time between connecting the cable and seeing the result in Device Manager is < 5 seconds.

Now, if you use HyperTerminal, TeraTerm, or any of your favorite terminal emulation programs that can communicate via a Serial Port, you may encounter "Cannot Open Com4" when you attempt to connect to the router with your terminal emulation program.

If this is your problem, connect the PC to the Cisco router so the port appears in device manager, right click on the port and select Update Driver Software, select Browse my computer for driver software, select Let me pick from a list of device drivers on my computer, and select Cisco Serial (there will be 2 choices, Cisco Serial and USB Serial Port.  The driver "Cisco Serial works <and> the USB Serial Port driver doesn't work.

Beginner

Thank you...Mark Nickson......your solution worked perfectly...........been searcing on the web for three hours..........

Community Member

Thank you Mark! 

Community Member

Thanks Mark,

     Choosing the Cisco driver was the key. 

Beginner

Thank! It is work!

Enthusiast

For me it did the trick as well. Thanks!

Beginner

I was trying to connect the usb and I followed your directions in the last paragraph, even though it was usb and it got me going. Big Thank!! Been hacking at this for 30 minutes. I reinstalled this sucker like twice and repaired it once, rebooted 3 times. I shouldn't have to go through this, but hey, this is why we get the big bucks I guess.

 

Dear Cisco,

 

Please put this in a troubleshooting doc for the USB. Ridiculous. I don't think I would've figured this out on my own.

Cisco Employee

I'm ashamed to say it, but I work for Cisco and I wasted a little time looking for this also.  I'm old school and have used the traditional RS-232 setup my entire career (over 25 years).  This post is one of those rare gems!  I never would have figured this out on my own. 

By they way, mine mapped as COM7.  You can find the COM port in the Windows Device Manager.

Beginner

this solve my problem 

Beginner

You rock!!

Community Member

It works fine for Windows 7 but not for Windows 8 :-(

Thanks!

 

Sorry It works fine but I had to delete the USB Serial Port, Download the latest driver and reinstall. After that I used the same solution as Windows 7. Changed the USB Serial Port to the Cisco Serial.

Community Member

Worked on windows embedded 8.1 industry pro x64. Thanks!

Beginner

Thank you, works fine!

CreatePlease to create content
Content for Community-Ad