cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

USB Console Driver and Windows 7

144563
Views
20
Helpful
32
Comments

I just purchased a USB to Mini-USB console cable to use with the 2960s switches we just bought.  I download the current(?) driver Ver. 3.1 loaded it on my Win 7 64-bit laptop.  It installs ok but when I try to use it with Putty, Putty comes back saying it can't access the port.  I noticed the driver says it's for Win XP and Win Vista.  Is there a newer driver for Win 7?  Any other ideas?

Comments
Community Member

In the Device Manager you may have to try different COM Ports, until you find one that works.. Usually, its COM 2 or  COM 3 in my case.  Question, Can you even download these from Cisco Any more ? I would like the link, if you still have it.

 

Thanks

Community Member

Here's the software and the link

https://software.cisco.com/download/release.html?mdfid=282774228&softwareid=282855122&release=3.1

Community Member

I get all the way to the Cisco Serial driver and it fails to install.  I am on windows 8.1 and this is the closest I have come to getting the USB console cable setup.  Any ideas?! thanks! 

Community Member

In theory Win 8.x and Win 10 should be close to Win 7 (this is the reason why Microsoft is confident enough to encourage Win 7 and Win 8 users to perform an in-place upgrade to Win 10 for free, if it's not highly compatible, Microsoft will be tortured by support requests / complaints).

With that said, the difficulty you're experiencing may be different than what I encountered.  I wish I had experience with Windows 8.1, but my limited experience has been with Windows 10 as part of the preview program.  I would perform a test of the Cisco package on Windows 10 but Win 10 was erased from the computer was using in the lab a week ago (so the computer could be used by another staff member and the Microsoft Win 10 preview program has ended now that it's in production, thus I don't have a reference Win 10 platform currently).

Beginner

I have the same problem and your solution works fine, so much tanks.

 

 

I have Win8.1 and worked fine after selecting the Cisco Driver :)

ajc Frequent Contributor
Frequent Contributor

Thanks Mark,

The same procedure applies for the MINI console port on the Wireless Controllers. So I am attaching to this post a detailed procedure with screenshots so anyone can follow it.

Community Member

It takes me 15 min to login and create account in cisco.com in order to reply to this thread.

I still do, in order to say a thanks here :)

Beginner

That did the trick! What bothers me is that I was accessing the router correcty from USB Console at COM3. I just unplugged the cable and turned off the router in order to get it installed and screwed in its rack and then.. *POOF* I got that "Cannot Open port COM3" after the router was rebooted.

So beware ppl! that error can just pop out at your machine for no apparent reason.

The driver update solution works like a charm!

Community Member

Thanks Mark worked here as well!

Beginner

Thank you.

key bit is this step:

""select Let me pick from a list of device drivers on my computer, and select Cisco Serial""

which I missed when initially read the info.

Neil

Thank you Mark!

Last case - to pick "Cisco Serial" works fine for me at Windows 10 .

Update for Windows 10 :

The problem happens again. Now, I should choose USB Serial Device, which is Microsoft's driver. But works ... It is unexplicable.

Beginner

Thank you Mark

Beginner

Thanks Mark, you are the Man!!!

This worked for me as well. Saved a bunch of time looking at outdated solutions.  I'm rocking and rolling now!!!!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards