cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Using UBR10K as Packet-Shelf and RFGW-10 as EQAM in MCMTS Setup

4570
Views
0
Helpful
2
Comments

Cable Technology

Using UBR10K as Packet-Shelf and RFGW-10 as EQAM in MCMTS Setup

LAB GUIDE

TAC Carrier Services

Jack Yu 3/6/2009

Objective:

1.     Bring Narrowband Modems online off Modular Interfaces

2.     Bring Wideband Modems w-online with channel-bonding

Components:

                RFGW-10

                ESR-PRE2

                UBR10-MC5X20H (or U,S Cards)

                Generic DTI Server

                UBR10-2XDS-SIP

                SPA-24XDS-SFP (24 Port Modena SPA)

                CMTS IOS 12.3(23) BC or 12.2(33)SCB

Overview:

               

                This lab guide is intended for quick setup of a simple Lab deployment of MCMTS - with the UBR10K acting as the packet shelf and the RFGW10 as the EQAM.

Tasks:

1.     Topology Design Planning and Cabling

2.     DTI Clocking

3.     Modular-Cable Controllers

4.     MC5X20 Cable Interface Configuration

5.     Cable Bundle Interface Configuration

6.     Modular-Cable Interface Configurations

7.     RFGW-10 Configurations

8.     Wideband Channel Bonding Modems

1.     Topology Design Planning

For our design – we will utilize a total of 6 RF-channels.

We plan on using one primary channel directly off the 5x20 card, the remaining four channels at layer one will be off the Modena SPA. The remaining 4 channels will be one dedicated primary, a second shared primary and bonding channels, and remaining four RFs will be split into two bonding groups

5X20 Primary 609 Mhz – Primary

RF-Channel 0 615 Mhz – Remote Primary only

RF-Channel 1 621 Mhz – Remote Primary and Bonding channel 1

RF-Channel 2 627 Mhz – Bonding channel 1

RF-Channel 3 633 Mhz – Bonding channel 2

RF-Channel 4 639 Mhz – Bonding channel 2

I will use all 4 Upstreams of the 5X20 card in our setup.

To keep things simple, all DS/US listed here serve the same batch of modems on the same node – In actual deployment scenarios, this may not be the case as providers usually segment off certain rf-channels to certain nodes. Later on, the Cable Fiber Node allows us to define physical topology (only required for wideband bonding groups).

-       All of my 5 modems can reach and lock any of these 5 DS channels

-       All of my 5 modems can reach and lock any of these 4 US channels

Physical Cabling

- UBR SPA-24XDS-SFP Connects by two redundant GigE MM Fibers to RFGW-10 Gig3/13 and Gig3/14

- DTCC Ethernet connection to DTI server

- 5X20 in slot 6/1 domain 6/1/0 US0-4 Connects to Diplexer which leads to node

- RFGW-10 DS ports and 5x20 DS ports are combined and connect to the Diplexer which connects to the node.

RFGW10 Cabling:

The RFGW10 mapping of Qams to ports should be pointed out. The RF Gateway 10 has slots in the front for 10 DS-48 cards stacked vertically. They are numbered from slot 3 to 12, left to right. In the back there are 12 RF Slots stacked horizontally numbered  RF Slot 1 to 12 (1 on top, 12 on bottom).

The DS-48 in slot 3 translates to the first (rightmost) port on each of the 12 RF slots in the back. The DS-48 in slot 4 translates to the 2nd port on each of the 12 RF Slots in the back, etc etc.

Here’s the mapping:

Qam3/1 -> 1st RF Slot, 1st port – This is the top right most port in the back.

Qam3/2 -> 2nd RF Slot, 1st port – This is the 2nd from the top card, right most port

Qam3/3 -> 3rd RF Slot, 1st port – This is the 3rd from the top card, right most port

Qam4/1 -> 1st RF Slot, 2nd port – This is the topmost card, 2nd from the right port

Qam4/2 -> 2nd RF Slot, 2nd port – This is the 2nd from the top card, 2nd from the right port

Qam4/3 -> 3rd RF Slot, 2nd port – This is the 3rd from the top card, 2nd from the right port

In our example I am going to use RFGW10’s Interface Qam3/1 and Qam4/1 to simplify cabling (I only have one UCH2). I’ll combine the two RF Outputs from the rightmost 2 ports of the top RF Slot in the back with the RF outputs from the 5x20 slot 6/1 downstream into a DS combiner.

At that point I take the output of the combiner into the diplexer. All the 4 US ports will be combined in into the diplexer like a normal setup.

2.     Configuring the DTI Clock

Since we are running a modem off a primary going through a device other than the 5X20 – We’ll need some way to sync up the MAP grants and other DOCSIS timing related functions.

- MCMTS has many modular parts - The EQAM (RFGW10), The Packet-Shelf (UBR10K), etc

- We must be able to syncronize all these devices

- DTI server is the way

UBR10K-D3(config)#cable clock dti

*Jan 31 22:08:14.543: %IPCOIR-5-CARD_DETECTED: Card type 2cable-dtcc (0x5B0) in slot 2/1

*Jan 31 22:08:14.543: %IPCOIR-5-CARD_LOADING: Loading card in slot 2/1

*Jan 31 22:08:14.891: %SYS-5-CONFIG_I: Configured from console by vty0 (171.69.85.25)

*Jan 31 22:08:15.755: %C10K-5-LC_NOTICE: Slot[2/1] Line-card Image Downloaded...Booting...

*Jan 31 22:08:33.567: %IPCOIR-5-CARD_DETECTED: Card type 2cable-dtcc (0x5B0) in slot 2/1

*Jan 31 22:08:33.643: %UBR10KTCC-4-CHG_CLK_REF: Clock reference source set to DTI for DTCC card 2/1

*Jan 31 22:08:33.943: %UBR10K_ALARM-6-INFO: CLEAR CRITICAL slot 2/1/0 Active Card Removed OIR Alarm - subslot 1

*Jan 31 22:08:33.943: %IPCOIR-2-CARD_UP_DOWN: Card in slot 2/1 is up.  Notifying 2cable-dtcc driver.

*Jan 31 22:08:33.947: %UBR10KTCC-2-ACTIVE_TCC: DTCC card 2/1 is active with DTI as clock reference

*Jan 31 22:08:33.947: %UBR10KTCC-4-CHG_CLK_REF: Clock reference source set to DTI for DTCC card 2/1

SLOT 6/1: Jan 31 22:08:33.871: %CLCJIB-6-TSLOAD: JIB 0 timestamp is reloaded

SLOT 6/1: Jan 31 22:08:33.851: %CLCJIB-6-TSLOAD: JIB 0 timestamp is reloaded

*Jan 31 22:08:35.091: %UBR10KTCC-1-DTIPORTSERVER: DTCC slot 2/1 port 1 DTI server status changed to freerun, external clock source: none

UBR10K-D3#sh cable clock

Number of TCC Cards in the Chassis: 1

Active TCC Card is in slot: 2 subslot: 1,(DTCC Eightbells card)

Clock reference used by the active card is DTI

Active TCC card in slot 2/1

No card in slot 1/1

TCC Card 2/1 DTI status:

-------------------------------------------

    Active Client port             : 1

    Active Client status           : normal

    Active Client Server status    : freerun

    Active Client frame error rate : < 2%

    Active Client CRC error count  : 0x02

    Standby Client Signal detected : yes

3.     Define the Modular-Cable Controllers:

Define your modular-cable controllers:

- These are the RF-Channels you will be using for your MCMTS setup

- Define the frequency/annex/mod/interleave you want - and mirror the configuration on the EQAM

- I suggest all frequencies you wish to bond be no more than 50Mhz apart maximum

Once you define the RF-Channels, the CMTS will know how to encapsulate the MPEG/DOCSIS frames into the L2TPv3 Frames which it will send out the SPA's Ethernet Interface. This packet will contain the proper DST/SRC IP and the DST/SRC MAC to the Eqam. The EQAM will look at the Depi ID and have a mapping to convert the incoming frames to the appropriate DOCSIS frame and send it on the appropriate Frequency/mod/interleave etc.

Why define frequency in Modular-Controller when the EQAM simply maps DEPI to the Frequency you choose on the EQAM?

Because Modem will compare the MDD message and realize the MDD describes on frequency but its receiving on another

Configuration:

- Define the SPA IP Address

- Define the Modular-host (Since SIP/SPA doesn't have enough horsepower CPU to encapsulate Docsis, use the 5X20's CPU listed here)

For each RF Channel you must define

- Define the RF-Channel's Downstream Channel-id

- Define the RF-Channel's Frequency, Annex, Modulation, and Interleave

- Define the IP address of the EQAM and Dst Mac Address and DEPI ID

- (Optional) Define the Network-delay – No longer recommended – there is a 550 usec delay already built in

In Example:

The EQAM'S ethernet mac address is 0022.9084.073f and is at 11.30.4.2. In RFGW10’s case the MAC address should be the mac address of any of the Interface Gigabits. For this example I used the Interface Gig1/3 on my RFGW10.

I am going to be encapsulating my stream with a Remote-ID of 4001. This will be important later on when we configure the EQAM side.

rf-channel 0 cable downstream channel-id 24

rf-channel 0 frequency 615000000 annex B modulation 256qam interleave 32

rf-channel 0 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4000

Here you can see I've defined 615Mhz though 639 Mhz for the 5 Channels we’ll be using.

controller Modular-Cable 1/0/0

ip-address 11.30.4.1                    ! This is the Modena’s IP address – Used in the SRC IP of the header

modular-host subslot 6/1             ! This defines the 5x20 card whose CPU will be used to generate the DOCSIS Frames

rf-channel 0 cable downstream channel-id 24

rf-channel 0 frequency 615000000 annex B modulation 256qam interleave 32

rf-channel 0 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4000

rf-channel 1 cable downstream channel-id 25

rf-channel 1 frequency 621000000 annex B modulation 256qam interleave 32

rf-channel 1 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4001

rf-channel 2 cable downstream channel-id 26

rf-channel 2 frequency 627000000 annex B modulation 256qam interleave 32

rf-channel 2 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4002

rf-channel 3 cable downstream channel-id 27

rf-channel 3 frequency 633000000 annex B modulation 256qam interleave 32

rf-channel 3 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4003

rf-channel 4 cable downstream channel-id 28

rf-channel 4 frequency 639000000 annex B modulation 256qam interleave 32

rf-channel 4 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4004

4.     MC5X20 Cable Interface Configuration

In my example we are using a MC5X20H Card in slot 6/1.  We will use Cable6/1/0 for our lab.

- Configure the Cable Bundle

- Configure the Upstreams

- Configure the Downstream Power and Frequency (Please note that if we did not want to run a Primary off the 5X20 we can omit this step)

- Define the associated Modular-Interfaces with this CGD

This command tells the MAC Domain (Technically CGD Domain) that the Modular 1/0/0 Rf-channel 0 using upstream 0-4 are also part of this MAC domain. This means, this host interface carries at this time two Primary Channels – the 5X20 609 Mhz and the Modular-Cable 1/0/0 RF-Channel 0.

downstream Modular-Cable 1/0/0 rf-channel 0 upstream 0-4

*Jan 31 22:17:16.951: %SNMP-5-LINK_DOWN: LinkDown:Interface Modular-Cable1/0/0:0 changed state to down

!

interface Cable6/1/0

no ip address

downstream Modular-Cable 1/0/0 rf-channel 0-1 upstream 0-4

no cable packet-cache

cable bundle 1

cable downstream channel-id 120

cable downstream annex B

cable downstream modulation 256qam

cable downstream interleave-depth 32

cable downstream frequency 609000000

no cable downstream rf-shutdown

cable upstream max-ports 4

cable upstream 0 connector 4

cable upstream 0 frequency 31500000

cable upstream 0 docsis-mode atdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 power-level 0

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 221

no cable upstream 0 shutdown

cable upstream 1 connector 1

cable upstream 1 frequency 25000000

cable upstream 1 docsis-mode atdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 221

no cable upstream 1 shutdown

cable upstream 2 connector 2

cable upstream 2 frequency 18500000

cable upstream 2 docsis-mode atdma

cable upstream 2 channel-width 3200000 3200000

cable upstream 2 minislot-size 2

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 221

no cable upstream 2 shutdown

cable upstream 3 connector 3

cable upstream 3 frequency 13500000

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 200000 200000

cable upstream 3 minislot-size 32

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

no cable upstream 3 shutdown

5.     Cable Bundle Interface Configuration and Provisioning Services

Cable Bundle Interface configuration is typical – since this is layer 3 for the modems we really don’t care that much about anything lower than layer 3 here.

We keep it simple by doing DHCP IP Pools and TFTP-Server directly on the CMTS.

The modem configuration file we use can be a simple DOCSIS 1.1 or 2.0 Modem file. In my case it’s called “chicago1-wcm2.bin”

!

interface Bundle1

ip address 172.32.0.1 255.255.255.0 secondary

ip address 10.1.1.1 255.255.255.0

cable arp filter request-send 3 2

cable arp filter reply-accept 3 2

!

tftp-server disk0:WCM.bin

tftp-server disk0:chicago1-wcm2.bin

ip dhcp pool WCM

   network 10.1.1.0 255.255.255.0

   bootfile chicago1-wcm2.bin

   next-server 10.1.1.1

   default-router 10.1.1.1

   domain-name dir

   option 7 ip 10.1.1.1

   option 4 ip 10.1.1.1

!

Checkpoint:

At this time you should have modems online off the 5X20 Primary DS Channel. You can verify this by “show cable modem” and “show cable modem primary. The Modular-Cable interfaces at this time should both be down/down.

UBR10K2-D3#scm pri

MAC Address    IP Address      Host      MAC          Prim  Num  Primary    DS

                               Interface State        Sid   CPE  Downstream RfId

0015.a3d9.71c5 10.1.1.2        C6/1/0/U2 online(pt)   1     0    C6/1/0     255

0015.a3c0.af49 10.1.1.3        C6/1/0/U0 online(pt)   2     0    C6/1/0     255

<snip>

UBR10K2-D3#sh ip int brie

Interface                  IP-Address      OK? Method Status                Protocol

<snip>

Modular-Cable1/0/0:0       Bundle1         YES unset  down                  down   

Modular-Cable1/0/0:1      Bundle1         YES unset  down                  down   

6.     Modular-Cable Interface Configurations

Since we defined the modular-cable interfaces under the 6/1/0 Domain, they now exist as interfaces on the CMTS. However, they will remain down/down until we define the percentage of bandwidth allocation.

For interface Modular-Cable 1/0/0:0 I will allocate the maximum percentage allowed which is 96% through the “cable rf-bandwidth-percent 96” command. The reason it is not 100% is due to reservation of at least 4% (sometimes more in real life) of the bandwidth for DOCSIS overhead.

For interface Modular-Cable 1/0/0:1 – since that channel will be carrying both primary channel data and bonding channel data – I will arbitrarily set the bandwidth reserved for the primary channel to 46%.

There is a feature called dynamic bandwidth sharing which allows for dynamic balancing of bandwidth available between a primary and bonding channel on the same physical rf-channel. Search Cisco.com for the feature “CMTS DBS”.

After such configuration the interfaces should come up up.

*Mar  6 10:18:12.515: %LINEPROTO-5-UPDOWN: Line protocol on Interface Modular-Cable1/0/0:0, changed state to up

*Mar  6 10:18:12.515: %SNMP-5-LINK_UP: LinkUp:Interface Modular-Cable1/0/0:0 changed state to up

!

interface Modular-Cable1/0/0:0

no ip address

cable bundle 1

cable rf-bandwidth-percent 96

!

interface Modular-Cable1/0/0:1

no ip address

cable bundle 1

cable rf-bandwidth-percent 46

!

Checkpoint:

At this time the CMTS has been configured for Narrowband modems off the Modular and Cable 6/1/0 interfaces. As far as the CMTS knows it is hosting three valid DSs within the 6/1/0 domain at this time. No modems will be able to come online on through the modular interfaces at this time on the 5x20.


You can verify this by a “show controller cable 6/1/0 downstream”

Cable6/1/0 Downstream is up

  Frequency 609.0000 MHz, Channel Width 6 MHz, 256-QAM, Symbol Rate 5.360537 Msps

  FEC ITU-T J.83 Annex B, R/S Interleave I=32, J=4

  Downstream channel ID: 120

  <Snip>

Local total modems 7, modems active 7, total DS flows 8

  NB DS Mo1/0/0:0, STATE: UP

   Frequency 615.0000 MHz 256-QAM,  ANNEX B, R/S Interleave I=32, J=4

   Network Delay 150 (usec)

   Bandwidth (Kbps): 36000,  Load Percent: 0

   Channel ID: 24, US MAP: 0x001F

   Total modems: 0, modems active : 0, total DS flows: 1

  NB DS Mo1/0/0:1, STATE: UP

   Frequency 621.0000 MHz 256-QAM,  ANNEX B, R/S Interleave I=32, J=4

   Network Delay 150 (usec)

   Bandwidth (Kbps): 17250,  Load Percent: 0

   Channel ID: 25, US MAP: 0x001F

   Total modems: 0, modems active : 0, total DS flows: 1

  DS_chan_id  RFID  Interface

  --------------------------------------

    24        0   Mo1/0/0:0

    25        1   Mo1/0/0:1

  --------------------------------------

7.     RFGW-10 Configuration

At this time you will be configuring the EQAM which we will be using as the RFGW10 device.

Checkpoint:

Make sure you are cabled correctly. The UBR10K’s spa GigE on the DS-48 is connected to the port on the associated DS-48 card in the front of the RFGW10 Device. Once this is connected the interface on the RFGW10 should come up/up:

RFGW-10#sh ip int brie

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet1          172.16.167.47   YES DHCP   up                    up

<snip>

GigabitEthernet3/13    unassigned      YES unset  up                    up

GigabitEthernet3/14    unassigned      YES unset  down                  down

In my setup I simply took the first port off my UBR SPA and hooked it to the slot 3 DS-48 first port. In my example I did not do redundant connections. If you wish, hook the redundant GigE from SPA on UBR to 2nd port on the DS-48 card and it should then come up/up.

The MAC address used earlier in the UBR’s Modular-Controller RF-Channel mappings is the mac address of RFGW10’s interface Gig1/3.

End checkpoint.


We need to map the correct incoming DEPI streams to the correct Qams. For my example I am going to map RF-Channel 0-2 in Qam3/1 and RF-Channel 3,4 on Qam 4/1. This means RF-Channel 0 is represented by Qam3/1.1, RF-channel 1 Qam3/1.2, and RF-Channel 2 Qam3/1.3.

The subinterface to RF-channel mapping is arbitrary – just make sure under the subinterface you define the “cable depi dest-ip xxxx session-id yyyy” to match that of what you have on the UBR’s Modular-Cable controller for your session ID.

- Cable mode depi local

- Cable downstream Frequency xxxxxxx

- Cable downstream modulation [256q|64q]

- Cable downstream annex b

- Cable depi dest-ip zzzzz session-id yyyy

!

interface Qam3/1.1

cable mode depi local

no cable downstream rf-shutdown

cable downstream rf-power 50.0

cable downstream frequency 615000000

cable downstream modulation 256

cable depi dest-ip 11.30.4.2 session-id 4000

snmp trap link-status

!

interface Qam3/1.2

cable mode depi local

no cable downstream rf-shutdown

cable downstream rf-power 50.0

cable downstream frequency 621000000

cable downstream modulation 256

cable depi dest-ip 11.30.4.2 session-id 4001

snmp trap link-status

!

interface Qam3/1.3

cable mode depi local

no cable downstream rf-shutdown

cable downstream rf-power 50.0

cable downstream frequency 627000000

cable downstream modulation 256

cable depi dest-ip 11.30.4.2 session-id 4002

snmp trap link-status

!

interface Qam4/1.1

cable mode depi local

no cable downstream rf-shutdown

cable downstream rf-power 50.0

cable downstream frequency 633000000

cable downstream modulation 256

cable depi dest-ip 11.30.4.2 session-id 4003

snmp trap link-status

!

interface Qam4/1.2

cable mode depi local

no cable downstream rf-shutdown

cable downstream rf-power 50.0

cable downstream frequency 639000000

cable downstream modulation 256

cable depi dest-ip 11.30.4.2 session-id 4004

snmp trap link-status

!

Checkpoint:

At this time your DEPI mappings on the RFGW10 should be accurate – Issue a “show cable depi manual summary” to make sure they are correct. Notice that 4002-4 are IDLE, this is correct as we have not used them in any way on the UBR yet.

RFGW-10#sh cable depi manual sum

List of the Configured Depi Sessions

  ID          Type                State      Qam-info   PWtype

  x-----------x-------------------x----------x----------x--------

  4000        MANUAL_DEPI_OVER_IP ACTIVE     Qam3/01.1  DMPT

  4001        MANUAL_DEPI_OVER_IP ACTIVE     Qam3/01.2  DMPT

  4002        MANUAL_DEPI_OVER_IP IDLE       Qam3/01.3  DMPT

  4003        MANUAL_DEPI_OVER_IP IDLE       Qam4/01.1  DMPT

  4004        MANUAL_DEPI_OVER_IP IDLE       Qam4/01.2  DMPT

RFGW-10#sh cable depi manual 4000

Detailed Info about Session with id# 4000:

                Type               : MANUAL_DEPI_OVER_IP

                Name               :

                State              : ACTIVE

                Remote id         : 0

                DestIP addr        : 11.30.4.2

                Qam slotid         : 3

                Qam portid         : 1

                Qam ch id          : 1

                Payload type       : DEPI_PW_TYPE_D_MPT

                Sync Mode          : ENABLE

                Sync Intl          : 100

                Up time            : 00:48:42

                << Session Statistic >>

                Session is off     : 0

                Broken seq num     : 0

                Bad depi header    : 0

                Bad MPEG sync byte : 0

                In packet rate     : 1042 pps

                In bit rate        : 2088456 bps

                Out bit rate       : 1738344 bps

                << Flow Statistic >>

                Total packet       : 2923407

                Total byte         : 549600516

                Total segment      : 2923407

                Discards           : 0

                Errors             : 0

                Bad pyld size      : 0

                Cmnd buf ovfw     : 0

If you’ve cabled this correctly your cable modems should be able to move between 5x20 Primary, Modular1/0/0:0, and Modular1/0/0:1.

You can now move between them with “test cable dcc” command.

Note that if you wish to use technique 4 of DCC you’ll need to appropriately tune the DEPI offset in the RFGW10 Qam configuration.

UBR10K2-D3#scm pri

MAC Address    IP Address      Host      MAC          Prim  Num  Primary    DS

                               Interface State        Sid   CPE  Downstream RfId

0018.19b6.2bd6 10.1.1.5        C6/1/0/U1 online(pt)   9     1    Mo1/0/0:1  1

0014.bfbe.816f 10.1.1.3        C6/1/0/U1 online(pt)   10    0    Mo1/0/0:1  1

0015.a3c0.af49 10.1.1.6        C6/1/0/U1 online(pt)   11    0    Mo1/0/0:1  1

0014.bfbe.8163 10.1.1.9        C6/1/0/U1 online(pt)   12    0    Mo1/0/0:0  0

0018.6897.cf1c 10.1.1.4        C6/1/0/U1 online(pt)   13    0    Mo1/0/0:0  0

0015.a3d9.71c5 10.1.1.10       C6/1/0/U1 online(pt)   14    0    Mo1/0/0:1  1

0015.96d9.f16c 10.1.1.8        C6/1/0/U1 online(pt)   15    0    Mo1/0/0:1  1

0013.11ea.29c9 10.1.1.2        C6/1/0/U1 online(pt)   16    0    Mo1/0/0:0  0

UBR10K2-D3#scm pri

MAC Address    IP Address      Host      MAC          Prim  Num  Primary    DS

                               Interface State        Sid   CPE  Downstream RfId

0015.a3d9.71c5 10.1.1.10       C6/1/0/U1 online(pt)   14    0    Mo1/0/0:1  1

UBR10K2-D3#test cable dcc 0015.a3d9.71c5 mo1/0/0:0 1

0015.a3d9.71c5 10.1.1.10       C6/1/0/U1 offline      14    0.50   1834   0   N N

UBR10K2-D3#scm pri

MAC Address    IP Address      Host      MAC          Prim  Num  Primary    DS

                               Interface State        Sid   CPE  Downstream RfId

0015.a3d9.71c5 10.1.1.10       C6/1/0/U1 init(io)     14    0    Mo1/0/0:0  0

UBR10K2-D3#scm pri

MAC Address    IP Address      Host      MAC          Prim  Num  Primary    DS

                               Interface State        Sid   CPE  Downstream RfId

0015.a3d9.71c5 10.1.1.10       C6/1/0/U1 online(pt)   14    0    Mo1/0/0:0  0

8.     Wideband Channel Bonding Modems

At this point we should have narrowband modems working off the UBR SPA-24XDS-SFP card. It’s simply configuration of the Interface Wideband and fiber-nodes to get modems to bond and come w-online.

-       Create the interface Wideband

                                          i.    For the Interface wideband you must define the RF-channels you want to use in as bonding channels

                                         ii.    You also must define the interface wideband as part of a cable bundle

                                        iii.    Most field deployments also utilize dynamic bandwidth sharing (DBS)

-       Create the fiber node

                                          i.    This defines the physical topology.

I will create Interface Wideband-Cable1/0/0:0 to represent my first bonding group.

!

interface Wideband-Cable1/0/0:0

cable bundle 1

cable bonding-group-id 1

cable rf-channel 1 bandwidth-percent 50

cable rf-channel 2 bandwidth-percent 96

!

Recall that rf-channel 1 is used both for narrowband primaries as well as a bonding channel. This means the bandwidth is shared between the two. Earlier I defined rf-channel 1’s bandwidth within modular1/0/0:1 at 46%. Add it to that allocated for bonding 50% you get exactly 96% which is the maximum allowed allocation.

I will create Interface Wideband-Cable1/0/0:1 to represent the second bonding group.

!

interface Wideband-Cable1/0/0:1

cable bundle 1

cable bonding-group-id 2

cable rf-channel 3 bandwidth-percent 96

cable rf-channel 4 bandwidth-percent 96

!

For wideband channel bonding to work we have to define the Cable Fiber Node. A fiber node defines the physical cabling of the plant. In my case, all DS can hit all my modems, so I have defined them to be in the same node.

cable fiber-node 1

  downstream Modular-Cable 1/0/0 rf-channel 0-4

  downstream Cable6/1/0

!

%Fiber node 1 status changed to Valid state

A fiber node represents the Modular and Cable interfaces which can all hit a subset of modems. There is not necessarily an association with the wideband interfaces. For example, the following definition is redundant and you don’t need fiber node 2 because they overlap.

cable fiber-node 1

  downstream Modular-Cable 1/0/0 rf-channel 0-4

  downstream Cable6/1/0

!

cable fiber-node 2

  downstream Modular-Cable 1/0/0 rf-channel 2,3

  downstream Cable6/1/0

!

But this example fiber node IS NOT redundant because it is saying those Modular1/0/0:0-2 can never be seen by modems on Modular1/0/0:3,4

!

cable fiber-node 1

  downstream Modular-Cable 1/0/0 rf-channel 0-2

  downstream Cable6/1/0

!

cable fiber-node 2

  downstream Modular-Cable 1/0/0 rf-channel 3,4

  downstream Cable6/1/0

!

Checkpoint:

At this time delete the wideband capable modems and they now should come w-online(pt). I only have three WCMs so this is correct!

UBR10K2-D3#scm

                                                                              B D

MAC Address    IP Address      I/F       MAC          Prim  RxPwr  Timing Num P I

                                         State        Sid   (dBmv) Offset CPE I P

0015.a3d9.71c5 10.1.1.10       C6/1/0/U1 online(pt)   18    0.50   1833   0   Y N

0014.bfbe.816f 10.1.1.3        C6/1/0/U1 w-online(pt) 19    0.00  1833   0   Y N

0018.19b6.2bd6 10.1.1.5        C6/1/0/U3 online(pt)   20    -0.50  1396   1   Y N

0014.bfbe.8163 10.1.1.9        C6/1/0/U1 w-online(pt) 21    0.00   1833   0   Y N

0015.a3c0.af49 10.1.1.6        C6/1/0/U1 online(pt)   22    -0.50  1833   0   Y N

0015.96d9.f16c 10.1.1.8        C6/1/0/U1 online(pt)   23    0.50   1658   0   Y N

0013.11ea.29c9 10.1.1.2        C6/1/0/U1 online(pt)   24    0.50   1663   0   Y N

0018.6897.cf1c 10.1.1.4        C6/1/0/U1 w-online(pt) 25    0.00   1445   0   Y N

UBR10K2-D3#show cable modem wideband

MAC Address    IP Address      I/F       MAC           Prim  RCC  MD-DS-SG

                                         State         Sid   ID

0014.bfbe.816f 10.1.1.3        C6/1/0/U1 w-online(pt)  19    2    1

0014.bfbe.8163 10.1.1.9        C6/1/0/U1 w-online(pt)  21    1    1

0018.6897.cf1c 10.1.1.4        C6/1/0/U1 w-online(pt)  25    1    1

Notice that in the RFGW10 all DEPI sessions are now ACTIVE – because before we did not utilize those rf-channels which were involved in channel bonding.

RFGW-10#sh cable depi-sessions  manual summ

List of the Configured Depi Sessions

  ID          Type                State      Qam-info   PWtype

  x-----------x-------------------x----------x----------x--------

  4000        MANUAL_DEPI_OVER_IP ACTIVE     Qam3/01.1  DMPT

  4001        MANUAL_DEPI_OVER_IP ACTIVE     Qam3/01.2  DMPT

  4002        MANUAL_DEPI_OVER_IP ACTIVE     Qam3/01.3  DMPT

  4003        MANUAL_DEPI_OVER_IP ACTIVE     Qam4/01.1  DMPT

  4004        MANUAL_DEPI_OVER_IP ACTIVE     Qam4/01.2  DMPT

Congratulations, you now have a simple working MCTMS lab!

See below for show run of UBR and RFGW10:

UBR10K2-D3#sh run

Building configuration...

Current configuration : 18012 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service internal

!

hostname UBR10K2-D3

!

boot-start-marker

boot system disk0:ubr10k2-k9p6u2-mz.122-33.SCB.bin

boot-end-marker

!

logging buffered 65535

enable secret 5 $1$gypj$gCHK5fetCrzIzLLB9U7101

!

no aaa new-model

facility-alarm core-temperature major 58

facility-alarm core-temperature minor 50

facility-alarm core-temperature critical 85

facility-alarm intake-temperature major 54

facility-alarm intake-temperature minor 45

facility-alarm intake-temperature critical 72

!

!

card 1 2jacket-1

card 1/0 24rfchannel-spa-1

card 2/1 2cable-dtcc

card 4/0 1gigethernet-hh-1

card 5/0 5cable-mc520u-d

card 6/1 5cable-mc520h-d

cable admission-control preempt priority-voice

no cable qos permission create

no cable qos permission update

cable qos permission modems

!

cable diaglog active

cable clock dti

ip subnet-zero

no ip domain lookup

no ip dhcp use vrf connected

!

ip dhcp pool WCM

   network 10.1.1.0 255.255.255.0

   bootfile chicago1-wcm2.bin

   next-server 10.1.1.1

   default-router 10.1.1.1

   domain-name dir

   option 7 ip 10.1.1.1

   option 4 ip 10.1.1.1

!

!

!

!

!

!

!

redundancy

mode sso

!

!

controller Modular-Cable 1/0/0

ip-address 11.30.4.1

modular-host subslot 6/1

rf-channel 0 cable downstream channel-id 24

rf-channel 0 frequency 615000000 annex B modulation 256qam interleave 32

rf-channel 0 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4000

rf-channel 1 cable downstream channel-id 25

rf-channel 1 frequency 621000000 annex B modulation 256qam interleave 32

rf-channel 1 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4001

rf-channel 2 cable downstream channel-id 26

rf-channel 2 frequency 627000000 annex B modulation 256qam interleave 32

rf-channel 2 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4002

rf-channel 3 cable downstream channel-id 27

rf-channel 3 frequency 633000000 annex B modulation 256qam interleave 32

rf-channel 3 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4003

rf-channel 4 cable downstream channel-id 28

rf-channel 4 frequency 639000000 annex B modulation 256qam interleave 32

rf-channel 4 ip-address 11.30.4.2 mac-address 0022.9084.073f depi-remote-id 4004

rf-channel 5 cable downstream channel-id 29

rf-channel 6 cable downstream channel-id 30

rf-channel 7 cable downstream channel-id 31

rf-channel 8 cable downstream channel-id 32

rf-channel 9 cable downstream channel-id 33

rf-channel 10 cable downstream channel-id 34

rf-channel 11 cable downstream channel-id 35

rf-channel 12 cable downstream channel-id 36

rf-channel 13 cable downstream channel-id 37

rf-channel 14 cable downstream channel-id 38

rf-channel 15 cable downstream channel-id 39

rf-channel 16 cable downstream channel-id 40

rf-channel 17 cable downstream channel-id 41

rf-channel 18 cable downstream channel-id 42

rf-channel 19 cable downstream channel-id 43

rf-channel 20 cable downstream channel-id 44

rf-channel 21 cable downstream channel-id 45

rf-channel 22 cable downstream channel-id 46

rf-channel 23 cable downstream channel-id 47

!

!

!

!

!

!

interface FastEthernet0/0/0

ip address 172.16.167.54 255.255.255.224

speed 100

full-duplex

!

interface Wideband-Cable1/0/0:0

cable bundle 1

cable bonding-group-id 1

cable rf-channel 1 bandwidth-percent 50

cable rf-channel 2 bandwidth-percent 96

!

interface Wideband-Cable1/0/0:1

cable bundle 1

cable bonding-group-id 2

cable rf-channel 3 bandwidth-percent 96

cable rf-channel 4 bandwidth-percent 96

!

interface Modular-Cable1/0/0:0

cable bundle 1

cable rf-bandwidth-percent 96

cable cm-status enable 1-2 4-5

!

interface Modular-Cable1/0/0:1

cable bundle 1

cable rf-bandwidth-percent 46

cable cm-status enable 1-2 4-5

!

interface GigabitEthernet4/0/0

no ip address

negotiation auto

!

interface Cable5/0/0

cable cm-status enable 1-2 4-5

no cable packet-cache

cable downstream channel-id 120

cable downstream annex B

cable downstream modulation 64qam

cable downstream interleave-depth 32

cable downstream rf-shutdown

cable upstream max-ports 4

cable upstream 0 connector 0

cable upstream 0 docsis-mode tdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 21

cable upstream 0 shutdown

cable upstream 1 connector 1

cable upstream 1 docsis-mode tdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 21

cable upstream 1 shutdown

cable upstream 2 connector 2

cable upstream 2 docsis-mode tdma

cable upstream 2 channel-width 1600000 1600000

cable upstream 2 minislot-size 4

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 21

cable upstream 2 shutdown

cable upstream 3 connector 3

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 1600000 1600000

cable upstream 3 minislot-size 4

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

cable upstream 3 shutdown

!

interface Cable5/0/1

cable cm-status enable 1-2 4-5

no cable packet-cache

cable downstream channel-id 121

cable downstream annex B

cable downstream modulation 64qam

cable downstream interleave-depth 32

cable downstream rf-shutdown

cable upstream max-ports 4

cable upstream 0 connector 4

cable upstream 0 docsis-mode tdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 21

cable upstream 0 shutdown

cable upstream 1 connector 5

cable upstream 1 docsis-mode tdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 21

cable upstream 1 shutdown

cable upstream 2 connector 6

cable upstream 2 docsis-mode tdma

cable upstream 2 channel-width 1600000 1600000

cable upstream 2 minislot-size 4

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 21

cable upstream 2 shutdown

cable upstream 3 connector 7

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 1600000 1600000

cable upstream 3 minislot-size 4

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

cable upstream 3 shutdown

!

interface Cable5/0/2

cable cm-status enable 1-2 4-5

no cable packet-cache

cable downstream channel-id 122

cable downstream annex B

cable downstream modulation 64qam

cable downstream interleave-depth 32

cable downstream rf-shutdown

cable upstream max-ports 4

cable upstream 0 connector 8

cable upstream 0 docsis-mode tdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 21

cable upstream 0 shutdown

cable upstream 1 connector 9

cable upstream 1 docsis-mode tdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 21

cable upstream 1 shutdown

cable upstream 2 connector 10

cable upstream 2 docsis-mode tdma

cable upstream 2 channel-width 1600000 1600000

cable upstream 2 minislot-size 4

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 21

cable upstream 2 shutdown

cable upstream 3 connector 11

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 1600000 1600000

cable upstream 3 minislot-size 4

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

cable upstream 3 shutdown

!

interface Cable5/0/3

cable cm-status enable 1-2 4-5

no cable packet-cache

cable downstream channel-id 123

cable downstream annex B

cable downstream modulation 64qam

cable downstream interleave-depth 32

cable downstream rf-shutdown

cable upstream max-ports 4

cable upstream 0 connector 12

cable upstream 0 docsis-mode tdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 21

cable upstream 0 shutdown

cable upstream 1 connector 13

cable upstream 1 docsis-mode tdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 21

cable upstream 1 shutdown

cable upstream 2 connector 14

cable upstream 2 docsis-mode tdma

cable upstream 2 channel-width 1600000 1600000

cable upstream 2 minislot-size 4

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 21

cable upstream 2 shutdown

cable upstream 3 connector 15

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 1600000 1600000

cable upstream 3 minislot-size 4

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

cable upstream 3 shutdown

!

interface Cable5/0/4

cable cm-status enable 1-2 4-5

no cable packet-cache

cable downstream channel-id 124

cable downstream annex B

cable downstream modulation 64qam

cable downstream interleave-depth 32

cable downstream rf-shutdown

cable upstream max-ports 4

cable upstream 0 connector 16

cable upstream 0 docsis-mode tdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 21

cable upstream 0 shutdown

cable upstream 1 connector 17

cable upstream 1 docsis-mode tdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 21

cable upstream 1 shutdown

cable upstream 2 connector 18

cable upstream 2 docsis-mode tdma

cable upstream 2 channel-width 1600000 1600000

cable upstream 2 minislot-size 4

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 21

cable upstream 2 shutdown

cable upstream 3 connector 19

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 1600000 1600000

cable upstream 3 minislot-size 4

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

cable upstream 3 shutdown

!

interface Cable6/1/0

downstream Modular-Cable 1/0/0 rf-channel 0-1 upstream 0-4

cable cm-status enable 1-2 4-5

no cable packet-cache

cable bundle 1

cable downstream channel-id 120

cable downstream annex B

cable downstream modulation 256qam

cable downstream interleave-depth 32

cable downstream frequency 609000000

no cable downstream rf-shutdown

cable upstream max-ports 4

cable upstream 0 connector 4

cable upstream 0 frequency 31500000

cable upstream 0 docsis-mode atdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 power-level 0

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 221

no cable upstream 0 shutdown

cable upstream 1 connector 1

cable upstream 1 frequency 25000000

cable upstream 1 docsis-mode atdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 221

no cable upstream 1 shutdown

cable upstream 2 connector 2

cable upstream 2 frequency 18500000

cable upstream 2 docsis-mode atdma

cable upstream 2 channel-width 3200000 3200000

cable upstream 2 minislot-size 2

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 221

no cable upstream 2 shutdown

cable upstream 3 connector 3

cable upstream 3 frequency 13500000

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 200000 200000

cable upstream 3 minislot-size 32

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

cable upstream 3 s160-atp-10-millisecond-bucket

no cable upstream 3 shutdown

!

interface Cable6/1/1

cable cm-status enable 1-2 4-5

no cable packet-cache

cable downstream channel-id 149

cable downstream annex B

cable downstream modulation 64qam

cable downstream interleave-depth 32

cable downstream rf-shutdown

cable upstream max-ports 4

no cable upstream 0 connector

cable upstream 0 docsis-mode tdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 21

cable upstream 0 shutdown

cable upstream 1 connector 5

cable upstream 1 docsis-mode tdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 21

cable upstream 1 shutdown

cable upstream 2 connector 6

cable upstream 2 docsis-mode tdma

cable upstream 2 channel-width 1600000 1600000

cable upstream 2 minislot-size 4

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 21

cable upstream 2 shutdown

cable upstream 3 connector 7

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 1600000 1600000

cable upstream 3 minislot-size 4

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

cable upstream 3 shutdown

!

interface Cable6/1/2

cable cm-status enable 1-2 4-5

no cable packet-cache

cable downstream channel-id 150

cable downstream annex B

cable downstream modulation 64qam

cable downstream interleave-depth 32

cable downstream rf-shutdown

cable upstream max-ports 4

cable upstream 0 connector 8

cable upstream 0 docsis-mode tdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 21

cable upstream 0 shutdown

cable upstream 1 connector 9

cable upstream 1 docsis-mode tdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 21

cable upstream 1 shutdown

cable upstream 2 connector 10

cable upstream 2 docsis-mode tdma

cable upstream 2 channel-width 1600000 1600000

cable upstream 2 minislot-size 4

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 21

cable upstream 2 shutdown

cable upstream 3 connector 11

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 1600000 1600000

cable upstream 3 minislot-size 4

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

cable upstream 3 shutdown

!

interface Cable6/1/3

cable cm-status enable 1-2 4-5

no cable packet-cache

cable downstream channel-id 151

cable downstream annex B

cable downstream modulation 64qam

cable downstream interleave-depth 32

cable downstream rf-shutdown

cable upstream max-ports 4

cable upstream 0 connector 12

cable upstream 0 docsis-mode tdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 21

cable upstream 0 shutdown

cable upstream 1 connector 13

cable upstream 1 docsis-mode tdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 21

cable upstream 1 shutdown

cable upstream 2 connector 14

cable upstream 2 docsis-mode tdma

cable upstream 2 channel-width 1600000 1600000

cable upstream 2 minislot-size 4

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 21

cable upstream 2 shutdown

cable upstream 3 connector 15

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 1600000 1600000

cable upstream 3 minislot-size 4

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

cable upstream 3 shutdown

!

interface Cable6/1/4

cable cm-status enable 1-2 4-5

no cable packet-cache

cable downstream channel-id 152

cable downstream annex B

cable downstream modulation 64qam

cable downstream interleave-depth 32

cable downstream rf-shutdown

cable upstream max-ports 4

cable upstream 0 connector 16

cable upstream 0 docsis-mode tdma

cable upstream 0 channel-width 1600000 1600000

cable upstream 0 minislot-size 4

cable upstream 0 range-backoff 3 6

cable upstream 0 modulation-profile 21

cable upstream 0 shutdown

cable upstream 1 connector 17

cable upstream 1 docsis-mode tdma

cable upstream 1 channel-width 1600000 1600000

cable upstream 1 minislot-size 4

cable upstream 1 range-backoff 3 6

cable upstream 1 modulation-profile 21

cable upstream 1 shutdown

cable upstream 2 connector 18

cable upstream 2 docsis-mode tdma

cable upstream 2 channel-width 1600000 1600000

cable upstream 2 minislot-size 4

cable upstream 2 range-backoff 3 6

cable upstream 2 modulation-profile 21

cable upstream 2 shutdown

cable upstream 3 connector 19

cable upstream 3 docsis-mode tdma

cable upstream 3 channel-width 1600000 1600000

cable upstream 3 minislot-size 4

cable upstream 3 range-backoff 3 6

cable upstream 3 modulation-profile 21

cable upstream 3 shutdown

!

interface Bundle1

ip address 172.32.0.1 255.255.255.0 secondary

ip address 10.1.1.1 255.255.255.0

cable arp filter request-send 3 2

cable arp filter reply-accept 3 2

no cable ip-multicast-echo

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.167.33

!

!

no ip http server

no ip http secure-server

!

logging cmts cr10k log-level errors

cpd cr-id 1

nls resp-timeout 1

cdp run

!

tftp-server disk0:WCM.bin

tftp-server disk0:chicago1-wcm2.bin

!

!

control-plane

!

alias exec scm show cable modem

alias exec ccmd clear cable modem all delete

alias exec ccmr clear cable modem all reset

alias exec dcm debug cable mac-add

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

privilege level 15

password cisco

login

line vty 0 4

exec-timeout 60 0

privilege level 15

password cisco

logging synchronous

login

line vty 5 10

exec-timeout 60 0

privilege level 15

password cisco

logging synchronous

login

!

!

cable fiber-node 1

  downstream Modular-Cable 1/0/0 rf-channel 0-4

  downstream Cable6/1/0

!

end

RFGW-10#sh run

Building configuration...

Current configuration : 11953 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service internal

service compress-config

service heartbeat warning-timeout 3

service heartbeat fatal-timeout 5

service heartbeat alive-timeout 300

!

hostname RFGW-10

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

hw-module uplink select tengigabitethernet

ip subnet-zero

!

vtp domain ''

vtp mode transparent

cluster run

!

!

!

power redundancy-mode redundant

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

redundancy

notification-timer 240000

mode sso

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet1

ip address dhcp

speed auto

duplex auto

!

interface TenGigabitEthernet1/1

!

interface TenGigabitEthernet1/2

!

interface GigabitEthernet1/3

no switchport

ip address 11.30.4.2 255.255.255.0

!

interface GigabitEthernet1/4

!

interface GigabitEthernet1/5

!

interface GigabitEthernet1/6

!

interface TenGigabitEthernet2/1

!

interface TenGigabitEthernet2/2

!

interface GigabitEthernet2/3

!

interface GigabitEthernet2/4

!

interface GigabitEthernet2/5

!

interface GigabitEthernet2/6

!

interface Qam3/1

no ip address

no cable downstream rf-shutdown

!

interface Qam3/1.1

cable mode depi local

no cable downstream rf-shutdown

cable downstream tsid 37111

cable downstream rf-power 40.0

cable downstream frequency 615000000

cable downstream modulation 256

cable depi dest-ip 11.30.4.2 session-id 4000

snmp trap link-status

!

interface Qam3/1.2

cable mode depi local

no cable downstream rf-shutdown

cable downstream rf-power 40.0

cable downstream frequency 621000000

cable downstream modulation 256

cable depi dest-ip 11.30.4.2 session-id 4001

snmp trap link-status

!

interface Qam3/1.3

cable mode depi local

no cable downstream rf-shutdown

cable downstream rf-power 40.0

cable downstream frequency 627000000

cable downstream modulation 256

cable depi dest-ip 11.30.4.2 session-id 4002

snmp trap link-status

!

interface Qam3/1.4

no cable downstream rf-shutdown

cable downstream rf-power 40.0

cable downstream frequency 633000000

cable downstream modulation 256

snmp trap link-status

!

interface Qam3/2

no ip address

cable downstream rf-shutdown

!

interface Qam3/2.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/2.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/2.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/2.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/3

no ip address

cable downstream rf-shutdown

!

interface Qam3/3.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/3.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/3.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/3.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/4

no ip address

cable downstream rf-shutdown

!

interface Qam3/4.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/4.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/4.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/4.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/5

no ip address

cable downstream rf-shutdown

!

interface Qam3/5.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/5.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/5.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/5.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/6

no ip address

cable downstream rf-shutdown

!

interface Qam3/6.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/6.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/6.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/6.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/7

no ip address

cable downstream rf-shutdown

!

interface Qam3/7.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/7.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/7.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/7.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/8

no ip address

cable downstream rf-shutdown

!

interface Qam3/8.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/8.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/8.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/8.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/9

no ip address

cable downstream rf-shutdown

!

interface Qam3/9.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/9.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/9.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/9.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/10

no ip address

cable downstream rf-shutdown

!

interface Qam3/10.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/10.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/10.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/10.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/11

no ip address

cable downstream rf-shutdown

!

interface Qam3/11.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/11.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/11.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/11.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam3/12

no ip address

load-interval 30

cable downstream rf-shutdown

!

interface Qam3/12.1

cable mode depi local

cable downstream rf-shutdown

cable downstream rf-power 50.0

cable downstream frequency 609000000

cable downstream modulation 256

snmp trap link-status

!

interface Qam3/12.2

cable downstream rf-shutdown

cable downstream rf-power 50.0

cable downstream frequency 615000000

cable downstream modulation 256

snmp trap link-status

!

interface Qam3/12.3

cable downstream rf-shutdown

cable downstream rf-power 50.0

cable downstream frequency 621000000

cable downstream modulation 256

snmp trap link-status

!

interface Qam3/12.4

cable downstream rf-shutdown

cable downstream rf-power 50.0

cable downstream frequency 627000000

cable downstream modulation 256

snmp trap link-status

!

interface GigabitEthernet3/13

load-interval 30

!

interface GigabitEthernet3/14

!

interface Asi3/15

no ip address

!

interface Qam4/1

no ip address

no cable downstream rf-shutdown

!

interface Qam4/1.1

cable mode depi local

no cable downstream rf-shutdown

cable downstream rf-power 40.0

cable downstream frequency 633000000

cable downstream modulation 256

cable depi dest-ip 11.30.4.2 session-id 4003

snmp trap link-status

!

interface Qam4/1.2

cable mode depi local

no cable downstream rf-shutdown

cable downstream rf-power 40.0

cable downstream frequency 639000000

cable downstream modulation 256

cable depi dest-ip 11.30.4.2 session-id 4004

snmp trap link-status

!

interface Qam4/1.3

cable downstream rf-shutdown

cable downstream rf-power 40.0

cable downstream frequency 645000000

cable downstream modulation 256

snmp trap link-status

!

interface Qam4/1.4

cable downstream rf-shutdown

cable downstream rf-power 40.0

cable downstream frequency 651000000

cable downstream modulation 256

snmp trap link-status

!

interface Qam4/2

no ip address

cable downstream rf-shutdown

!

interface Qam4/2.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/2.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/2.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/2.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/3

no ip address

cable downstream rf-shutdown

!

interface Qam4/3.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/3.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/3.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/3.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/4

no ip address

cable downstream rf-shutdown

!

interface Qam4/4.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/4.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/4.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/4.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/5

no ip address

cable downstream rf-shutdown

!

interface Qam4/5.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/5.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/5.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/5.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/6

no ip address

cable downstream rf-shutdown

!

interface Qam4/6.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/6.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/6.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/6.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/7

no ip address

cable downstream rf-shutdown

!

interface Qam4/7.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/7.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/7.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/7.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/8

no ip address

cable downstream rf-shutdown

!

interface Qam4/8.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/8.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/8.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/8.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/9

no ip address

cable downstream rf-shutdown

!

interface Qam4/9.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/9.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/9.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/9.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/10

no ip address

cable downstream rf-shutdown

!

interface Qam4/10.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/10.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/10.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/10.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/11

no ip address

cable downstream rf-shutdown

!

interface Qam4/11.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/11.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/11.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/11.4

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/12

no ip address

cable downstream rf-shutdown

!

interface Qam4/12.1

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/12.2

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/12.3

cable downstream rf-shutdown

snmp trap link-status

!

interface Qam4/12.4

cable downstream rf-shutdown

snmp trap link-status

!

interface GigabitEthernet4/13

!

interface GigabitEthernet4/14

!

interface Asi4/15

no ip address

!

interface Vlan1

no ip address

!

ip http server

no ip http secure-server

!

!

!

!

logging alarm minor

!

!

!

control-plane

!

banner lcd RFGW-10

!

line con 0

stopbits 1

line vty 0 4

login

!

scheduler runtime netinput 100

end

Comments

Very nice document. Version with 3G60 cards would also be very helpful.

Beginner

Hey Chieh,

This is my Sh Cab modem output for lab setup.

uBR10k#scm

MAC Address    IP Address      I/F       MAC          Prim RxPwr  Timing Num BPI

                                         State        Sid  (dBmV) Offset CPE Enb

0015.cf9d.171d a.b.c.75     C5/1/0/U0 online       170   0.50  1432    1   N

78cd.8e6c.510d a.b.c.122    C5/1/0/U0 w-online     171   0.00  1442    1   N

I want to know w-online modem is bonded to how many channels ... its a 4X4 D3 modem..

Thanks in advance for suggestions.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards