cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco announces new innovations in SD-WAN, ISRs, SD-WAN Services, and Catalyst 9000 Series switches


SVI routing not working cisco 3750

1433
Views
5
Helpful
9
Comments
Beginner
Ask the Expert
thru

Hi guys,

I am stuck. I've spent 3 evenings trying to find out why my L3 routing not working on 3750.

What I've done so far is:

1. no ip routing and then ip routing

2. write erase and reload, no ip routing-write erase-roload- ip routing

3. shut no shut all respective ports

4. updating IOS to C3750-IPSERVICESK9-M, Version 12.2(55)SE and previous one was ipbase 12.2 (4.) SE

5. increasing MTU to jumbo

6. Only one thing I can't get rid of sysmet mtu routing 1500. I does except no command but line stays anyway

7. sdm prefer ip routing  - is enabled

8. I am able to ping end hosts respective gateways but can't ping between SVIs

9. outpot of sh ver,  sh run, sh sdm prefer, sh cdp neigh, sh ip route are attached below

10. I can replicate this in Packet Tracer without any problems but with my physical lab where I've got 2x3750 same issue for both switches.

 

My topology is so streigh forward

Topology.jpg

 

host 1

ip address 10.10.10.2 /24

DG 10.10.10.1

 

host 2

ip address 10.10.20.2 /24

DG 10.10.20.1

 

L3 3750 Switch

Switch#sh run
Building configuration...

Current configuration : 3309 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
switch 1 provision ws-c3750-24p
system mtu routing 1500
ip routing
!
!
!         
!
crypto pki trustpoint TP-self-signed-1165801216
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1165801216
 revocation-check none
 rsakeypair TP-self-signed-1165801216
!
!
crypto pki certificate chain TP-self-signed-1165801216
 certificate self-signed 01
  3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31313635 38303132 3136301E 170D3933 30333031 30303031
  34325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31363538
  30313231 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CE92 03642CC0 80767A5D 2AD49535 4C850432 6D493F92 8D934086 537104FF
  87347BB4 710AB1AD 5F7AA25B 55F776EF 523FBD6F E86F3572 45979081 38A7D924
  D1358517 E1C3998F 410E27C8 ADCEF9EE 90171D7A F016BCD4 0CE35754 BE490398
  45FBE412 238B05AE 088D22EC A60610F3 882155F1 FAEEED09 1BF5C601 CDB3D341
  D54D0203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603
  551D1104 0B300982 07537769 7463682E 301F0603 551D2304 18301680 14DE0C5C
  68245A80 9E692C31 C10F1489 E3214C0A E7301D06 03551D0E 04160414 DE0C5C68
  245A809E 692C31C1 0F1489E3 214C0AE7 300D0609 2A864886 F70D0101 04050003
  81810072 D8A72C91 59C3955D DB91BF5D 4D038B24 B081629E 8029C8DC A1FFC777
  B118EF6A A68A71C7 29AD7749 CAA58E95 FF3F86A4 7059421C 5DA3288F DA5D253A
  1D0A124F 552EE1A2 6F1BB510 6B65BBFD A587A873 34A02BC6 8374D5CF 6DCED0FD
  F2249A7A 1BEA2BDF 56E5A8AE 4A6011D7 FE069CAF E8467E4C 8BBAD4C5 414FDE10 4CA959
  quit
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet1/0/1
!
interface FastEthernet1/0/2
!
interface FastEthernet1/0/3
!         
interface FastEthernet1/0/4
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet1/0/5
!
interface FastEthernet1/0/6
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet1/0/7
!
interface FastEthernet1/0/8
!
interface FastEthernet1/0/9
!
interface FastEthernet1/0/10
!
interface FastEthernet1/0/11
!
interface FastEthernet1/0/12
!
interface FastEthernet1/0/13
!
interface FastEthernet1/0/14
!
interface FastEthernet1/0/15
!
interface FastEthernet1/0/16
!
interface FastEthernet1/0/17
!
interface FastEthernet1/0/18
!
interface FastEthernet1/0/19
!
interface FastEthernet1/0/20
!
interface FastEthernet1/0/21
!
interface FastEthernet1/0/22
!
interface FastEthernet1/0/23
!
interface FastEthernet1/0/24
!         
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
 no ip address
 no ip mroute-cache
 shutdown
!
interface Vlan10
 ip address 10.10.10.1 255.255.255.0
 no ip mroute-cache
!
interface Vlan20
 ip address 10.10.20.1 255.255.255.0
 no ip mroute-cache
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
end

Switch#

Switch#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R3               Fas 1/0/6         171             R S I  2811      Fas 0/0
R1               Fas 1/0/4         171             R S I  2811      Fas 0/0

 

Switch#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.10.0 is directly connected, Vlan10
C       10.10.20.0 is directly connected, Vlan20
Switch#

 

Switch#sh sdm prefer
 The current template is "desktop routing" template.
 The selected template optimizes the resources in
 the switch to support this level of features for
 8 routed interfaces and 1024 VLANs.

  number of unicast mac addresses:                  3K
  number of IPv4 IGMP groups + multicast routes:    1K
  number of IPv4 unicast routes:                    11K
    number of directly-connected IPv4 hosts:        3K
    number of indirect IPv4 routes:                 8K
  number of IPv4 policy based routing aces:         0.5K
  number of IPv4/MAC qos aces:                      0.5K
  number of IPv4/MAC security aces:                 1K

 

Switch#sh ver
Cisco IOS Software, C3750 Software (C3750-IPSERVICESK9-M), Version 12.2(55)SE, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Sat 07-Aug-10 22:45 by prod_rel_team
Image text-base: 0x01000000, data-base: 0x02F00000

ROM: Bootstrap program is C3750 boot loader
BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.2(44)SE5, RELEASE SOFTWARE (fc1)

Switch uptime is 13 minutes
System returned to ROM by power-on
System image file is "flash:/c3750-ipservicesk9-mz.122-55.SE.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C3750-24P (PowerPC405) processor (revision K0) with 131072K bytes of memory.
Processor board ID FDO1132Z6P3
Last reset from power-on
3 Virtual Ethernet interfaces
24 FastEthernet interfaces
2 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 00:1D:45:7C:B7:00
Motherboard assembly number     : 73-9672-15
Power supply part number        : 341-0029-05
Motherboard serial number       : FDO113203ED
Power supply serial number      : LIT11300BNN
Model revision number           : K0
Motherboard revision number     : B0
Model number                    : WS-C3750-24PS-S
System serial number            : FDO1132Z6P3
Top Assembly Part Number        : 800-25860-09
Top Assembly Revision Number    : D0
Version ID                      : V10
CLEI Code Number                : COMAJ10BRA
Hardware Board Revision Number  : 0x01


Switch Ports Model              SW Version            SW Image                 
------ ----- -----              ----------            ----------               
*    1 26    WS-C3750-24P       12.2(55)SE            C3750-IPSERVICESK9-M     


Configuration register is 0xF

Switch#

9 Comments

In your physical devices, windows firewall is active? Maybe is blocking the traffic.

Beginner

Hi Jadarson,

Just checked and disabled anything possible on my pc and still the same issue. And wierd thing I picked up just now, I conf 3rd sw 3550 with ip routing and same story. 

routes are in routing table

endhosts able to ping its respective GW but not able to ping each other.

Switch#sh sdm prefer
 The current template is "desktop routing" template.
 The selected template optimizes the resources in
 the switch to support this level of features for
 8 routed interfaces and 1024 VLANs.

 

Try change sdm prefer for lanbase routing..

Beginner

Try no ip  routing , configure default gateway, and then create static routes , example 0.0.0.0 0.0.0.0 nexthop

Beginner

This sounds like a default route issue. When you can ping the DG of your subnet and nothing else in a different subnet that a good place to start. 

Beginner

Hi there,

 

I did different way of default route

Switch(config)#end
Switch#sh ip route
*Mar  1 00:24:22.739: %SYS-5-CONFIG_I: Configured from console by console
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.10.20.2 to network 0.0.0.0

     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.10.0 is directly connected, Vlan10
C       10.10.20.0 is directly connected, Vlan20
S*   0.0.0.0/0 [1/0] via 10.10.20.2
               [1/0] via 10.10.10.2
               is directly connected, Vlan20
               is directly connected, Vlan10

and disabled ip routing changing sdm nothing helped. This is so weird. I can do it anywhere PT, GNS3 in 2 min but can't perfomr it on real equipment.

Beginner

I meant it sounds like a default route issue in your host devices.  The 3750 has routes to each subnet so in your scenario a default route is not needed. 

Beginner

Hi mdannenbring,

Yes you are completely right. Once I changed def route in my end host poting to next hop which is respective SVI it worked. But I can't understand why it doe's work if I have saem DG???? Could you explaine pls

Beginner
CreatePlease to create content
Content for Community-Ad

Blog-Cisco Community Designated VIP Dinner CLEUR2019