cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
345
Views
0
Helpful
1
Replies
jemu1
Beginner

ESXI 6.7 host and Nexus 7k1 Switch Trunking

I am using Virtual Switch Tagging (VST) between ESXI 6.7 host and
Nexus 7k switch, N7K1,this way :
I have created Vlans 88,90-95 on N7K1. ESXI 6.7 host management network is
on Vlan 88. Thus on ESXI 6.7 host management network is on Vlan 88 instead of
the default Not set
Trunking between N7K1 and ESXI 6.7 host is like this
N7K1(config)# int e2/1
N7K1(config)# switchport
N7K1(config)#switchport mode trunk
N7K1(config)#no ip address
N7K1(config)#switchport trunk allowed vlan 88-99
N7K1(config)#switchport dot1q ethertype 0x9100
N7K1(config)#spanning-tree port type edge trunk

The vlan XX where XX in 88-99
N7K1(config)# vlan XX
N7K1(config-vlan)# name VLXX
N7K1(config)# feature interface-vlan
N7K1(config)# int vlan XX
N7K1(config-if)# ip add 10.1.XX.251/24

When I use this configuration I lose connection to ESXI 6.7 host
but when change switchport trunk vlan 88 to
switchport access vlan 88 I retain connection to ESXI 6.7 host but
none of its guests in different vlans are accessible

Anywhere in my configurations are wrong ?
Or what is the corresponding configuration for N7K1
int e2/1
switchport trunk encapsulation dot1q
switchport trunk allowed 89-99
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk

1 REPLY 1
Sergiu.Daniluk
VIP Engager

Hi @jemu1 

First, not sure why you are using "switchport dot1q ethertype 0x9100".  Are you using q-in-q?

Second, it looks like your vmk0 is using untagged connectivity, so add the "switchport trunk native vlan 88".

 

Let us know if this solved the problem.

 

Cheers,

Sergiu

 

Content for Community-Ad

This widget could not be displayed.