cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Can't compile cisco-etsi-nfvo package for ncs-5.3.1.1-cisco-etsi-nfvo-4.2.0-bundle/

293
Views
0
Helpful
1
Comments
Beginner

Hello experts,

I am trying to install the ncs-5.3.1.1-cisco-etsi-nfvo-4.2.0-bundle for NSO (version 5.2.0.3, local install under ~/ncs-run)

I can get all the other packages to load and compile, but for the cisco-etsi-nfvo package, there isn't a Makefile under /src.

I tried loading the packages without compiling the cisco-etso-nfvo package, but NSO throws this error:


>>> System upgrade is starting.
>>> Sessions in configure mode must exit to operational mode.
>>> No configuration changes can be performed until upgrade has completed.
>>> System upgrade has been cancelled.
Error: Internal error: {failed,
{recompile_needed,
"./state/packages-in-use/1/cisco-etsi-nfvo/load-dir/etsi-nfv-descriptors.fxs"}}

 

But... no makefile... no compile.

Any  help or guidance would be appreciated.  if someone has the makefile, maybe post that and I'll copy it into the build.

 

Thanks

1 Comment
Cisco Employee

Hi,

 

The ncs-5.3.1.1-cisco-etsi-nfvo-4.2.0-bundle is pre-compiled to run on NSO 5.3.*, hence the

error you are seeing.

We do not ship source code with NFVO, so you cant re-compile it.

You need to get NFVO the is pre-build for NSO 5.2.

 

I hope this answers you question.