cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
606
Views
10
Helpful
5
Replies
Janos_Gal
Beginner

cisco NSO Juniper NED - Device JROUTER does not advertise any known YANG modules

Hi Community,

 

tested with:

Juniper Model: MX480

Junos OS Version 19.2R1

cNSO Ver.: ncs-5.3.0.1

NED Ver.: ncs-5.3.0.1-juniper-junos-4.5.19

 

We want to use yang-compliant netconf between Cisco NSO and Juniper MX routers to follow general requirements our Production requirements.

We configured rfc-compliant & yang-compliant on the Juniper MX480 Routers.

                //

                set system services netconf rfc-compliant

                set system services netconf yang-compliant

               //

 

After implementing these commands, we got these error messages in cNSO:

[edit]
admin@ncs% request devices device JROUTER sync-from | details debug
2020-02-25T10:29:26.062 ncs: device JROUTER: sync-from...
2020-02-25T10:29:26.063 ncs: device JROUTER: taking device lock... ok [0.000 sec]
2020-02-25T10:29:26.077 ncs: device JROUTER: connect: device connect...
2020-02-25T10:29:26.078 ncs: device JROUTER: connect: SSH connecting to admin@JROUTER
2020-02-25T10:29:26.154 ncs: device JROUTER: connect: reuse SSH connection to admin@JROUTER
2020-02-25T10:29:30.202 ncs: device JROUTER: connect: device connect error [4.124 sec]
2020-02-25T10:29:30.202 ncs: device JROUTER: releasing device lock
2020-02-25T10:29:30.202 ncs: device JROUTER: sync-from error [4.140 sec]
result false
info Device JROUTER does not advertise any known YANG modules
[ok][2020-02-25 10:29:30]

[edit]
admin@ncs% *** ALARM connection-failure: Device JROUTER does not advertise any known YANG modules

 

 

I have a question in this regard:

NED Version : ncs-5.3.0.1-juniper-junos-4.5.19 ( “official Juniper NED”)
- I would like to ask, if the "bug" in this Juniper NED can be fixed right now or will have a fix in the future?
(error message: “info Device LAB-SPE242 does not advertise any known YANG modules”)

 

- or should we use only the self-created NED in the future?

(Going Junos Native with NSO)

 

Thank you in advance.

Best regards

Janos Gal

5 REPLIES 5
nso20
Beginner

Hi Janos_Gal,

 

Have you solved the problem ? I am facing it now.

Hi,

 

yes, I followed steps mentioned in below document and created NETCONF NED .
https://community.cisco.com/t5/nso-developer-hub-blogs/going-junos-native-with-nso/ba-p/3995765

 

If you have only one Routing engine, it works.

 

I am trying to build netconf ned from 3 yang files: junos-common-type, junos-conf-interfaces and junos-conf-root, just to set description on interface by this customized NED. I tried partial sync for interfaces but still same error:

admin@ncs# show running-config devices device juniper config configuration interfaces
% No entries found.
admin@ncs# devices partial-sync-from path [ /devices/device[name='juniper']/config/configuration/interfaces ]
sync-result {
device juniper
result false
info Device juniper does not advertise any known YANG modules
}

Are you already using the new NED? (juniper-junos-18.4R1-nc-1.0), you can download all the Juniper Yang Modells from the Router or https://github.com/Juniper/yang

Your Junos Version should be 18.4R1or newer.

I would build a complete NED and try it out first.

I built a netconf NED with the yang files:

admin@ncs# show netconf-ned-builder project mycisco_ned 1.0 module status
NAME REVISION STATUS
-------------------------------------------------------------------
Cisco-IOS-XE-features 2019-10-01 selected,downloaded
Cisco-IOS-XE-interface-common 2019-11-01 selected,downloaded
Cisco-IOS-XE-interfaces-oper 2019-11-01 selected,downloaded
Cisco-IOS-XE-native 2019-11-01 selected,downloaded
Cisco-IOS-XE-types 2019-11-01 selected,downloaded
Cisco-IOS-XE-yang-interfaces-cfg 2019-05-21 selected,downloaded
cisco-semver 2019-03-20 selected,downloaded
ietf-inet-types 2013-07-15 selected,downloaded
ietf-yang-types 2013-07-15 selected,downloaded

 

And could do partial-sync:

admin@ncs# devices partial-sync-from path [ /devices/device[name='mycsr']/config/native ]
sync-result {
device mycsr
result true
}

admin@ncs(config)# do show running-config devices device mycsr config
devices device mycsr

native ip domain name cisco.com

 

I would expect to set any configuration parameter inside native but have the below error:

admin@ncs(config)# devices device mycsr config native ip domain name mydomain.com
admin@ncs(config-config)# commit
Aborted: Network Element Driver: device mycsr: out of sync