Showing results for 
Search instead for 
Did you mean: 

Could not load private-jar in ned citrix-netscaler

Chris Wang
Cisco Employee
Cisco Employee

currently we are using citrix-netscaler 3.0.23 to managed netscaler devices, but meet below exception: Error creating stream factory: java.lang.ClassNotFoundException:


We try to extrat the private-jar and put the jars into shared-jar folder, it works.


Can anyone help why the private-jar is not loaded?


Cisco Employee
Cisco Employee



your solution is within a later version of citrix ned:


Version: 3.0.29
citrix-netscaler v3.0.29


  - Added 'systemglobal_authenticationlocalpolicy_binding *' configuration
    detailed bellow.
     (CITNET-28 / PS-29590 / RT34527)

  - Enhanced the Yang model with the configuration described bellow.
     (CITNET-29 / PS-29611 / RT34548)

YANG model changes since 3.0.28:

  New nodes:

  Changed nodes:

A similar issue was found in our internal database and it states 3.0.29 resolved this issue.


Where can I see the NSO and ned's release notes? As you see, all the fixes we're not aware.

Hi Chris,

My bad. The specific NED that fixes it is:

Version: 3.0.28


citrix-netscaler v3.0.28


- Updated the LICENSE file and removed the private-jar/commons-codec.jar lib.
- Replaced with json-20171018.jar.
- Expanded the Yang file with the configuration as below.

(CITNET-17 / RT33629)

I tried version citrix-netscaler 3.0.28, another issue occurred.


ncsadmin@ncs# devices device NS-LAB connect
result false
info Failed to connect to device NS-LAB: connection refused: INSTANCE


And I checked the log, it shows the ssl connect have error, seems the http ssl lib could not be loaded.


<ERROR> 05-Mar-2019::05:15:03.616 NedWorker Ned-Worker-Thread-0: - Error in connect
java.lang.NoSuchFieldError: INSTANCE
at org.apache.http.conn.ssl.SSLConnectionSocketFactory.<clinit>(
at com.tailf.packages.ned.citrixnetscaler.RESTConnection.doConnect(
at com.tailf.packages.ned.citrixnetscaler.RESTConnection.<init>(
at com.tailf.packages.ned.citrixnetscaler.CitrixNetscalerNedGeneric.<init>(
at com.tailf.packages.ned.citrixnetscaler.CitrixNetscalerNedGeneric.newConnection(
at com.tailf.ned.NedWorker.dorun(
<INFO> 05-Mar-2019::05:15:03.616 NedWorker Ned-Worker-Thread-0: - Sending={ned_error,ned_connect,econnrefused,#Bin<<INSTANCE>>}

I assume you recompiled the new ned via make clean all and then reloaded the packages and tried to connect/sync-from to the device, right?

Can you connect to any other citrix devices? This may be a NED issue, but i'd suggest trying the latest citrix NED first to verify if it is reproduced or have been fixed.

I checked our database for that exact error, there was 2 instances of a similar error which both resulted in BU escalation.

1st one: Ned enhanced for jar versions/files
2nd one: incompatible/deprecated device attempted to be connected. (that's why i asked to see if the issue occurs with all citrix devices).

I believe this may require escalation, but first test out the latest ned. See if this issue is reproduced on netsim as a simple test so that we (TAC) can reproduce it locally if possible since we do not have a citrix device at hand.

none of the netscaler devices could be manged due to the issue. And I tried 4.2 and 3.0.28 as well as 3.0.29, the same issue.
Other neds like cisco-ios... could work well.

We find out an work round to managed the netscaler devices, but need to do more test. we move the "staxon-1.3.jar" in folder private-jar to NSO's java/jar folder. And the citrix-netscaler version is :3.0.23

For this issue, I'd recommend requesting a NED enhancement. Providing all the data you observed and the workaround that worked. I imagine this may be a fix that'll be required in the future since you may need an NED update and would require to manually workaround your issue.

Was your issue resolved?
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: