cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
277
Views
10
Helpful
2
Replies
Highlighted

Does migration from NCS-3.4.12 to NSO-5.1.0.1 is possible?

I am migrating from NCS-3.4.12 to NSO-5.1.0.1, which gives me error while compiling the code in the conf api for the NavuCdbConfig Classes.

Any suggestions how to tackle this?

2 REPLIES 2
Highlighted
Cisco Employee

Re: Does migration from NCS-3.4.12 to NSO-5.1.0.1 is possible?

This is a *very* big step to migrate in one go. There are
many internals that have changed during this period.

If I recall correctly, the recommended upgrade path
is first an NSO release pre 4.5, then a release post 4.5
then 5.x. Something like the following:
NCS-3.4.12 -> NSO-4.4 -> NSO-4.7 -> NSO-5.1.0.1.

Possibly, even more intermediate steps are needed.
Highlighted
Cisco Employee

Re: Does migration from NCS-3.4.12 to NSO-5.1.0.1 is possible?

To add to this, NSO 5.1 in particular includes major changes under the hood (mainly the move to Common Data Models, or CDM), so the upgrade to 5.1 may involve more work than previous upgrades. If you check the docs/ directory for NSO 5.1.0.1, you should find a "nso_cdm_migration_guide" file that includes the details of what is required to upgrade to an NSO version that uses CDM (meaning NSO 5.1 or later). Anyone wishing to upgrade from a pre 5.1 version to NSO 5.1 or later should read the migration guide thoroughly before planning the upgrade.