cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
563
Views
0
Helpful
1
Replies

group assignment error during re-deploy

jjgrinwis
Level 1
Level 1

Hi,

a customer of us is doing some tests with exnternal authentication. They can login via the CLI, are assigned to a group and can provision a service. But when they want to do a re-deploy of the same service, they are getting an access-denied error:

test@ncs> request services core-link uuid-20180313-16:51:00 re-deploy

Error: access denied

When we have a look in the audit trail:

<INFO> 14-Mar-2018::16:44:39.481 nso-01-tst ncs[26047]: audit user: test/51 assigned to groups: ncsadmin

<INFO> 14-Mar-2018::16:44:52.104 nso-01-tst ncs[26047]: audit user: test/51 CLI ‘request services core-link uuid-20180313-16:51:00 re-deploy’

<INFO> 14-Mar-2018::16:44:52.134 nso-01-tst ncs[26047]: audit user: test/52 assigned to groups:

<INFO> 14-Mar-2018::16:44:52.153 nso-01-tst ncs[26047]: audit user: test/51 CLI aborted

It looks like assigned to groups is empty

When I have a look in our environment with only a couple of local users and do a re-deploy of a service:


<INFO> 26-Mar-2018::17:06:45.865 nso ncs[1875]: audit user: test/6569 CLI 'request services vcompartiment vcompartiment13 re-deploy'

<INFO> 26-Mar-2018::17:06:45.867 nso ncs[1875]: audit user: test/6577 assigned to groups: admin

<INFO> 26-Mar-2018::17:06:46.078 nso ncs[1875]: audit user: test/6569 CLI done


User is assigned to local admin group and we can provision en re-deploy the service without any problem.

Any idea what might be the problem here?

1 Accepted Solution

Accepted Solutions

jjgrinwis
Level 1
Level 1

We upgraded to the latest version which solved our issue.

View solution in original post

1 Reply 1

jjgrinwis
Level 1
Level 1

We upgraded to the latest version which solved our issue.