cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1085
Views
0
Helpful
7
Replies
Michal Garcarz
Cisco Employee

restconf and :8080

Hello Team,

 

Have NSO with FMC device registered - using via CLI (for testing only) - all working fine.

I wanted to use restconf for my application.

But i do not see and process listening on tcp/8080:

Screen Shot 2018-10-05 at 21.38.31.png

Also config file looks like this:

Screen Shot 2018-10-06 at 09.35.49.png

Pretty default/standard install.

Why there is no webgui nor restconf ? What do i miss ?

Thanks,

Michal

1 ACCEPTED SOLUTION

Accepted Solutions

Additionally it was determined that the TCP port for 8080 was disabled in the conf. Reenabling and rebooting solved the issue.

View solution in original post

7 REPLIES 7
Jan Lindblad
Cisco Employee

If you remove your -c option to netstat, I'm sure you'll see it. Did you try connecting your browser to localhost:8080?

Hi Jan,

Thanks for the help here.

It looks like we have no process listening on 8080.

Screen Shot 2018-10-08 at 14.13.01.png

the same also with lsof:

Screen Shot 2018-10-08 at 14.14.02.png

telnet gives the same result as curl.

Should it work out of the box ? Or maybe there is something i should configure after deploying NSO ?

(when i was playing in the lab with the old NSO version, around 4.1-4.2 i had web interfaces and did not remember to install anything extra, it was out of the box).

Now with 4.6.2 it is not....

Thanks,

Michal

This depends entirely on your ncs.conf file. If you are running any of the NSO examples, then yes, the webui would be enabled out of the box. Did you change the ncs.conf file after starting NSO? If so, "ncs --reload".

 

On my system "lsof -n" calls 8080 "http-alt":

ncs.smp   57089 jlindbla   92u     IPv4 0xca5b712a925f347d          0t0        TCP *:http-alt (LISTEN)

 

Hi Jan,

 

Yes - this is default 4.6.2 install, no changes to nso.conf, very default install. And i can confirm no process listening on tcp/8080. ncs --reload did no help.

I will open a TAC case for this and update you here on the results.

 

Thanks !

I have noticed that sometimes nso seems to “back off”, so that if 8080 is taken when nso starts, it will not bind to it, even if it later becomes free.

You can try doing “show ncs-state rest” or “show ncs-state webui” in NSO as well.

Hi Viktor, Team

Thank you for the help here.

I have opened TAC case 685381128.

ncs --reload did not help but....

After we rebooted whole VM the problem is gone. We can see process listening on tcp/8080.

Certainly some problem here.

Will keep in monitoring status for 1 week.

 

Thanks,

Michal

Additionally it was determined that the TCP port for 8080 was disabled in the conf. Reenabling and rebooting solved the issue.

View solution in original post