cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Please be advised, the GuideMe Wizard is no longer available on the Small Business Support Community. For search capability please use the community search field to find content related to Cisco Small Business documents, videos, and discussions.
511
Views
0
Helpful
1
Replies
Beginner

Using SG300 in conjunction with Asus RT-AC68U

I have racked my brain and exhausted Google trying to figure out how to get my SG300 switch working properly with my Asus RT-AC68U router.

Basically speaking, I just want my switch to allow my router to serve DHCP addresses. I haven't done any special configuration to the switch, though I have played with some settings in an attempt to get it to work.

Right now I have the unit factory reset in my office. I have an Arris SURFboard SB183 cable modem plugged into it directly. I have my router—located in the kitchen—connected to the switch as well via Cat6 cable. When the router is connected directly to the cable modem, I have zero issues. Once I plugged everything into the switch, though, nothing else going through the switch sees a DHCP address from the router.

I have tried many things, including disabling VLAN and switching from L2 to L3. I made sure the switch had a default gateway (192.168.1.1) that pointed back to my router, and I have an IP routing table entry in the router to point to my switch (192.168.1.201).

I kind of just want this to function like a dumb switch in my office, though I wouldn't mind being able to use its expanded capabilities if I can just get it working. What am I doing wrong?

Everyone's tags (1)
1 REPLY 1
Highlighted
Contributor

Hmm. This is just a guess,

Hmm. This is just a guess, but maybe the modem and router both serve DHCP and conflict?  You wouldn't have had this problem before because the modem would server DHCP to the WAN port of your router and then the router would serve DHCP to your clients.  

So. plug your router WAN port into your modem and the LAN port of your router into your switch and you should be good.

Also, if you want it to act like a dumb switch, I would factory default it again and then before connecting anything log in and run the global command 'macro auto disabled'  This will ensure the switch doesn't do any 'magic' and change port settings in a way you might not expect or desire.

-- please remember to rate and mark answered helpful posts --
CreatePlease to create content
Small Business community Righttrail
Cisco Partner Design Support

Cisco Small Business Partner Design Support offers access to a team of engineers focused on Cisco Small Business products best practices to our partners.  For more information and to access the Partner Design Online Chat, click here. (partner login required)

This widget could not be displayed.