cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
144
Views
0
Helpful
6
Replies
Highlighted

Specific License Reservation update licenses not working

I have a 4400 series router which is airgapped and registered for SLR.  In the past someone has provisioned it with licenses and it works OK.  I have access to the smart licensing account which 'owns' the platform and have confirmed it's the right UDI.  I now need to add further licenses to the box - but can't get it to happen.

If I regenerate the [existing] auth code, transfer it (by TFTP) to the platform, copy the file to flash and attempt to load it, the install command throws an error 'failed to validate the universal reservation authorisation code for UDI <the correct UDI>' and 'the reservation authorisation code does not match the reservation request code'.

Adding a license to the complement and generating a new auth code gives the same error. 

 

This happens for *every* other platform in the account (I tried a few), so I presume something fundamental has gone wrong. 

Note - if possible I want to avoid the nuclear option of deregistering, because then things will stop working and it will take some time to re-register and reprovision.

 

Has anyone seen this before, and if so do you know of a solution?

Thanks

6 REPLIES 6
Highlighted
VIP Expert

Can you post device model and show version and show License all to have a look ?

 

 



BB


*** Rate All Helpful Responses ***

Highlighted

Not immediately, because it is airgapped.  Is there any particular part of the output from 'show license all' which you'd want to be looking at?

Highlighted

i am more interested look and understand "show version"

 

here is some reference :

 

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/smart-licensing/qsg/b_Smart_Licensing_QuickStart/b_Smart_Licensing_QuickStart_chapter_01000.html

 



BB


*** Rate All Helpful Responses ***

Highlighted

Thanks for the link.

'Show version' shows the device is running IOS XE 16.12.03

X86-64_Linux-iosd-universalk9-m

release software (fc5)

compiled 9-mar-20 by mcpre.

 

Suite license info  for 'esg'

foundationsuitek9  none  Smart  none

securityk9

appxk9

AdvUCSsuitek9  none  Smart  none

uck9

cme-srst

cube

 

Technology package licenses

uck9  Smart license

ipbasek9  Smart license

 

Smart licensing status registered-specific license reservation / not authorised

 

-----------------------------------------

A different device, which I have the SAME problem with, is otherwise identical but shows the Smart licensing status as

registered - specific license registration / authorised - reserved.

 

 

Highlighted
VIP Expert

Highlighted

Thanks for the link.  I have read through it.  However, I can't see anything to apply to this case.  Is there something specific I should try?

Content for Community-Ad