cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2529
Views
0
Helpful
6
Replies
Beginner

Fiber link problem 2960

Hello all,

First off all I'm not that experienced with Cisco and networking in general so bear with me.

I recently bought a new WS-C2960-48PST-L which has 2 copper and 2 fiber uplinks.

Anyways let me explain the current setup first

Core switch 3750---media converter---patchpanel---MMF---patchpanel---media converter---Cisco 2960

I hope this make sense.

So since media converters annoy me and I still had a GLC-SX-MM SFP I decided to plug in the switch and directly attach the fiber cable to the switch. So I have one fault tolerance less (media converters tend to break alot). But somehow the link on the 2960 doesn't go up.But if I use the media converter with a utp in gi0/3 it works. The SFP gi0/1 has auto speed/duplex.

I dont know what the problem is maybe because 1 side still has a media converter?

This is the config of the 2960

! Last configuration change at 14:23:04 GMT Tue Jan 15 2013

! NVRAM config last updated at 14:24:04 GMT Tue Jan 15 2013

!

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname alrswcc11

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$D4zA$lxRfIWblbTjWpRyvD6unz.

!

no aaa new-model

clock timezone GMT 1 0

clock summer-time GMT recurring

system mtu routing 1500

!

!

crypto pki trustpoint TP-self-signed-3347807616

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3347807616

revocation-check none

rsakeypair TP-self-signed-3347807616

!

!

crypto pki certificate chain TP-self-signed-3347807616

certificate self-signed 01 nvram:IOS-Self-Sig#1.cer

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

!

!

!

interface FastEthernet0/1

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/2

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/3

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/4

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/5

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/6

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/7

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/8

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/9

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/10

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/11

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/12

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/13

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/14

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/15

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/16

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/17

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/18

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/19

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/20

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/21

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/22

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/23

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/24

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/25

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/26

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/27

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/28

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/29

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/30

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/31

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/32

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/33

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/34

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/35

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/36

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/37

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/38

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/39

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/40

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/41

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/42

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/43

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/44

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/45

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/46

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/47

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface FastEthernet0/48

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface GigabitEthernet0/1

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface GigabitEthernet0/2

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface Vlan1

ip address 10.250.12.12 255.255.255.0

no ip route-cache

!

ip http server

ip http secure-server

logging esm config

access-list 1 permit 10.250.0.2

snmp-server community ciscoro RO 1

!

line con 0

password 7 00051F140B5D0C575D720D

login

line vty 0 4

password 7 14161E1903022D7A767B72

login

line vty 5 15

password 7 14161E1903022D7A767B72

login

!

ntp server 192.168.1.78

end

Any ideas?

Thanks in advance!

Kind regards,

Michael

6 REPLIES 6
Highlighted
Cisco Employee

Fiber link problem 2960

Michael,

Are the SFP's the same in both switches? I am thinking your issue is most likely an optical power issue without the media converters. The specs for the GLC-SX-MM(1000BASE-SX) are:

TX -3 to -9.5dBm.

Rx is 0 to -17dBM.

Do you have the specs on the media converters? If they are putting out a higher Tx or have a lower threshold on their Rx port then that is the reason they will work with the media converters(even just one). Do you have the distance or loss across the MMF between the two sites?

Also a good test on the SFP's would be to loop them back on themself to make sure the port on the switch comes up/up looped.

If you have an optical light meter that supports 850nm you could use this to verify the fibering between the router and the FDP panel is okay as well by taking power readings at the FDP and at the router to see if the light levels are within spec mentioned above.

Hope this gets you started in the right direction.

Thanks,

Ryan

Hall of Fame Master

Re: Fiber link problem 2960

Michael.

The 2960 is a bit unusual in its use of dual-purpose uplink ports. Please have a look at the notes here describing their operational characteristics. You also sometimes need to explicitly specify "speed 1000" when using SX transceivers (even though they only operate at one speed - it's an IOS thing).

If you continue to have issues after taking the points there into considrations, please post the "show int gi0/1" and "show int status | i Gi" output with the GLC-SX-MM SFP in place.

Hope this helps.

Beginner

Fiber link problem 2960

Ryan, mklemovitch

Thank you for your response

Wel I am only using one SFP in the new 2960. The 3750  core switch is still using a media converter. Could that be the problem?  Both sides need an SFP or it doesn't matter?

Because atm at both sides I'm using this converter:

http://www.signamax.com/mediaconverters/5-10100basettx-to-100basefx-converters

Type: LED

Wavelength: 1300 nm nominal (1270 nm maximum, 1380 nm minimum)

Maximum Output Power: - 14.0 dBm

Minimum Output Power: - 20.0 dBm

Sensitivity: -33.0 dBm

Maximum Input Power: - 8.0 dBm

Link Power Budget: 13.0 dB

When using an SFP on the 2960 I get no signal.

I have no idea about the distance but I am sure it's less than 550 metrs. Unfortunately I dont have an optical light meter.

I can only think of 3 possible problems:

1) One side a media converter and the other an SFP doesn't work together

2) The SFP isn't the correct one

3) My settings in the switch are incorrect.

I will try and explicitly specify "speed 1000" and see if it works. If it doesn't I will post the outcome of gi0.

Again thank you for helping me!

Kind regards,

Michael

Hall of Fame Master

Fiber link problem 2960

Oh I see your issue.

The media converter end is 100 Mbps. Your SFP is 1 Gbps. With that media converter you would need to use a 100 Mbps SFP. See Table 6 here for compatible 100 Mbps SFPs.

An SFP transceiver's optics only run at a fixed speed. The one you are using is 1 Gbps and it will never link optically with a 100 Mbps media converter.

Beginner

Fiber link problem 2960

I see. I had a slight suspicion that that was the problem. I didn't know the SFP would run at a fixed speed, I thought it could also automatically operate at 100 Mbps. Guess I should have done my homework better :-)

Also I think the best thing I could do now is buy one for the 3750 too but that would be a Gbic because the SFP is too small.

Thank you

Regards,

Michael

Hall of Fame Master

Fiber link problem 2960

You're welcome.

Please rate your question as answered and the replies if it helped.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards


This widget could not be displayed.