Showing results for 
Search instead for 
Did you mean: 

cisco 2960X not recognizing SP-10G-SR modules

I have a WS-C2960X-48LPD-L with two 1 GB uplinks/downlinks conected to Cisco two 4500 backbone devices. Recently we installed Om3 fiber over all building and we tried to install SFP-10G-SR modules on the tengigabit ports. One of them  (1/0/1) works the other (1/0/2) don't. We made all king of things, inverting modules, inverting fibers, etc.etc, and "show int" shows always the same that the second port is administrative down and link down.  Other amazing thing is that the command "show interface transceivers" say they are no present, none of them. The image of device is Cisco IOS Software, C2960X Software (C2960X-UNIVERSALK9-M), Version 15.2(3)E1, RELEASE SOFTWARE (fc3).  What can we do?


VIP Master

One of them  (1/0/1) works the other (1/0/2) don't

1/0/1 - works with 10G-SR ? did this show show interface ten 1/0/1 trans output correct ? As you mentioned none, but checking)

what happends if the same SFP used 1/0/1 and plug in 1/0/2 ?is this works ? same case not working SFP plug in to 1/0/1 is this recognises ?


Is the same interface used before for 1GB uplink ? default the interface and try ? when you Plug SFP what Logs you see on the console.




***** Rate All Helpful Responses *****

How to Ask The Community for Help

when I try "show interface trans" I receive "no transceiver present". When I try each one with "show interface te 1/0/1 trans" I receive "Diagnostic monitoring is not implemented". The same with int te 1/0/2.

I inverted SFP's (both are the same Cisco model 10G-SR), none of them work. But nw, when I want back to original positions, none of them work.

It is not the same interface when I worked with 1GB. In fact, now it came back to work with ports 47 and 48 (1 GB each) because they where installed just in case. Working port now is 48 bacause, as per spanning tree definitions it became root as soon as I pulled the SFP+ 10GB out.

Leo Laohoo
VIP Community Legend

Upgrade the firmware of the switch and try again.

I can understand, Looking at some document here :


15.2(6) - may offer some fixes - i do not have 2960 to offer any testing now - when you get chance upgrade and test.



***** Rate All Helpful Responses *****

How to Ask The Community for Help


did you resolve your issues .....?