Showing results for 
Search instead for 
Did you mean: 

Cisco 3945 with SFP - full duplex possible?

My provider (Deutsche Telekom) is only able to hand over a 1Gbps-Link with speed und full-duplex configured fix.

To force the router (cisco 3945) for 1000/full, I had to remove the 'media-type sfp'

SFP is MM-SX on Router-Interface Gi0/2

This configuration worked a while but shows many interface resets (more than 30 in one minute).

Telekom confirmed, their connection is working properly.

After switching the router off an on, I could no longer connect with telnet or ssh. Ping is also not successful but cdp shows the neighbor router!?!

Maybe this is a problem with SFP and duplex configuration.

Any ideas?


with Gigabit there is only full. But it could also be the software. A customer of us has had almost the same problems and by a software update the problem was repaired.

my problem is that my cisco router 3845-MB has its interface gig0/0 down. admistratively down. the ios version is the 12.4(20)T4 ,do i upgrade the version? if yes which one doesnt have a such bug.

thanks to reply


have you tried the command speed nonegotiate under the interface?

*speed nonegotiate* is not available to configure

Software-Update to 151-2.T1 did not solve the issue, either :-(

Leo Laohoo
VIP Community Legend

A GLC-SX-MM will always negotiate to full 1G.


After replacing the 3945 with a 3845 the Link is up and running - without any 'interface resets'

Hi, I'm facing a similar issue with a 3845 with GLC-SX-MM module trying to connect at 100Mbps with a telco device. Documentations says 'media-type sfp' defaults to 1Gig, and only changing to 'media-type rj45' would allow me to set 100Mbps instead. Any clue what should I do in order to allow speed compatibility with this telco device ? Follows the current interface config:

Interface GigabitEthernet0/0

description ---

bandwidth 100000

no ip address

duplex auto

speed 1000

media-type sfp

negotiation auto


with IOS version 15.0(1)M4 the Gig interface can be left on speed/duplex autosensing mode. Its default is to connect with 1000/full, again.

IOS versions before connected with half-duplex.

The new software fixed the Bug CSCtj35792

the command 'no negotiation auto' should fix your issue

on a 3845

In order to connect to a 100BaseFX link, you will need to install a GLC-GE-100FX SFP module in your 3945 switch.  This 100M SFP module is designed to be installed in a GE SFP slot.

If, in the future, you want to support GE on the 3945 switch's port, you will have to change the SFP to a compatible GE module.

Hope this helps!


the request was to connect a 1000/full link.

After the software update it works without any problems

Did Router 3945 SFP Port support SFP-10G-LR, How to define it ?

You can check the compatibility documents to find out which pluggable optics modules are supported on your platform.

It does not list any 10Gbps pluggable optics options for the 3945 router.