Showing results for 
Search instead for 
Did you mean: 

7970 lost its firmware load


Since upgrading our cme lab to version 12.4(11)T our 7970 got stuck on "configuring ip", after extensive searching I eventually followed the procedure to reset to factory defaults, however when you power up the phone the headset button is lit green and the buttons just cycle through green constantly, firmware is loaded in flash and tftp server is configured with the right firmware as well as the load command under telephony service, we have other 7860's and 7912's in the lab which get there ip info no problem, any ideas ?

I have tried deleting the firmware from flash and tried loading earlier versions of firmware but the phone has the same problems, i cant get to the settings menu to view the network configs

Thanks in advance

3 Replies 3


hi mark:

i am oscar and i comment you that ,i put it 7970 into cme but never work?s,

( i mean firmware ok but the ipphone never give me the extension number, always keept in registering state altoght never could make calls for that register state)

i put in factory default in stay in that state that you says (green led moving)

i had the same problem in a cme i solve the firmware situation with this (i must suppose that your phone stay in state booting ...understanding color green led move around the key buttons at right hand of display ip 7970) but never i get it work with extension number can you help me with that

well after too much explanation here goes the solution

connect the ip phone 7970 into a Call Manager and assure the stay in dhcp default and you will see the ip phone is going to live firmware is passed at ipphone and the ipphone goes to work into CM

now you must to take it and move it to your CMExpress and try if is working into this box with cme

i hope this help to you to solve your problem

i wait your comments via email or for here

sorry for my errors ortographics

any comment is well received

Unfortunately we do not have a callmanager system to move the 7970 too, you are right in stating that the phone seems to be constantly in some sort of boot cycle process, the headset button is permantley lit green and the line keys to the right of the phone just cycle green continuosly, cisco's response to this behaviour is to reset the phone to factory defaults which I have done several times but it has no affect.

Thanks for your response


if you can you can go to another system and try to configure and you will see that the firmware is passed to your phone ....and then back to your system CME and try to verify i told you... the same passed to me and it was the only way the i come in back

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers