cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
399
Views
0
Helpful
1
Replies
Enthusiast

CME 12 can't get 8945 SCCP phone to register

I have another router (3945) that uses 7975 SCCP phones and works great!.  I am now trying to setup a 2911 CME router using 8945 SCCP phones and they just will not register.  Here are some screen shots of the phones:  I bought these phones used and no idea where they came from (not eBay).

1.jpg

VPN error?  No vpn configured here.g3-tones.xml where does one get this file?

11.jpg12.jpg

I reset to factory and I made sure there are no ITL;s installed as you can see above.  Yet, it looks like the phone is looking for one.

Below is everything for reviewing.

Directory of flash0:/PhoneFiles/8945/

126 -rw- 728 Jun 1 2019 20:29:04 +00:00 SCCP894x.9-4-2SR3-1.loads
127 -rw- 111552 Jun 1 2019 20:29:38 +00:00 BOOT894x.0-0-2-0.bin.sgn
128 -rw- 3145120 Jun 1 2019 20:31:52 +00:00 SCCP894x.9-4-2SR3-1.bin1.sgn
129 -rw- 3145120 Jun 1 2019 20:32:12 +00:00 SCCP894x.9-4-2SR3-1.bin2.sgn
130 -rw- 3145120 Jun 1 2019 20:32:26 +00:00 SCCP894x.9-4-2SR3-1.bin3.sgn
131 -rw- 3145120 Jun 1 2019 20:33:08 +00:00 SCCP894x.9-4-2SR3-1.bin4.sgn
132 -rw- 3145120 Jun 1 2019 20:33:22 +00:00 SCCP894x.9-4-2SR3-1.bin5.sgn
133 -rw- 3145120 Jun 1 2019 20:33:42 +00:00 SCCP894x.9-4-2SR3-1.bin6.sgn
134 -rw- 3145120 Jun 1 2019 20:34:08 +00:00 SCCP894x.9-4-2SR3-1.bin7.sgn
135 -rw- 3145120 Jun 1 2019 20:34:20 +00:00 SCCP894x.9-4-2SR3-1.bin8.sgn
136 -rw- 3145120 Jun 1 2019 20:34:34 +00:00 SCCP894x.9-4-2SR3-1.bin9.sgn
137 -rw- 202840 Jun 1 2019 20:34:42 +00:00 SCCP894x.9-4-2SR3-1.bin10.sgn

 

Router#sh ephone

ephone-12[11] Mac:7081.0585.87A0 TCP socket:[-1] activeLine:0 whisperLine:0 UNREGISTERED
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:0
IP:0.0.0.0* 0 Unknown 0 keepalive 0 max_line 0 available_line 0
button 1: cw:1 ccw:(0 0)
dn 12 number 1102 CH1 DOWN CH2 DOWN
button 2: cw:1 ccw:(0 0 0 0 0 0 0 0)
dn 1 number 1100 CH1 DOWN CH2 DOWN CH3 DOWN CH4 DOWN CH5 DOWN CH6 DOWN CH7 DOWN CH8 DOWN
button 3: cw:1 ccw:(0)
dn 30 number A2100 auto dial A2101 CH1 DOWN
Preferred Codec: g711ulaw
Lpcor Type: none Username: man Password: 123456

ephone-13[12] Mac:7081.0585.8718 TCP socket:[-1] activeLine:0 whisperLine:0 UNREGISTERED
mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:0
IP:0.0.0.0* 0 Unknown 0 keepalive 0 max_line 0 available_line 0
button 1: cw:1 ccw:(0 0)
dn 13 number 1103 CH1 DOWN CH2 DOWN
button 2: cw:1 ccw:(0 0 0 0 0 0 0 0)
dn 1 number 1100 CH1 DOWN CH2 DOWN CH3 DOWN CH4 DOWN CH5 DOWN CH6 DOWN CH7 DOWN CH8 DOWN
button 3: cw:1 ccw:(0)
dn 31 number A2101 auto dial A2100 CH1 DOWN
Preferred Codec: g711ulaw
Lpcor Type: none Username: Lady Password: 123456

Router#sh ip dhcp bind
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
192.168.201.25 0170.8105.8587.a0 Jun 02 2019 08:59 AM Automatic
192.168.201.26 0170.8105.8587.18 Jun 02 2019 08:57 AM Automatic

 

Router#debug tftp events
Jun 1 23:09:04.973: TFTP: Looking for English_United_States/gb-sccp-sip.jar
Jun 1 23:09:05.149: TFTP: Looking for United_States/g3-tones.xml
Jun 1 23:09:13.477: TFTP: Looking for CTLSEP7081058587A0.tlv
Jun 1 23:09:13.517: TFTP: Looking for ITLSEP7081058587A0.tlv
Jun 1 23:09:13.557: TFTP: Looking for ITLFile.tlv
Jun 1 23:09:13.729: TFTP: Looking for SEP7081058587A0.cnf.xml
Jun 1 23:09:13.729: TFTP: Opened system:/its/vrf1/XMLDefault8945.cnf.xml, fd 0, size 1800 for process 517
Jun 1 23:09:13.733: TFTP: Finished system:/its/vrf1/XMLDefault8945.cnf.xml, time 00:00:00 for process 517

 


Current configuration : 23698 bytes
!
! Last configuration change at 20:51:42 UTC Sat Jun 1 2019
! NVRAM config last updated at 20:35:44 UTC Sat Jun 1 2019
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip dhcp excluded-address 192.168.101.1 192.168.101.20
ip dhcp excluded-address 192.168.201.1 192.168.201.20
!
ip dhcp pool Users
network 192.168.101.0 255.255.255.0
dns-server 1.1.1.1
default-router 192.168.101.1
option 150 ip 192.168.201.1
lease 0 12
!
ip dhcp pool Voice
network 192.168.201.0 255.255.255.0
dns-server 1.1.1.1
default-router 192.168.201.1
option 150 ip 192.168.201.1
lease 0 12
!
ip domain lookup source-interface GigabitEthernet0/0
ip name-server 1.1.1.1
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
voice-card 0
dsp services dspfarm
!
voice service voip
ip address trusted list
ipv4 999.999.149.69
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
redirect ip2ip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
registrar server
!
voice class codec 1
codec preference 1 g711ulaw
!
voice register global
default mode
no allow-hash-in-dn
!
license udi pid CISCO2911/K9 sn FTX1603AKZK
hw-module pvdm 0/0
!
dial-control-mib retain-timer 10080
dial-control-mib max-size 500
!
redundancy
!
interface GigabitEthernet0/0
description "Internet"
ip address dhcp
ip nat outside
ip nat enable
ip virtual-reassembly in
no ip route-cache
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
no ip route-cache
duplex auto
speed auto
!
interface GigabitEthernet0/1.101
description Data Network
encapsulation dot1Q 101 native
ip address 192.168.101.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
no ip route-cache
!
interface GigabitEthernet0/1.201
description Voice Network
encapsulation dot1Q 201
ip address 192.168.201.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
no ip route-cache
!
router eigrp 9001
network 192.168.101.0
network 192.168.201.0
!
ip forward-protocol nd
!
ip http server
ip http authentication aaa login-authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:/GUI
!
ip nat inside source list 10 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
logging history size 500
ipv6 ioam timestamp
!
tftp-server flash0:/PhoneFiles/8945/BOOT894x.0-0-2-0.bin.sgn alias BOOT894x.0-0-2-0.bin.sgn
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.loads alias SCCP894x.9-4-2SR3-1.loads
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.bin1.sgn alias SCCP894x.9-4-2SR3-1.bin1.sgn
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.bin2.sgn alias SCCP894x.9-4-2SR3-1.bin2.sgn
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.bin3.sgn alias SCCP894x.9-4-2SR3-1.bin3.sgn
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.bin4.sgn alias SCCP894x.9-4-2SR3-1.bin4.sgn
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.bin5.sgn alias SCCP894x.9-4-2SR3-1.bin5.sgn
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.bin6.sgn alias SCCP894x.9-4-2SR3-1.bin6.sgn
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.bin7.sgn alias SCCP894x.9-4-2SR3-1.bin7.sgn
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.bin8.sgn alias SCCP894x.9-4-2SR3-1.bin8.sgn
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.bin9.sgn alias SCCP894x.9-4-2SR3-1.bin9.sgn
tftp-server flash0:/PhoneFiles/8945/SCCP894x.9-4-2SR3-1.bin10.sgn alias SCCP894x.9-4-2SR3-1.bin10.sgn
access-list 10 remark Networks Allowed onto the Internet
access-list 10 permit 192.168.101.0 0.0.0.255
access-list 10 permit 192.168.201.0 0.0.0.255
!
control-plane
!
voice-port 0/0/0
!
voice-port 0/0/1
!
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/1.201
sccp ccm 192.168.201.1 identifier 1 priority 1 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register TDCCONF
associate profile 2 register tdxcode
!
no ccm-manager fax protocol cisco
!
dspfarm profile 2 transcode
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
codec pass-through
codec g729br8
codec ilbc
codec g729r8
codec g722-64
maximum sessions 4
associate application SCCP
!
dspfarm profile 1 conference
codec g729br8
codec g729r8
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 1
associate application SCCP
!
dial-peer cor custom
name LoK_Local
name LoK_National
name LoK_International
name LoK_EMS
!
dial-peer cor list Keyring-Local
member LoK_Local
member LoK_EMS
!
dial-peer cor list Keyring-National
member LoK_Local
member LoK_National
member LoK_EMS
!
dial-peer cor list Keyring-International
member LoK_Local
member LoK_National
member LoK_International
member LoK_EMS
!
dial-peer cor list Keyring-EMS-Only
member LoK_EMS
!
dial-peer cor list Door-Local
member LoK_Local
member LoK_EMS
!
dial-peer cor list Door-National
member LoK_Local
member LoK_National
member LoK_EMS
!
dial-peer cor list Door-International
member LoK_Local
member LoK_National
member LoK_International
member LoK_EMS
!
dial-peer cor list Door-EMS-Only
member LoK_EMS
!
dial-peer voice 100 voip
description *** Incoming Calls VoIP ***
translation-profile incoming Incoming_calls
call-block translation-profile incoming BLOCK-INCOMING
call-block disconnect-cause incoming call-reject
preference 1
session protocol sipv2
session target sip-server
incoming called-number .
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 200 voip
corlist outgoing Door-National
description *** Outbound 11 Digit Dialing Calls ***
translation-profile outgoing Eleven_Digit_Dialing
preference 1
destination-pattern 1[2-9]..[2-9]......$
b2bua
session protocol sipv2
session target sip-server
dtmf-relay sip-notify
codec g711ulaw
no vad
!
gateway
timer receive-rtp 1200
!
sip-ua
credentials username 9610 password 7 03195058 realm anveo.com
authentication username 96810 password 7 151406A74 realm anveo.com
mwi-server ipv4:192.168.200.2 expires 3600 port 5060 transport udp unsolicited
registrar dns:sip.anveo.com:5010 expires 180
sip-server dns:sip.anveo.com:5010
!
gatekeeper
shutdown
!
telephony-service
sdspfarm units 2
sdspfarm tag 1 TDCCONF
sdspfarm tag 2 tdxcode
conference hardware
authentication credential mdurham Education$1
max-ephones 10
max-dn 100
ip source-address 192.168.201.1 port 2000
service phone daysDisplayNotActive 1,7
service phone displayOnTime 08:00
service phone displayOnDuration 12
service phone displayIdleTimeout 00:10
service phone settingsAccess 1
service phone modeOfOperation 1
service phone displaywhebincomingcall 1
service phone webAccess 0
service phone ehookEnable 1
service phone displayOnWhenIncomingCall 1
system message DEMO_CME
url services http://192.168.201.10/voiceview/common/login.do
url authentication http://192.168.201.1/CCMCIP/authenticate.asp
load 8945 SCCP894x.9-4-2SR3-1.loads
time-zone 12
voicemail 5000
mwi relay
max-conferences 4 gain -6
call-park system redirect
call-park system application
moh enable-g711 "flash:/Audio/music-on-hold.au"
multicast moh 239.2.2.2 port 2000
web admin system name Admin password Cisco
web admin customer name Customer password 123456
dn-webedit
time-webedit
transfer-system full-consult
after-hours block pattern 1 1010 7-24
after-hours block pattern 2 1900 7-24
fac standard
create cnf-files version-stamp 7960 Jun 01 2019 20:51:37
!
ephone-template 1
softkeys remote-in-use CBarge Newcall
softkeys hold Resume Newcall Join
softkeys idle Redial Newcall Cfwdall Dnd Mobility Pickup Join
softkeys connected Hold Endcall Park Trnsfer Confrn Join Select Mobility ConfList Acct
!
ephone-dn 1 octo-line
number 1100 no-reg both
label Demo Company
name Demo Corp
mobility
snr calling-number local
snr 3525551212 delay 1 timeout 25 cfwd-noan 5000
snr ring-stop
call-forward busy 5000
call-forward noan 5000 timeout 25
corlist incoming Keyring-National
hold-alert 45 originator
!
ephone-dn 12 dual-line
number 1102 no-reg both
label Boss Man
description Boss Man
name Boss Man
snr calling-number local
call-forward busy 5000
call-forward noan 5000 timeout 25
corlist incoming Keyring-International
!
ephone-dn 13 dual-line
number 1103 no-reg both
label Lady Boss
description Lady Boss
name Lady Boss
call-forward busy 5000
call-forward noan 5000 timeout 10
corlist incoming Keyring-National
!
ephone-dn 30
number A2100 no-reg both
description Intercom from Man Office to Lady
intercom A2101 no-mute label "Lady Boss Intercom"
!
ephone-dn 31
number A2101 no-reg both
description Intercom from Lady to Man
intercom A2100 no-mute label "Boss Mans Intercom"
!
ephone-dn 90
number 3000 no-reg both
park-slot timeout 45 limit 3 recall retry 2 limit 1
!
ephone-dn 98 octo-line
number AA01 no-reg both
conference ad-hoc
!
ephone-dn 99
number 5998.... no-reg both
mwi off
!
ephone-dn 100
number 5999.... no-reg both
mwi on
!
ephone 12
privacy off
device-security-mode none
description Boss Man
mac-address 7081.0585.87A0
ephone-template 1
username "man" password 123456
type 8945
auto-line 2 answer-incoming
mwi-line 1
button 1:12 2:1 3:30
!
ephone 13
privacy off
device-security-mode none
description Lady Boss
mac-address 7081.0585.8718
ephone-template 1
username "Lady" password 123456
type 8945
auto-line 2 answer-incoming
mwi-line 1
button 1:13 2:1 3:31
!
vstack
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
logging synchronous
login
terminal-type monitor
transport input ssh
transport output ssh
line vty 5 15
logging synchronous
login
terminal-type monitor
transport input ssh
transport output ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 103.105.51.156 minpoll 9
!
end

Everyone's tags (3)
1 REPLY 1
Highlighted
Enthusiast

Re: CME 12 can't get 8945 SCCP phone to register

I had bought the router used and did not realize that even thought it had the UC license, no one ever accepted it. Once I did, the phones started working.
I would delete this if I could.
CreatePlease to create content