cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

367
Views
0
Helpful
5
Replies
lwai
Beginner

CME IOS 12.3(14)T5 MOH Cannot Support Internal Phone

Cisco 3845 is running 12.3(14)T5, internal user could hold PSTN (outside) user with music, but internal user hold another internal user only hear two beep; no music at all.

Is that normal in CME??

Together, I could copied the additional ringer RAW files in ttftp-server flash, while I add the command "tftp-server flash:ringlist.xml", it show Warning: flash:ringlist.xml does not exist. Command retained.

But dir flash: indicate the files are listed.

Any expert know the way to solve it?

Or no addition ringer files could be used in CME. Thanks in advance!

5 REPLIES 5
JOHN SHOEMAKER
Beginner

Unfortunately, as of CME 3.3, internal MOH is not supported.

"Music on hold (MOH) is an audio stream that is played to PSTN and VoIP G.711 or G.729 callers who are placed on hold by phones in a Cisco CME system. This audio stream is intended to reassure callers that they are still connected to their calls. MOH is not played to local Cisco CME phones that are on hold with other Cisco CME phones; these parties hear a periodic repeating tone instead."

http://www.cisco.com/en/US/partner/products/sw/voicesw/ps4625/products_configuration_guide_chapter09186a00804ad866.html#wp2175028

I've used customized ringtones on CME in the past without issue. I'll check my documentation and post for you soon.

peter.rowe
Beginner

Hi there,

no this is not 'normal' but you are correct - it seems to be broken in 12.3(14)T5 - from memory it worked just fine in 12.3(14)T4 and T3

I use a streaming source and this is affected as well, however if you use Call Park, not hold, then the music plays as normal.

I'm afraid you'll have to wait for an IOS upgrade... sorry.

peter.

Hi i.shoemaker,

I had tried the IOS 12.3(14)T4, the same result in ringtones files and MOH.

Please post the stepes in setup customized ringtones, many thanks.

Peter, thanks for your comments.

Michael.

Hey Michael,

Im using 12.4(2)T1, but I'm pretty sure it will work the same on 12.3.

All you need are the correct files and the correct tftp path settings. I've attached a working ringlist file. Copy your ringtone audio file and RingList.xml file to flash, then use the global "tftp-server flash:RingList.xml". Make sure you also do this for your audio file: "tftp-server flash:testring.raw"

I think the the phone request for RingList.xml is case sensitive, so make sure it is exactly as typed here.

It's pretty easy to troubleshoot whether the phone finds the correct files. Run "debug tftp events" to see what the phone is trying to download. The debug will tell when the phone downloads the appropriate files. If you don't see this, then there is something wrong with the config.

The "ring type" menu on the phone will also display "RingList.xml" not found if it doesn't locate the file. Watch the debug and hit the ring type button, you should see the tftp request hit the router.

Hi i-shoemaker,

Thanks for your information!! It works now. The issue was solved.

The issue cause from the case sensitive of the files name. Thanks again for your supporting in this case!!

Create
Recognize Your Peers
Content for Community-Ad