Showing results for 
Search instead for 
Did you mean: 

Failed DMP Deployment

Level 1
Level 1

Failed DMP deployment of a video presentation containing 3 videos less than 50mb total.

DMM 5.2.2

DMP 4400

Error Message:

Not able to set FTP permissions.  Exception message is The IFMS DMP MIB utility could not connect to the DMP to  fetch the DMP's MIB.

I tried to ftp videos directly to the DMP and was unable to. The first video appeared to transfer. Then disappeared from the directory.

"ftp server" and "read and write" are on.

Anyone have any ideas what I'm doing wrong?

8 Replies 8

Cisco Employee
Cisco Employee

can you please check how much internal storage is available internally on DMP (this would show up in DMP page on left side--->internal storage). which FTP client did you use to transfer the file (try with core ftp client) ? after how long it disappears from the directory?

There were 2+gigs of internal storage remaining. I was using FileZilla to transfer. IT ended up pulling the unit. It also was not saving configuration changes.

Now that the box is not in production, can you take a backup and try to reimage the box with a  full iso image

Michael Sellers
Level 1
Level 1

I, too, am getting this error message.  The internal storage reads 2863/2667 in the DMM.  Running DMM 5.2.2 and DMP is 4400 running 5.2.2.  Tried using the content deployment task in the DMM.  It began processing, then failed.  The playlist used in the presentation is 18.7 MB according to the DMM, and consists of content on a separate server; all assets are created using URLs.

Level 1
Level 1

Does your DMP appears online in the DMP Manager?

I it doesn't it's a certificate problem. You should upgrade your DMP FW and, if possible, your DMM as well.


Thiago Fausto

I don't know if you're responding to my issue, but it does appear as online and accepts commands and displays presentations from the DMM.  If I need to upgrade the DMPs, should that be to  This DMM appliance will not work with 5.3.  Also, will the DMPs work with if the DMM is only 5.2.2?

Ok, so it's not a certificate problem.

You may try to check the DMP configuration. Flash must be in "Read/Write" mode, FTP must be activated and configured with a password.

If this is ok, try to verify te communication on ports 7777 (DMM<>DMP), 21 (FTP) and 22 (SFTP).

I am having a similar problem. Odd thing is that when I repeat the deployment steps manually it has not problem. This error only seems to work when I use the 'Play In Future' function.

You also mentioned setting FTP - since I can send manually would that confirm that the FPT setting are correct? The DMP management account and the FTP service use the same password but different user ids.