Showing results for 
Search instead for 
Did you mean: 


Incoming with pstn

Hello everyone,

Having this problem with call manager / ip telephony. I have a 2600 set up as a mgcp gateway. The 2600 has a fxo card. Both our outside lines are connected to this. Now I can make outgoing calls on both lines. But incoming calls are not getting through. The plane pots phones will ring once then I will get a fast busy signal on the outside line I am dialing in from. Any ideas remeber this is for a normal pstn line. I have been trying to get incoming for the last three weeks. I even opened a case but the gentlemen has not been very helpful so far.


Chester Rieman
Cisco Employee

Please send the mgcp portions of the config and the dial-peer portions of the config. Also try a debug mgcp packet and see what you get on the incoming call.


We've done this with CallManager 3.2 in all cases, except for during SRST fallback. In our case we have each FXO going directly to a given IP phone. The key thing to make sure is that in Call Manager Gateway Configuration under Port Information that select direction as 'bothways' and supply the directory number of the IP phone in the Attendant DN field. Be sure that you have the correct version of IOS in the 2600 - there are several trains and not all have full MGCP support yet. Check your outbound calling also to make sure you are getting timely disconnect - we had to turn on supervisory disconnect dualtone to get quick disconnect on our loop-start pstn lines.


Was there a resolution to this? I am having the same problem on a MGCP configured 2821. The gateway FXO port is configured on the callmanager as direction 'bothways' and supplied with a directory number of a IP phone in the Attendant DN field. I can make outgoing but incoming receives one ring then fast busy. Callmanager is 4.2.1sr1a and the IOS on the 2821 is 12.4.9T. Thanks in advance!

I recently found a problem with the 12.4.9T IOS when trying to set the router up as an MGCP gateway with FXO ports. I am running CallManager 5.0 and 2821 routers. The PRI circuits register with the CallManager, but the FXO ports show up as registration rejected, however when I do a show ccm in the router it shows registered. I also tried IOS 12.4.8 and received the same results. I was only able to get it to work properly by using an older IOS. I used 12.3.11.T10. I was trying to use the 12.4.9 due to a bug in older DSPware versions for echo problems. Just thought I'd post my latest issue in case it would help someone else. If anyone has another solution to the registration problem I would really like to know about it.



We hit the same problem. Did Cisco ever put out a bug notice for this?

Just FYI, we were running 12.3(11)T11 SP SERVICES, CCM 4.1(3)sr4b with no FXO ports (Just a bunch of VWIC-2MFT-T1s). After downgrading to 12.3(11)T10, we were fine. The symptoms seen were on one voice gateway PRIs would show as up on the VG, but not register in CCM. One the other VG, the PRIs registered and outbound calls worked fine, but incoming calls would either be busy drop after one ring. The Telco said they were seeing error 41 on call incoming calls.

On a side note, we're upgrading to a 3845 next month. Does anybody know if this bug affects the 3800 series as well?

Recognize Your Peers
Content for Community-Ad