cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Linux DHCP - offering TFTP IP Problem

darren.staples
Beginner
Beginner

we have a Linux DHCP server

which works great for everything except TFTP. Giving out DHCP address for TFTP address (instead of CCM address)

had the tfpt (0ption-150) pointing to "dns name", then changed it to the "IP Address" and that seemed to fix it....

It now back to giving out the DHCP address for the TFTP address - this happens on the 7960/40 sets, NOT the 7912 sets - they come up with the correct TFTP address (IP of CCM)

any ideas?

4 REPLIES 4

thisisshanky
Advisor
Advisor

So the 7940/7960 are getting a TFTP address, same as the DHCP server? I didnt quite understand the problem.

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

example

Callmanager (TFTP server) 10.19.17.1

DHCP server (Linux) 192.168.1.3

7914 phone will get 10.19.17.1 as TFTP

7940/60 will get 192.168.17.1 as TFTP

Vlan interface ip helper is Linux box 192.168.1.3

which has scopes for voice and Data vlans

voice vlan contains

- IP address

- subnet mask

- gateway

- domain name

- TFTP server

Set option 66 (boot server hostname), to the hostname of the CallManager. You can also leave it's IP for option 150.

Then make sure, you also set DNS server and domain as DHCP options, and that your DNS server can resolve correctly the hostname of the CallManager. If you don't have a DNS server, you can set up a simple one, that would just resolve that single name - that of the CCM.

For short, have a proper network setup, even if it "shouldn't matter". It does wonders to registration speed and functionality in general.

6rmisior
Beginner
Beginner

Hello,

I'm using linux dhpcd in our environment without any problems. Here are the pices that you need to add to your dhcpd.conf file

in the global section (top of the file) in my case the publisher is 10.70.0.1 and subscriber is 10.72.0.1

option option-150 code 150 = array of ip-address;

option option-150 10.70.0.1, 10.72.0.1;

in the subnet add option tftp-server-name "10.70.0.1";

subnet 10.70.0.0 netmask 255.255.0.0 {

pool {

option routers 10.70.0.254;

range 10.70.31.1 10.70.35.254;

option tftp-server-name "10.70.0.1";

}

}

Hope this helps.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: