cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4895
Views
0
Helpful
10
Replies
Beginner

Lync CUCM 8.6(1) Integration

I've been trying to integrate a Lync server with a Cisco CUCM using a Direct SIP trunk.  The key word there is trying.

I followed the Microsoft document for the integration of Lync with Cisco 8.5.  See attached file.

When I dial from the callmanager to the Lync, I see the traffic, I get the following error on the Lync Server.

TL_INFO(TF_PROTOCOL) [0]08E0.1794::09/19/2011-17:13:51.606.000108cc (SIPStack,SIPAdminLog::TraceProtocolRecord:SIPAdminLog.cpp(125))$$begin_record

Trace-Correlation-Id: 1854706246

Instance-Id: 00002C96

Direction: outgoing;source="local"

Peer: 172.16.200.100:60097

Message-Type: response

Start-Line: SIP/2.0 401 Unauthorized

From: <sip:8004@172.16.200.100>;tag=1055~2248b267-7874-4b2e-9b0f-b9e83134f64b-30262725

To: <sip:+19105557111@172.16.200.141>;tag=BC185DA828677767E1FE2F280D0D7FA3

CSeq: 101 INVITE

Call-ID:

38bb7180-e7713cb8-58-64c810ac@172.16.200.100

Date: Mon, 19 Sep 2011 17:13:51 GMT

WWW-Authenticate: NTLM realm="SIP Communications Service", targetname="WIN2008LYNC.ncnetworkers.com", version=4

WWW-Authenticate: Kerberos realm="SIP Communications Service", targetname="sip/WIN2008LYNC.ncnetworkers.com", version=4

WWW-Authenticate: TLS-DSK realm="SIP Communications Service", targetname="WIN2008LYNC.ncnetworkers.com", version=4, sts-uri="

https://WIN2008Lync.ncnetworkers.com:443/CertProv/CertProvisioningService.svc

"

Via: SIP/2.0/TCP 172.16.200.100:5060;branch=z9hG4bK58428bf502;ms-received-port=60097;ms-received-cid=CDB00

Server: RTC/4.0

Content-Length: 0

Message-Body: –

$$end_record

403 Forbidden

ms-diagnostics: 12004;reason="The user is not authorized to call the specified number.";source="LyncServer.mydomain.local";appName="OutboundRouting";OriginalPresenceState="0";CurrentPresenceState="0";MeInsideUser="Yes";ConversationInitiatedBy="0";SourceNetwork

TL_INFO(TF_PROTOCOL) [0]08E0.1794::09/19/2011-17:13:51.606.000108cc (SIPStack,SIPAdminLog::TraceProtocolRecord:SIPAdminLog.cpp(125))$$begin_record
Trace-Correlation-Id: 1854706246
Instance-Id: 00002C96
Direction: outgoing;source="local"
Peer: 172.16.200.100:60097
Message-Type: response
Start-Line: SIP/2.0 401 Unauthorized
From: <sip:8004@172.16.200.100>;tag=1055~2248b267-7874-4b2e-9b0f-b9e83134f64b-30262725
To: <sip:+19105557111@172.16.200.141>;tag=BC185DA828677767E1FE2F280D0D7FA3
CSeq: 101 INVITE
Call-ID: 38bb7180-e7713cb8-58-64c810ac@172.16.200.100
Date: Mon, 19 Sep 2011 17:13:51 GMT
WWW-Authenticate: NTLM realm="SIP Communications Service", targetname="WIN2008LYNC.ncnetworkers.com", version=4
WWW-Authenticate: Kerberos realm="SIP Communications Service", targetname="sip/WIN2008LYNC.ncnetworkers.com", version=4
WWW-Authenticate: TLS-DSK realm="SIP Communications Service", targetname="WIN2008LYNC.ncnetworkers.com", version=4, sts-uri="https://WIN2008Lync.ncnetworkers.com:443/CertProv/CertProvisioningService.svc"
Via: SIP/2.0/TCP 172.16.200.100:5060;branch=z9hG4bK58428bf502;ms-received-port=60097;ms-received-cid=CDB00
Server: RTC/4.0
Content-Length: 0
Message-Body: –
$$end_record

On the Lync client side I get a different error:

403 Forbidden
ms-diagnostics: 12004;reason="The user is not authorized to call the specified number.";source="LyncServer.mydomain.local";appName="OutboundRouting";OriginalPresenceState="0";CurrentPresenceState="0";MeInsideUser="Yes";ConversationInitiatedBy="0";SourceNetwork..

I can't make nor receive a call on either side of the trunk.  However, I have no issues calling from within each domain, Lync and Cisco.

Any help would be greatly appreciated,

Thanks,

Mitch

10 REPLIES 10
Highlighted

Lync CUCM 8.6(1) Integration

did you find a solution ?

Highlighted
Beginner

Lync CUCM 8.6(1) Integration

No I didn't.  I haven't had the time to go any further into this issue.  I do hope that the next few weeks provide me ith a bit of time to delve a bit deeper into this problem.

If/when I do sort this out, I will post the solution here.

Highlighted
Beginner

Lync CUCM 8.6(1) Integration

I ran into this same issue and found that by default Lync requires encryption and does not support SRTP with Cisco.

You should run the following commands on the Lync Server's -- Run As Administrator Lync Power Shell Window....

There are three parameters that need to be configured through the Windows PowerShell® command line interface because they are not configurable on Lync Server Control Panel:

  • •1.     RTCPCallsonHold and RTCPActiveCalls must be turned off. RTCP is a control channel that is opened and is used to monitor the network specific conditions of the RTP channel. CUCM does not support RTCP, so if the variables are not disabled, the Mediation Server will expect keepalives for the RTCP channel, which may cause unexpected behavior.

Set-CsTrunkConfiguration –identity –RTCPActiveCalls $false –RTCPCallsonHold $false

  • •2.     SessionTimer must be enabled. Because the RTCP channel is disabled, session timers must be enabled so that calls don’t stay up indefinitely in case we don’t get proper teardown of the call.

Set-CsTrunkConfiguration –identity –EnableSessionTimer $true

  • •3.     Media EncryptionLevel must be set to SupportEncryption. Since we do not support SRTP to Cisco through Direct SIP, we need to set the media configuration’s EncryptionLevel to SupportEncryption so that SRTP will only be used if it can be negotiated. By default, this parameter is set to RequireEncryption, meaning SRTP must be used.

Set-CsMediaConfiguration –identity Global -EncryptionLevel SupportEncryption

After this command is run please make sure and use 5068 as Mediation Server listening port if Co Located.... and of course make sure Mediation Server Service is running via the Control Panel on Lync.

Hope this helps!

Chris

Highlighted
Beginner

Lync CUCM 8.6(1) Integration

same issue here... CUCM8.6 and LYNC 2010 and there is no way to set up a sip trunk. on the sip trunk in CUCM - which port are you using (5060 or 5068).

Has anyone else fixed this problem?

Highlighted
Beginner

Lync CUCM 8.6(1) Integration

Yes this can be done.... use the intruction above to turn off SRTP

5068 should be the listening port on CUCM ...if Lync Mediation is coexisted then this should not be changed.

Let me know if this helps!

The doc listed below have all the info needed.

http://tech.rundtomrundt.com/2010/11/microsoft-lync-server-2010-with-cucm-8.html

https://supportforums.cisco.com/servlet/JiveServlet/download/3447587-113974/Integrating_Lync_Server_and_CUCM.doc

You should run the following commands on the Lync Server's -- Run As Administrator Lync Power Shell Window....

There are three parameters that need to be configured through the Windows PowerShell® command line interface because they are not configurable on Lync Server Control Panel:

  • •1.     RTCPCallsonHold and RTCPActiveCalls must be turned off. RTCP is a control channel that is opened and is used to monitor the network specific conditions of the RTP channel. CUCM does not support RTCP, so if the variables are not disabled, the Mediation Server will expect keepalives for the RTCP channel, which may cause unexpected behavior.

Set-CsTrunkConfiguration –identity –RTCPActiveCalls $false –RTCPCallsonHold $false

  • •2.     SessionTimer must be enabled. Because the RTCP channel is disabled, session timers must be enabled so that calls don’t stay up indefinitely in case we don’t get proper teardown of the call.

Set-CsTrunkConfiguration –identity –EnableSessionTimer $true

  • •3.     Media EncryptionLevel must be set to SupportEncryption. Since we do not support SRTP to Cisco through Direct SIP, we need to set the media configuration’s EncryptionLevel to SupportEncryption so that SRTP will only be used if it can be negotiated. By default, this parameter is set to RequireEncryption, meaning SRTP must be used.

Set-CsMediaConfiguration –identity Global -EncryptionLevel SupportEncryption

After this command is run please make sure and use 5068 as Mediation Server listening port if Co Located.... and of course make sure Mediation Server Service is running via the Control Panel on Lync.

Hope this helps!

Chris

Highlighted
Enthusiast

Lync CUCM 8.6(1) Integration

I’m trying to set this up and have a strange issue.

Calls from Lync into CUCM work fine. However calls from CUCM to Lync fail (busy tone).

When I pull the RTMT logs I can see a DigitAnalysis for the call but no real SIP messages (as far as I can tell). Also the logging on the Lync side does not see any SIP messages coming in.

Any ideas?

Thanks in advance.

Matt

Highlighted
Enthusiast

Lync CUCM 8.6(1) Integration

I'm running into the same issue as mmoulson1. Calls from CUCM Sip phone such as 9971 model to Lync get a fast busy tone. However, SCCP phones and Sip phones model 7945 is able to call to Lync fine. My initial though would be the trunk need enable early offer or required MTP settings. When I try to enable early offer I would get the reorder tone so now I'm just going through the logs. Anyone having this issue and can suggest a quick fix?

Highlighted
Enthusiast

Lync CUCM 8.6(1) Integration

Hi khanhluu82,

We ended up pushing the calls between CUCM & Lync via our CUBE router.

We did open a TAC case but that was not much help!


Matty

Have a look at this:

http://voipnorm.blogspot.co.uk/2011/05/important-settings-to-know-when.html

Highlighted
Beginner

Lync CUCM 8.6(1) Integration

I fixed it on our site :-)

the problem was, that i just added one server as sip destination on lync site, but we are running a cluster, and the phones have been connected to the other server.. I've added the subscriber to the trunk and everything was fine.

Highlighted
Enthusiast

Re: Lync CUCM 8.6(1) Integration

Figured out my issue with the sip phones 9971, 9951, and 8961. It was the firmware 9.3(1) that was causing the calls to Lync failed. I don't have time to troubleshoot the problem so all I did was to revert the phone back to firmware 9-2-1.

Khanh

CreatePlease to create content