cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
684
Views
0
Helpful
31
Replies
Highlighted
Beginner

"The agent id is invalid"

I'm have a problem logging agents into their desktop agents getting the error the agent id is invalid i'm not sure how to resolve this i tried deleting the profile and user configuraation sometimes this work but not all the time. Everything is done the profile is associated with the user and the RMuser and a skill is added to the agent but the error continues to come up. PLEASE HELP! Thanks inadvance for any assistance.

31 REPLIES 31
Highlighted
Frequent Contributor

Re: "The agent id is invalid"

make sure that the agent added to a resource group, and then agent will be able to login.

Highlighted
Beginner

Re: "The agent id is invalid"

We never used resource groups so all agent that are already exist with profiles are functional, it's just resently i'm getting this error. Any other ideas?

Highlighted

Re: "The agent id is invalid"

Agents should be associated with atleaset one skill set, make sure they are in one skill group.

Highlighted
Beginner

Re: "The agent id is invalid"

They are associated with a skill and the RM user and a user device profile, but nothing.

Highlighted

Re: "The agent id is invalid"

Make sure

Under User -

Enable CTI Application Use - Checked

Under User - Device Association

His/Her ICD extention is set as ICD Ext.

Also he/she has access rights to

\\\DESKTOP_CFG folder

Thanks

Highlighted
Beginner

Re: "The agent id is invalid"

Everything there is done exept the device association. We do not use the device association option because our users move around we use Extension Mobility association.

Highlighted
Beginner

Re: "The agent id is invalid"

Have you enabled any traces on the server or the agent desktop? I would turn on some debugs under the CRA Engine -> Trace Configuration. And you can enable some detailed logging on the agent desktop by modifying c:\program files\cisco\desktop\fastcalllocal.ini and changing "Level=0" to "Level=204". Restart the Agent Desktop and when you receive the error look in C:\Program Files\Cisco\Desktop\log. Post whatever errors you see.

Highlighted
Beginner

Re: "The agent id is invalid"

Attached is the agent log information for agent ID dds and a ciscoMIVR log.

Highlighted
Beginner

Re: "The agent id is invalid"

Ok, I assume you've restarted the CRA Engine (probably numerous times by now) and the CTIManager on the CallManager? Is this user sometimes able to login? Have you verified this user's Extension Mobility profile is assigned under their user profile in Global Directory and it is configured with an ICD extension? RMUSER has control of the physical phone? Within Desktop Administrator this user has been assigned to a team? Do you see this user within the CRA Administration under ICD->Resources. And finally, check the agent*.dbg file in the log directory for any relevant info and post here if there is still an issue.

I know, throwing a bunch of questions out there, but these are all the things I would be checking. If all this checks out and there is still an issue, especially if it is inconsistent, I would open a case with TAC.

Highlighted
Beginner

Re: "The agent id is invalid"

I did every thing except restart the CRA engine which i can do during off hours to see if that makes a difference. And this is a new profile i made i'm not having this problem with existing profiles just the new ones. Every thing was checked and double checked(assignment to the global directory, rmuser and skill).

Highlighted
Beginner

Re: "The agent id is invalid"

Yes, if everything else matches up with functional users I'm stumped. Are there any current users with Agent ID's at 3 or less characters? I haven't seen any limitations in the documentation, just a thought. Was there any more detailed info in the .dbg file?

Highlighted
Beginner

Re: "The agent id is invalid"

All of our agent have 3 characters for their id and one of them has 2 characters. Attached is all of the .dbg file.

Highlighted
Beginner

Re: "The agent id is invalid"

I would definitely restart the CRA engine and afterwards verify you still see the user under ICD->Resources and within the Desktop Administrator. Closest thing I saw was this in the TAC Case Collection:

'This error occurs when the AgentID doesn't exist in the internal agent list in memory. This table is created when the IPCC Express Subsystem starts and is refreshed when the Resource page is visited.'

I was unable to duplicate the error by logging in with a bogus username, bad password, or incorrect DN. So that seems to jive with the above error, as in the user exists but is not in memory. Anyway, please post the results after your engine restart.

Highlighted
Beginner

Re: "The agent id is invalid"

Just restarted the CRA engine and both login ids are working. I did not get that error and i created a dummy profile (just to see if i would still get the error) and that logged in without a problem. Thank you so much for your help. I would like to know what caused this though.