cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
193
Views
0
Helpful
4
Replies
Highlighted
Beginner

Route-list causing problems with MGCP

Folks,

I have callmanager 4.0(2a) and everytime i make a change to the route-list (add more route-groups for failover), the change does not happen, not only that, i can not even make phone calls through primary router-group.

I tried resetting the route-list and the gateway from callamanger (MGCP). No luck

If i reboot the routers (gateway) everthing works fine? any ideas?

i am downloading the configuration from callmanager using ccm config server command, anything i need?

here is the config:

boot-start-marker

boot system flash

boot system flash:c3745-ipvoice-mz.123-8.T4.bin

boot-end-marker

!

card type t1 1 1

card type t1 2 1

logging buffered 131072 informational

no logging console

enable secret xxxx/

!

no network-clock-participate slot 1

no network-clock-participate slot 2

no network-clock-participate aim 0

no network-clock-participate aim 1

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

no ip domain lookup

ip domain name northgrum.com

no ftp-server write-enable

isdn switch-type primary-dms100

voice-card 1

no dspfarm

dsp services dspfarm

!

voice-card 2

no dspfarm

dsp services dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 10.209.7.10

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.209.7.11

ccm-manager config

!

!

controller T1 1/0

shutdown

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

controller T1 1/1

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

controller T1 2/0

framing sf

linecode ami

!

controller T1 2/1

framing sf

linecode ami

!

!

!

interface FastEthernet0/0

ip address 10.209.7.9 255.255.255.192

speed 100

full-duplex

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface Serial1/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

interface Serial1/1:23

no ip address

isdn switch-type primary-dms100

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.209.7.1

no ip http server

!

!

!

!

!

control-plane

!

!

call application alternate DEFAULT

!

!

voice-port 1/0:23

!

voice-port 1/1:23

!

mgcp

mgcp call-agent 10.209.7.11 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

no mgcp explicit hookstate

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

sccp local FastEthernet0/0

sccp ccm 10.209.7.11 identifier 1 version 4.0

sccp ccm 10.209.7.10 identifier 2 version 4.0

sccp ip precedence 3

sccp

!

sccp ccm group 990

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 7 register CFB_10.209.7.9

associate profile 6 register MTP_10.209.7.9

keepalive retries 5

switchback method immediate

switchback interval 15

!

4 REPLIES 4
Highlighted
Contributor

Could you please use the trace function in the callmanager to isolate the problem .

Have a look at the following document

http://www.cisco.com/en/US/products/sw/voicesw/ps556/prod_troubleshooting_guide_chapter09186a00801eaf9f.html

Highlighted

You might be able to avoid a total reboot of the gateway router by doing a 'ccm config check reset' command from the gateway, it forces it to sync up with the CM, and a 'sh ccm' will show you your download config count increasing. I don't know why it would behave like this in the first place, but I have found this reset from the router to help a lot of weird things.

Mary Beth

Highlighted

I have the same CCM version and using 3745 gateways and I have not looked into to close, yet but I do know if you do a "NO MGCP" then MGCP from the global configuration it will synch back up after a 5-8 seconds.

I know what you mean, if you change parameters within side the Route List with the Route Groups like stripping digits or adding or even adding another RG this happens. This is also weird, if you add other Line Groups to the VoiceMail hunt list it does almost the same thing. You cannot access VM at all unless you take away the Route Pattern pointing to the VM-Hun List reboot the Publisher and then add it back in once the Pub is back online.

Highlighted
Beginner

I have the same problem.

When i have it, i just make an inbound call towards the pri (which still works fine). After that, outbound calls from the IP Phones work again.

Pretty strange all of this, is it a known bug or are we all missing something ?

Content for Community-Ad