cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
536
Views
0
Helpful
1
Replies

Unable to make inbound and outbound calls on SIP trunk

danielmaisu
Beginner
Beginner

I am unable to Unable to make inbound and outbound calls on SIP trunk.

My deployment scenarios is as follows;

IPPhone>>>>>>CUCMv11>>>>>>CUBE(CISCO2911/K9) IOS Version 15.4(3)M5>>>>>>>SBC/ITSP

SIP trunk from CUCM to CUBE is up, calls getting to CUBE but not going outbound and inbound calls.

sip-ua register status#
Line               peer         expires(sec)     reg           survival       P-Associ-URI
================================ ========== ============ === ======== ============
79999662       -1             172                 no             normal

following is my current configuration on the CUBE

pngasl-uc-router#sho run
Building configuration...


Current configuration : 6099 bytes
!
! Last configuration change at 13:25:20 GMT Wed Oct 26 2016 by x
! NVRAM config last updated at 12:58:16 GMT Wed Oct 26 2016 by x
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname x
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 0
logging buffered 12288
!
no aaa new-model
clock timezone GMT 10 0
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip domain name x.x.x
ip name-server 8.8.8.8
ip name-server 192.168.40.30
ip name-server 192.168.40.31
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
isdn switch-type primary-net5
!
cts logging verbose
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
ip address trusted list
ipv4 x14.91.29
ipv4 x.x.0 255.255.255.0
ipv4 x.x.70.5
ipv4 x.x.70.6
no notify redirect ip2ip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
bind control source-interface GigabitEthernet0/0
bind media source-interface GigabitEthernet0/0
outbound-proxy dns:x.x.xom
no update-callerid
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729r8
!
voice class codec 2
codec preference 1 g729r8
codec preference 2 g711alaw
codec preference 3 g711ulaw
!
!
!
!
!
!
voice translation-rule 103
rule 1 /^6../ /79999662/
rule 2 /^7../ /79999662/
!
voice translation-rule 105
rule 1 /79999662/ /600/
!
!
voice translation-profile INBOUND-SIP-TRANSLATIONS
translate called 105
!
voice translation-profile OUTBOUND-SIP-TRANSLATIONS
translate calling 103
!
!
!
license udi pid CISCO2911/K9 sn FGL202010A2
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!
!
controller E1 0/0/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 0/0/1
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description ---H.323 Gateway----
ip address x.x.x.x 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr x.x.70.254
!
interface GigabitEthernet0/1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
!
interface Dialer1
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip flow ingress
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname 
ppp chap password 
ppp pap sent-username password 

no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.0.0 255.255.0.0 192.168.70.1
ip ssh version 1
!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
bearer-cap Speech
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 192.168.70.5 identifier 1 priority 1 version 7.0
sccp ccm 192.168.70.6 identifier 2 priority 2 version 7.0
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/0
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 1 register CONFERENCE
!
!
!
dspfarm profile 100 transcode
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
codec g729r8
codec ilbc
maximum sessions 3
associate application SCCP
shutdown
!
dspfarm profile 1 conference
codec g729br8
codec g729r8
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 3
associate application SCCP
shutdown
!
dial-peer voice 1 voip
destination-pattern 79999662
session protocol sipv2
session target ipv4:192.168.70.5
incoming called-number 79999662
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 100 voip
destination-pattern 0.T
session protocol sipv2
session target dns
no voice-class sip outbound-proxy
voice-class sip bind control source-interface GigabitEthernet0/0
voice-class sip bind media source-interface GigabitEthernet0/0
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 600 voip
destination-pattern 6..
session target ipv4:192.168.70.5
incoming called-number 6..
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 700 voip
destination-pattern 7..
session target ipv4:192.168.70.5
incoming called-number 7..
dtmf-relay h245-alphanumeric
codec g711ulaw
!
!
sip-ua
credentials username 79999662 password 7realm pom-sbc.digicelpng.com
authentication username 79999662 password 7 realm pom-sbc.digicelpng.com
no remote-party-id
retry invite 2
retry register 10
timers register 250
registrar dns: expires 3600
sip-server dns:x..x.com
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
logging synchronous
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login local
transport input all
!
scheduler allocate 20000 1000
ntp master
ntp server 103.242.68.69
!
end

1 Reply 1

hsood
Participant
Participant

Hi Daniel,

Are the calls making to the CUBE at all from the CUCM to the PSTN side?

I would suggest to collect a set of debugs to verify and can have a look at the debugs from there:

debug ccsip messages

debug voice ccapi inout

Regards,

Hitesh

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers