cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
141
Views
0
Helpful
3
Replies
Highlighted
Beginner

VoIP Phone is switching to Data Lan

Hello,

I experienced some issue where a series of VoIP phones tried to switch from voice to data lan; switch config looks ok.

This was happening every 11 minutes.

I was wondering if someone else has ever faced such kind of issue.

 

See details below.VoiceLAN

 

Thanks,

 

Netmart

 

c4500: Version 03.08.03.E 


Platform: Cisco IP Phone 7841, Capabilities: Host Phone Two-port Mac Relay
Interface: GigabitEthernet1/1, Port ID (outgoing port): Port 1
Holdtime : 138 sec
Second Port Status: Up

Version :
sip78xx.12-5-1SR3-74.loads

 

 

Extract Syslog:


Voice VLAN 32: 192.168.20.0
Data VLAN 31: 192.168.10.0
2020-06-11T00:26:41-0400 Jun 11 00:26:41 172.16.0.254 76421675: Jun 11 00:26:42.407: sw_host_track-ev:host_track_notification: Add
event for host - (Gi1/1 192.168.10.54 (aaaa.bbbb.cccc) VLAN:31 ID:0 DHCP)
2020-06-11T00:15:11-0400 Jun 11 00:15:11 172.16.0.254 76381722: Jun 11 00:15:12.062: sw_host_track-obj_destroy:Host entry freed(Gi1/1 192.168.20.77 (aaaa.bbbb.cccc) VLAN:32 ID:171 ARP)
2020-06-11T00:15:11-0400 Jun 11 00:15:11 172.16.0.254 76381721: Jun 11 00:15:12.062: sw_host_track-redundancy:Syncing over event:
DELETE for (Gi1/1 192.168.20.77 (aaaa.bbbb.cccc) VLAN:32 ID:171 ARP) ENABLED
2020-06-11T00:15:11-0400 Jun 11 00:15:11 172.16.0.254 76381720: Jun 11 00:15:12.054: sw_host_track-notify:host_track_delete_entry -
Notify other features: del - (Gi1/1 192.168.20.77 (aaaa.bbbb.cccc) VLAN:32 ID:171 ARP)

 

 

!
interface GigabitEthernet1/1
switchport access vlan 31
switchport mode access
switchport voice vlan 32
switchport port-security maximum 3
switchport port-security violation restrict
switchport port-security aging time 10
switchport port-security aging type inactivity
switchport port-security
ip device tracking maximum 3
ip arp inspection limit rate 150
ipv6 nd raguard attach-policy HOST_POLICY
auto qos voip cisco-phone
qos trust device cisco-phone
macro description AccessEdgeQoS
spanning-tree portfast edge
service-policy input AutoQos-4.0-Cisco-Phone-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
ip verify source tracking port-security
ip dhcp snooping limit rate 100



3 REPLIES 3
Highlighted

Re: VoIP Phone is switching to Data Lan

The extract from the syslog mentions vlan 31 and 32 and your configuration has vlan 15 and 20. Are you absolutely sure you have captured the appropriate part of the logs?

Please rate all useful posts
Highlighted
Beginner

Re: VoIP Phone is switching to Data Lan

Congratulations Mr. Kallberg, out of 102 viewers you recognized the typo.

Now that the post is corrected, you may also come up with a solution what triggers the phone to switch from voice to data lan.

Highlighted

Re: VoIP Phone is switching to Data Lan

I think that these commands might be in play here.

switchport port-security aging time 10
switchport port-security aging type inactivity

Please test without these and see if it makes a difference.

Please rate all useful posts