cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1209
Views
5
Helpful
2
Replies
Highlighted
Beginner

Connecting a Nexus 5010 to a 2960-s

Hello

I was wondering if somebody could help me please.  I have two 5010 Nexus switch and a VPC domain.  I have connected each of the two 2960-s via SFP modules to each of the Nexus 5010 switches.

I am using LACP on the below channels.

I have added each of the two connections from the first 2960 into a port channel group.  When I check the port-channel summary information the port is always down.  I can never get the port channel to come up with LACP and see no operation members.

Interface information

interface Ethernet1/4
  description Trunk Port to DCSV01
  switchport mode trunk
  spanning-tree port type network
  speed 1000
  channel-group 10 mode active

interface Ethernet1/5
  description Trunk Port to DCSV02
  switchport mode trunk
  spanning-tree port type network
  speed 1000
  channel-group 10 mode active

Port Channel Information

interface port-channel10

  switchport mode trunk

  spanning-tree port type network

  speed 1000

  vpc 10

Port Channel Summary

Flags:  D - Down        P - Up in port-channel (members)

        I - Individual  H - Hot-standby (LACP only)

        s - Suspended   r - Module-removed

        S - Switched    R - Routed

        U - Up (port-channel)

        M - Not in use. Min-links not met

--------------------------------------------------------------------------------

Group Port-       Type     Protocol  Member Ports

      Channel

--------------------------------------------------------------------------------

1     Po1(SU)     Eth      NONE      Eth1/1(P)

2     Po2(SU)     Eth      NONE      Eth1/2(P)

3     Po3(SU)     Eth      NONE      Eth1/3(P)

7     Po7(SU)     Eth      LACP      Eth1/17(P)   Eth1/18(P)

10    Po10(SD)    Eth      LACP      Eth1/4(I)    Eth1/5(I)

100   Po100(SU)   Eth      LACP      Eth1/12(P)

200   Po200(SU)   Eth      LACP      Eth1/13(P)

Any help would be appeciated.

Robin                  

Everyone's tags (1)
2 REPLIES 2
Advisor

Connecting a Nexus 5010 to a 2960-s

Robin-

A couple of things to try-

Check your vcp status and make sure it is up

Change the LACP from on to passive (on all switches)

Break LACP and test that each 2960 can trunk to the 5K's successfully

Cisco Employee

Connecting a Nexus 5010 to a 2960-s

Hi Robin

From the output it looks like both ports: eth 1/4 and 1/5 are in "i"ndividual state - which means that both of them receives different LACP id (LACP packet from different switches):

10    Po10(SD)    Eth      LACP      Eth1/4(I)    Eth1/5(I)

Also from the interface description 1/4 connected to DCSV01, and 1/5 to DCSV02 - seems like 2 different switches. That is the reason why ports are in the individual state.

To fix this you need to change the config as following:

on both n5k

eth1/4 connected to  DCSV01

eth1/5 connected to  DCSV02

interface Ethernet1/4
  description Trunk Port to DCSV01
  switchport mode trunk
  spanning-tree port type network
  speed 1000
  channel-group 10 mode active

interface Ethernet1/5
  description Trunk Port to DCSV02
  switchport mode trunk
  spanning-tree port type network
  speed 1000
  channel-group 11 mode active

nterface port-channel10

  switchport mode trunk

  spanning-tree port type network

  speed 1000

  vpc 10

nterface port-channel11

  switchport mode trunk

  spanning-tree port type network

  speed 1000

  vpc 11

That should resolve the issue.

HTH,

Alex

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards