cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
884
Views
0
Helpful
2
Replies
Highlighted
Beginner

Issue faced on failover test for Inter DC VXLAN that will be used to migrate server from old DC to New

Hi All,

 

We are in the process of migrating our servers from old DC to a new DC.  with the new DC already have pre-existing vlans and servers.. please take note we are not running any vxlan on new DC just a simple nexus core/access server farm setup.

 

we only have 2 DWDM so the connection will be pair of nexus 9k connected to another pair of nexus of 9k on both sides that will run the VXLAN bridge.. then from these it will be connected to access layer and just trunk the l2 access vlans. simple.

 

 

Our goal is just to move the L2 vlans..

DCA  VLANS 300 will be converted to vlan 600 at DCB

vlan 301 to vlan 601

vlan 400 to vlan 800

vlan 401 to vlan 801

VPC is working fine; OSPF IGP is working fine as well with BFD configured for fast link failure detection..

thinking to manually load balance the l2 traffic. spanning tree is configured with A1 as root bridge for vlan 300/301  ( B1 root bridge for 600/601)

A2 root bridge for  vlan 400/401 (B2 root bridge for 800/801.)

we are facing an issue when we do the failover test.. the failover doesnt work..

 

============

hostname A1
cfs eth distribute
nv overlay evpn
feature ospf
feature bgp
feature pim
feature fabric forwarding
feature udld
feature interface-vlan
feature vn-segment-vlan-based
feature hsrp
feature lacp
feature dhcp
feature vpc
feature bfd
feature nv overlay

vlan 1,300-301,400-401,3967
ip pim ssm range 232.0.0.0/8
ip pim bfd
vlan 300
  name SGB_300
  vn-segment 400000
vlan 301
  name SGB_301
  vn-segment 400001
vlan 400
  name SGB_400
  vn-segment 400002
vlan 401
  name SGB_401
  vn-segment 400003

spanning-tree vlan 300-301 priority 24576
spanning-tree vlan 400-401 priority 28672
vrf context vPC_Keepalive
  description vPC_Keepalive
vpc domain 100
  peer-switch
  role priority 1
  system-priority 1
  peer-keepalive destination 10.10.10.2 source 10.10.10.1 vrf vPC_Keepalive
  delay restore 150
  peer-gateway
  auto-recovery reload-delay 600
  ip arp synchronize


interface Vlan3967
  description L3_Underlay_interswitch
  no shutdown
  mtu 9216
  bfd interval 300 min_rx 300 multiplier 3
  no ip redirects
  ip address 1.1.1.5/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf VXLAN_underlay area 0.0.0.0
  ip ospf bfd
  ip pim sparse-mode
  ip arp timeout 900

interface port-channel2
  description ^:uplink:COre-Access:Po2
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 300-301,400-401
  vpc 2

interface port-channel100
  description ^:uplink:A2:Po100:e1/17-18:vPC_Keepalive
  logging event port link-status
  vrf member vPC_Keepalive
  bfd interval 300 min_rx 300 multiplier 3
  no ip redirects
  ip address 10.10.10.1/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf vPC area 0.0.0.0
  ip ospf bfd
  ip pim sparse-mode
  ip arp timeout 900

interface port-channel1000
  description A2:vPC_Peer-Link
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 300-301,400-401,3967
  spanning-tree port type network
  vpc peer-link

interface nve1
  no shutdown
  source-interface loopback1
  host-reachability protocol bgp
  member vni 400000
    ingress-replication protocol bgp
  member vni 400001
    ingress-replication protocol bgp
  member vni 400002
    ingress-replication protocol bgp
  member vni 400003
    ingress-replication protocol bgp

interface Ethernet1/1
  description ^:WAN:1G:B1:e1/1
  mtu 9216
  no ip redirects
  ip address 5.5.5.1/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf VXLAN_underlay area 0.0.0.0
  ip ospf bfd
  ip arp timeout 900
  no shutdown


interface loopback0
  description ^:if:loopback: BGP management
  ip address 10.1.1.1/32
  ip router ospf VXLAN_underlay area 0.0.0.0

interface loopback1
  description VXLAN:VTEP Management
  ip address 1.1.1.2/32
  ip address 1.1.1.1/32 secondary
  ip router ospf VXLAN_underlay area 0.0.0.0

router ospf VXLAN_underlay
  bfd
  router-id 10.1.1.1
router ospf vPC
  bfd
  vrf vPC_Keepalive
router bgp 64680
  router-id 10.1.1.1
  log-neighbor-changes
  neighbor 10.1.1.2
    bfd
    remote-as 64680
    description A2:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
  neighbor 20.1.1.1
    bfd
    remote-as 64680
    description B1:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
  neighbor 20.1.1.2
    bfd
    remote-as 64680
    description B2:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
evpn
  vni 400000 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400001 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400002 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400003 l2
    rd auto
    route-target import auto
    route-target export auto

 

============

hostname A2
cfs eth distribute
nv overlay evpn
feature ospf
feature bgp
feature pim
feature fabric forwarding
feature udld
feature interface-vlan
feature vn-segment-vlan-based
feature hsrp
feature lacp
feature dhcp
feature vpc
feature bfd
feature nv overlay

vlan 1,300-301,400-401,3967
ip pim ssm range 232.0.0.0/8
ip pim bfd
vlan 300
  name SGB_300
  vn-segment 400000
vlan 301
  name SGB_301
  vn-segment 400001
vlan 400
  name SGB_400
  vn-segment 400002
vlan 401
  name SGB_401
  vn-segment 400003

spanning-tree vlan 300-301 priority 28672
spanning-tree vlan 400-401 priority 24576
vrf context vPC_Keepalive
  description vPC_Keepalive
vpc domain 100
  peer-switch
  system-priority 1
  peer-keepalive destination 10.10.10.1 source 10.10.10.2 vrf vPC_Keepalive
  delay restore 150
  peer-gateway
  auto-recovery reload-delay 600
  ip arp synchronize

 

interface Vlan3967
  description L3_Underlay_interswitch
  no shutdown
  mtu 9216
  bfd interval 300 min_rx 300 multiplier 3
  no ip redirects
  ip address 1.1.1.6/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf VXLAN_underlay area 0.0.0.0
  ip ospf bfd
  ip pim sparse-mode
  ip arp timeout 900

interface port-channel2
  description ^:uplink:COre-Access:Po2
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 300-301,400-401
  vpc 2

interface port-channel100
  description ^:uplink:A1:Po100:e1/17-18:vPC_Keepalive
  logging event port link-status
  vrf member vPC_Keepalive
  bfd interval 300 min_rx 300 multiplier 3
  no ip redirects
  ip address 10.10.10.2/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf vPC area 0.0.0.0
  ip ospf bfd
  ip pim sparse-mode
  ip arp timeout 900

interface port-channel1000
  description A1:vPC_Peer-Link
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 300-301,400-401,3967
  spanning-tree port type network
  vpc peer-link

interface nve1
  no shutdown
  source-interface loopback1
  host-reachability protocol bgp
  member vni 400000
    ingress-replication protocol bgp
  member vni 400001
    ingress-replication protocol bgp
  member vni 400002
    ingress-replication protocol bgp
  member vni 400003
    ingress-replication protocol bgp

interface Ethernet1/1
  description ^:B2:e1/1
  mtu 9216
  no ip redirects
  ip address 5.5.5.5/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf VXLAN_underlay area 0.0.0.0
  ip ospf bfd
  ip arp timeout 900
  no shutdown


interface loopback0
  description ^:if:loopback: BGP management
  ip address 10.1.1.2/32
  ip router ospf VXLAN_underlay area 0.0.0.0

interface loopback1
  description VXLAN:VTEP Management
  ip address 1.1.1.3/32
  ip address 1.1.1.1/32 secondary
  ip router ospf VXLAN_underlay area 0.0.0.0

router ospf VXLAN_underlay
  bfd
  router-id 10.1.1.2
router ospf vPC
  bfd
  vrf vPC_Keepalive
router bgp 64680
  router-id 10.1.1.2
  log-neighbor-changes
  neighbor 10.1.1.1
    bfd
    remote-as 64680
    description A1:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
  neighbor 20.1.1.1
    bfd
    remote-as 64680
    description B1:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
  neighbor 20.1.1.2
    bfd
    remote-as 64680
    description B2:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
evpn
  vni 400000 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400001 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400002 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400003 l2
    rd auto
    route-target import auto
    route-target export auto

 

===============

hostname B1
cfs eth distribute
nv overlay evpn
feature ospf
feature bgp
feature pim
feature fabric forwarding
feature udld
feature interface-vlan
feature vn-segment-vlan-based
feature hsrp
feature lacp
feature dhcp
feature vpc
feature bfd
feature nv overlay

vlan 1,600-601,800-801,3967
ip pim ssm range 232.0.0.0/8
ip pim bfd
vlan 600
  name SGB_300
  vn-segment 400000
vlan 601
  name SGB_301
  vn-segment 400001
vlan 800
  name SGB_400
  vn-segment 400002
vlan 801
  name SGB_401
  vn-segment 400003

spanning-tree vlan 600-601 priority 24576
spanning-tree vlan 800-801 priority 28672
vrf context vPC_Keepalive
  description vPC_Keepalive
vpc domain 100
  peer-switch
  role priority 1
  system-priority 1
  peer-keepalive destination 10.10.10.6 source 10.10.10.5 vrf vPC_Keepalive
  delay restore 150
  peer-gateway
  auto-recovery reload-delay 600
  ip arp synchronize


interface Vlan3967
  description L3_Underlay_interswitch
  no shutdown
  mtu 9216
  bfd interval 300 min_rx 300 multiplier 3
  no ip redirects
  ip address 2.1.1.5/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf VXLAN_underlay area 0.0.0.0
  ip ospf bfd
  ip pim sparse-mode
  ip arp timeout 900

interface port-channel2
  description ^:uplink:COre-Access:Po2
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 600-601,800-801
  vpc 2

interface port-channel100
  description ^:uplink:B2:Po100:e1/17-18:vPC_Keepalive
  logging event port link-status
  vrf member vPC_Keepalive
  bfd interval 300 min_rx 300 multiplier 3
  no ip redirects
  ip address 10.10.10.5/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf vPC area 0.0.0.0
  ip ospf bfd
  ip pim sparse-mode
  ip arp timeout 900

interface port-channel1000
  description B2:vPC_Peer-Link
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 600-601,800-801,3967
  spanning-tree port type network
  vpc peer-link

interface nve1
  no shutdown
  source-interface loopback1
  host-reachability protocol bgp
  member vni 400000
    ingress-replication protocol bgp
  member vni 400001
    ingress-replication protocol bgp
  member vni 400002
    ingress-replication protocol bgp
  member vni 400003
    ingress-replication protocol bgp

interface Ethernet1/1
  description ^:A1:e1/1
  mtu 9216
  no ip redirects
  ip address 5.5.5.2/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf VXLAN_underlay area 0.0.0.0
  ip ospf bfd
  ip arp timeout 900
  no shutdown


interface loopback0
  description ^:if:loopback: BGP management
  ip address 20.1.1.1/32
  ip router ospf VXLAN_underlay area 0.0.0.0

interface loopback1
  description VXLAN:VTEP Management
  ip address 2.1.1.2/32
  ip address 2.1.1.1/32 secondary
  ip router ospf VXLAN_underlay area 0.0.0.0

router ospf VXLAN_underlay
  bfd
  router-id 20.1.1.1
router ospf vPC
  bfd
  vrf vPC_Keepalive
router bgp 64680
  router-id 20.1.1.1
  log-neighbor-changes
  neighbor 10.1.1.1
    bfd
    remote-as 64680
    description A1:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
  neighbor 10.1.1.2
    bfd
    remote-as 64680
    description A2:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
  neighbor 20.1.1.2
    bfd
    remote-as 64680
    description B2:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
evpn
  vni 400000 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400001 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400002 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400003 l2
    rd auto
    route-target import auto
    route-target export auto

 

 

==============

hostname B2
cfs eth distribute
nv overlay evpn
feature ospf
feature bgp
feature pim
feature fabric forwarding
feature udld
feature interface-vlan
feature vn-segment-vlan-based
feature hsrp
feature lacp
feature dhcp
feature vpc
feature bfd
feature nv overlay

vlan 1,600-601,800-801,3967
ip pim ssm range 232.0.0.0/8
ip pim bfd
vlan 600
  name SGB_300
  vn-segment 400000
vlan 601
  name SGB_301
  vn-segment 400001
vlan 800
  name SGB_400
  vn-segment 400002
vlan 801
  name SGB_401
  vn-segment 400003

spanning-tree vlan 600-601 priority 28672
spanning-tree vlan 800-801 priority 24576
vrf context vPC_Keepalive
  description vPC_Keepalive
vpc domain 100
  peer-switch
  system-priority 1
  peer-keepalive destination 10.10.10.5 source 10.10.10.6 vrf vPC_Keepalive
  delay restore 150
  peer-gateway
  auto-recovery reload-delay 600
  ip arp synchronize

 

interface Vlan3967
  description L3_Underlay_interswitch
  no shutdown
  mtu 9216
  bfd interval 300 min_rx 300 multiplier 3
  no ip redirects
  ip address 2.1.1.6/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf VXLAN_underlay area 0.0.0.0
  ip ospf bfd
  ip pim sparse-mode
  ip arp timeout 900

interface port-channel2
  description ^:uplink:COre-Access:Po2
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 600-601,800-801
  vpc 2

interface port-channel100
  description ^:uplink:B1:Po100:e1/17-18:vPC_Keepalive
  logging event port link-status
  vrf member vPC_Keepalive
  bfd interval 300 min_rx 300 multiplier 3
  no ip redirects
  ip address 10.10.10.6/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf vPC area 0.0.0.0
  ip ospf bfd
  ip pim sparse-mode
  ip arp timeout 900

interface port-channel1000
  description B1:vPC_Peer-Link
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 600-601,800-801,3967
  spanning-tree port type network
  vpc peer-link

interface nve1
  no shutdown
  source-interface loopback1
  host-reachability protocol bgp
  member vni 400000
    ingress-replication protocol bgp
  member vni 400001
    ingress-replication protocol bgp
  member vni 400002
    ingress-replication protocol bgp
  member vni 400003
    ingress-replication protocol bgp

interface Ethernet1/1
  description ^:A2:e1/1
  mtu 9216
  no ip redirects
  ip address 5.5.5.6/30
  no ipv6 redirects
  ip ospf network point-to-point
  ip router ospf VXLAN_underlay area 0.0.0.0
  ip ospf bfd
  ip arp timeout 900
  no shutdown


interface loopback0
  description ^:if:loopback: BGP management
  ip address 20.1.1.2/32
  ip router ospf VXLAN_underlay area 0.0.0.0

interface loopback1
  description VXLAN:VTEP Management
  ip address 2.1.1.3/32
  ip address 2.1.1.1/32 secondary
  ip router ospf VXLAN_underlay area 0.0.0.0

router ospf VXLAN_underlay
  bfd
  router-id 20.1.1.2
router ospf vPC
  bfd
  vrf vPC_Keepalive
router bgp 64680
  router-id 20.1.1.2
  log-neighbor-changes
  neighbor 10.1.1.1
    bfd
    remote-as 64680
    description A1:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
  neighbor 10.1.1.2
    bfd
    remote-as 64680
    description A2:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
  neighbor 20.1.1.1
    bfd
    remote-as 64680
    description B1:lo0
    update-source loopback0
    address-family ipv4 unicast
    address-family l2vpn evpn
      send-community
      send-community extended
evpn
  vni 400000 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400001 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400002 l2
    rd auto
    route-target import auto
    route-target export auto
  vni 400003 l2
    rd auto
    route-target import auto
    route-target export auto

 

 

2 REPLIES 2
Highlighted
Beginner

Re: Issue faced on failover test for Inter DC VXLAN that will be used to migrate server from old DC to New

this what im getting..  i cannot ping a vlan 300-600 host behind DCB..

 

 

A2# show bgp l2vpn evpn 0014.1c18.a2c1
BGP routing table information for VRF default, address family L2VPN EVPN
Route Distinguisher: 10.1.1.2:33067    (L2VNI 400000)
BGP routing table entry for [2]:[0]:[0]:[48]:[0014.1c18.a2c1]:[0]:[0.0.0.0]/216,
 version 254
Paths: (2 available, best #2)
Flags: (0x000212) on xmit-list, is in l2rib/evpn, is not in HW

  Path type: internal, path is valid, not best reason: Router Id, no labeled nex
thop
             Imported from 20.1.1.2:33367:[2]:[0]:[0]:[48]:[0014.1c18.a2c1]:[0]:
[0.0.0.0]/112
  AS-Path: NONE, path sourced internal to AS
    2.1.1.1 (metric 45) from 20.1.1.2 (20.1.1.2)
      Origin IGP, MED not set, localpref 100, weight 0
      Received label 400000
      Extcommunity:  RT:64680:400000 SOO:2.1.1.1:0 ENCAP:8

  Advertised path-id 1
  Path type: internal, path is valid, is best path, no labeled nexthop, in rib
             Imported from 20.1.1.1:33367:[2]:[0]:[0]:[48]:[0014.1c18.a2c1]:[0]:
[0.0.0.0]/112
  AS-Path: NONE, path sourced internal to AS
    2.1.1.1 (metric 45) from 20.1.1.1 (20.1.1.1)
      Origin IGP, MED not set, localpref 100, weight 0
      Received label 400000
      Extcommunity:  RT:64680:400000 SOO:2.1.1.1:0 ENCAP:8

  Path-id 1 not advertised to any peer

Route Distinguisher: 20.1.1.1:33367
BGP routing table entry for [2]:[0]:[0]:[48]:[0014.1c18.a2c1]:[0]:[0.0.0.0]/216,
 version 243
Paths: (1 available, best #1)
Flags: (0x000202) on xmit-list, is not in l2rib/evpn, is not in HW, is locked

  Advertised path-id 1
  Path type: internal, path is valid, is best path, no labeled nexthop
  AS-Path: NONE, path sourced internal to AS
    2.1.1.1 (metric 45) from 20.1.1.1 (20.1.1.1)
      Origin IGP, MED not set, localpref 100, weight 0
      Received label 400000
      Extcommunity:  RT:64680:400000 SOO:2.1.1.1:0 ENCAP:8

  Path-id 1 not advertised to any peer

Route Distinguisher: 20.1.1.2:33367
BGP routing table entry for [2]:[0]:[0]:[48]:[0014.1c18.a2c1]:[0]:[0.0.0.0]/216,
 version 253
Paths: (1 available, best #1)
Flags: (0x000202) on xmit-list, is not in l2rib/evpn, is not in HW, is locked

  Advertised path-id 1
  Path type: internal, path is valid, is best path, no labeled nexthop
  AS-Path: NONE, path sourced internal to AS
    2.1.1.1 (metric 45) from 20.1.1.2 (20.1.1.2)
      Origin IGP, MED not set, localpref 100, weight 0
      Received label 400000
      Extcommunity:  RT:64680:400000 SOO:2.1.1.1:0 ENCAP:8

  Path-id 1 not advertised to any peer

Highlighted
Beginner

Re: Issue faced on failover test for Inter DC VXLAN that will be used to migrate server from old DC to New

normal traffic is via e1/1 on A2..

 

A2# show mac address-table
Legend:
        * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
        age - seconds since last seen,+ - primary entry using vPC Peer-Link,
        (T) - True, (F) - False, C - ControlPlane MAC
   VLAN     MAC Address      Type      age     Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
C  300     0014.1c18.a2c1   dynamic  0         F      F    nve1(2.1.1.1)
+  300     0014.1c4d.32c3   dynamic  0         F      F    Po2
C  400     0014.1c18.a2c2   dynamic  0         F      F    nve1(2.1.1.1)
*  400     0014.1c4d.32c4   dynamic  0         F      F    Po2
G  300     2cd0.2d56.3619   static   -         F      F    vPC Peer-Link(R)
G 3967     2cd0.2d56.3619   static   -         F      F    vPC Peer-Link(R)
G  400     2cd0.2d56.3619   static   -         F      F    vPC Peer-Link(R)
G    -     70df.2f0e.ac27   static   -         F      F    sup-eth1(R)
G  300     70df.2f0e.ac27   static   -         F      F    sup-eth1(R)
G 3967     70df.2f0e.ac27   static   -         F      F    sup-eth1(R)
G  400     70df.2f0e.ac27   static   -         F      F    sup-eth1(R)
KGRBSWSVP-SL02A-DMZ#                   

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey