cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

10788
Views
56
Helpful
10
Replies
Highlighted
Beginner

Nexus 5k syslog issue

Good Morning!   I'm having some difficulties regarding our new Nexus 5020 switches.   We have two of thse in which are connected to multiple

2k models (which are being used in the Top of Rack).    We are currently utilizing the 4.1(3)N1(1) version of code.   I am still very new to these switches

and I'm not sure if it's even considered IOS or if there is another name for it.   

Anyhow, here is my dilemma.   When we initially began setting these up, we noticed that there were two VRF's automatically set up (management

and default).   We are trying to set up logging to go to a remote syslog server, however....it keeps attempting to use the management vrf.    I removed the IP address from the management interface and am using VLAN 1 as my management interface (in-band management).     So....i believe this is where my

issue lies. I'm wanting to send my messages to a logging server, but use the default vrf instead of the management.    I tried using the following command:

logging server x.x.x.x 5 use-vrf default facility syslog

Unfortunately, the 'use-vrf' option doesn't show up for me.    I can't seem to figure out how to force the logging to use a certain vrf.   If anyone can help, i'd greatly be appreciated.   And once again, I'm sorry for my ignorance on this subject.

10 REPLIES 10

Re: Nexus 5k syslog issue

Good Morning!   I'm having some difficulties regarding our new Nexus 5020 switches.   We have two of thse in which are connected to multiple

2k models (which are being used in the Top of Rack).    We are currently utilizing the 4.1(3)N1(1) version of code.   I am still very new to these switches

and I'm not sure if it's even considered IOS or if there is another name for it.   

Anyhow, here is my dilemma.   When we initially began setting these up, we noticed that there were two VRF's automatically set up (management

and default).   We are trying to set up logging to go to a remote syslog server, however....it keeps attempting to use the management vrf.    I removed the IP address from the management interface and am using VLAN 1 as my management interface (in-band management).     So....i believe this is where my

issue lies. I'm wanting to send my messages to a logging server, but use the default vrf instead of the management.    I tried using the following command:

logging server x.x.x.x 5 use-vrf default facility syslog

Unfortunately, the 'use-vrf' option doesn't show up for me.    I can't seem to figure out how to force the logging to use a certain vrf.   If anyone can help, i'd greatly be appreciated.   And once again, I'm sorry for my ignorance on this subject.

Check out the below link for syslog configuration on nexus 5K

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli_rel_4_0_1a/sm_syslog.html#wp1088182

Hope to Help !!

Ganesh.H

If helpful do rate the post

Beginner

This was the weirdest thing.

This was the weirdest thing. not sure if you fixed your problem but it wouldn't work for me until i hit Ctrl z after the config. Only ctrl Z worked, I still had the same issue when I typed "exit". It would always show "this server is temporarily unreachable" for me before the ctrl z. Weird!

Beginner

@PoliberteThe same in my

@Poliberte

The same in my situation. Ctrl+Z is the solution :)

Beginner

I was having the same exact

I was having the same exact issue with "this server is temporarily unreachable" for all my logging servers, but on a Nexus 9372 version 7.0(3)I2(2d)

I had to hit ctrl+z after each logging server command instead of enter.

How did anyone figure that one out!

Beginner

Luck!! I used ctrl-z and exit

Luck!! I used ctrl-z and exit depending on the mood i'm in lol. It just happened that I was working on 2 different nexus environemnt. One work and the other didn't. The only difference was that I used ctrl-z rather than exit, lol. Just a stroke of luck. 

Beginner

I had the same problem but i

I had the same problem but i resolve with the next steps:

Workaround:Run following commands:

(config)# no logging server x.x.x.x 5 use-vrf management facility local6
(config)# logging server x.x.x.x 5 facility local6
(config)# logging source-interface loopback 0
(config)# logging server x.x.x.x 5 use-vrf management facility local6
(config)# no logging source-interface loopback 0

Beginner

Re: I had the same problem but i

This is in response to the Nexus 7000 series bug, right? I tried this solution first even though i was on a 5k series to no avail, but glad it worked for you !

Beginner

Re: I had the same problem but i

This worked for me.

 

no logging server 10.82.131.10
logging server 10.82.131.10 5 facility local6
logging source-interface loopback 0
logging server 10.82.131.10 5 use-vrf management facility local6
no logging source-interface loopback 0

Beginner

Re: I had the same problem but i

switch01(config)# loggin server 1.1.1.1 5 use-vrf default
switch01(config)# sho run | in "logging s"
logging server 1.1.1.1 ----notice no options display
switch01(config)# loggin server 1.1.1.1 facility syslog
switch01(config)# sho run | in "logging s"
logging server 1.1.1.1 5 use-vrf default facility syslog 
now those options are visible??   Does that mean it took the options, or they aren't active unless a facility is defined?

Beginner

logging-server default of 5 use-vrf default do not appear in running configuration

The logging server level of 5 is default.   "use-vrf default" is default.  Neither will appear in the running configuration of nx-os.  Not sure at what version this changed.

 

logging server 1.1.1.1 5 use-vrf management <--If I specify a vrf other that default
switch-01(config)# sho run | in "logging server 1.1.1"
logging server 1.1.1.1 5 use-vrf management <-- Level and vrf appears

 

switch-01(config)# logging server 1.1.1.1 5 use-vrf default <-- reset to default value
switch-01(config)# sho run | in "logging server 1.1.1"
logging server 1.1.1.1 <--level and vrf are gone

 

switch-01(config)# logging server 1.1.1.1 4 use-vrf default <-- 4 instead of 5 of logging level
switch-01(config)# sho run | in "logging server 1.1.1"
logging server 1.1.1.1 4

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards