cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
8668
Views
0
Helpful
5
Replies
Highlighted
Beginner

SRG file not present/cannot be opened <- N5K upgrade

Hi all, I am getting the above error that was also discussed here on this forum without any resolution a few years back!

Some detail on my 5020. I am looking to go from 4.1.3 -> 5.2.1

If anyone has any suggestion, I would appreciate the help.

Thanks in advance,

Eoin

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted

Can you please check the caveats listed below ?

CSCsw25835 - NX-OS upgrade fails due to SRG extraction failure

https://www.cisco.com/cisco/psn/bssprt/bss?keywords=CSCsw25835&searchType=bstbugidsearch&page=bstBugDetail&BugID=CSCsw25835

CSCtn79039 - install all errors due to SRG extraction failure due to pc.log file size

https://www.cisco.com/cisco/psn/bssprt/bss?keywords=CSCtn79039&searchType=bstbugidsearch&page=bstBugDetail&BugID=CSCtn79039

Thanks, Vinayak

View solution in original post

Highlighted
Beginner

Hi Eoin,

Here's something I noticed -- to do a good/valid ISSU you'd need to get to at a minimum the 5.0(3)N1(1c) but the waypoints would require a disruptive upgrade.  Getting out of the 4.1 code will require at least one reboot/disruptive upgrade. 

See this link regarding getting to the 5.2 code:

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/release/notes/Rel_5_2_1_N1_1/Nexus5000_Release_Notes_5_2_1_N1.html#wp429893

Here's the upgrade path to 5.0(2)

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/release/notes/Rel_5_0_2_N1_1/Nexus5000_Release_Notes_5_0_2_N2_1a.html#wp267984

Please be aware of the power-sequencer upgrade -- you'll have to remove power.

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/release/notes/Rel_5_0_2_N1_1/Nexus5000_Release_Notes_5_0_2_N2_1a.html#wp204614

As a prudent/safe course I'd recommend

1. upgrade into the 5.0(2)

2. remove power completely

3. upgrade the 5.2(1)

--

Joe

View solution in original post

5 REPLIES 5
Highlighted
Beginner

Hi all, I just want to add that this is what the error looks like:

hadoop-iscsi-sw1(config)# install all kickstart bootflash:n5000-uk9-kickstart.5.2.1.N1.4.bin system bootflash:n5000-uk9.5.2.1.N1.4.bin

Verifying image bootflash:/n5000-uk9-kickstart.5.2.1.N1.4.bin for boot variable "kickstart".

[####################] 100% -- SUCCESS

Verifying image bootflash:/n5000-uk9.5.2.1.N1.4.bin for boot variable "system".

[####################] 100% -- SUCCESS

Verifying image type.

[####################] 100% -- SUCCESS

Extracting "system" version from image bootflash:/n5000-uk9.5.2.1.N1.4.bin.

[#                   ]   0% -- FAIL. Return code 0x404F0003 (SRG file not present/cannot be opened).

Version Compatibility check failed. Return code 0x40930012 (SRG extraction failed).

hadoop-iscsi-sw1(config)#

Highlighted

Can you please check the caveats listed below ?

CSCsw25835 - NX-OS upgrade fails due to SRG extraction failure

https://www.cisco.com/cisco/psn/bssprt/bss?keywords=CSCsw25835&searchType=bstbugidsearch&page=bstBugDetail&BugID=CSCsw25835

CSCtn79039 - install all errors due to SRG extraction failure due to pc.log file size

https://www.cisco.com/cisco/psn/bssprt/bss?keywords=CSCtn79039&searchType=bstbugidsearch&page=bstBugDetail&BugID=CSCtn79039

Thanks, Vinayak

View solution in original post

Highlighted
Beginner

Hi Eoin,

Here's something I noticed -- to do a good/valid ISSU you'd need to get to at a minimum the 5.0(3)N1(1c) but the waypoints would require a disruptive upgrade.  Getting out of the 4.1 code will require at least one reboot/disruptive upgrade. 

See this link regarding getting to the 5.2 code:

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/release/notes/Rel_5_2_1_N1_1/Nexus5000_Release_Notes_5_2_1_N1.html#wp429893

Here's the upgrade path to 5.0(2)

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/release/notes/Rel_5_0_2_N1_1/Nexus5000_Release_Notes_5_0_2_N2_1a.html#wp267984

Please be aware of the power-sequencer upgrade -- you'll have to remove power.

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/release/notes/Rel_5_0_2_N1_1/Nexus5000_Release_Notes_5_0_2_N2_1a.html#wp204614

As a prudent/safe course I'd recommend

1. upgrade into the 5.0(2)

2. remove power completely

3. upgrade the 5.2(1)

--

Joe

View solution in original post

Highlighted

Hi all, I finally got this sorted thanks to the help & advice here.

I ended up having to do a multiple version step upgrade. I went from 4.1.3 -> 4.2.1.N2.1a (last of the 4 series of NXOS) ->5.0.2.N1.1 (1st of power sequencer upgrade) -> 5.2.1.N1.4.

In any of the steps above, I couldn't "jump beyond" the releases I mentioned in the sequence above.

thanks all for the help,

Eoin

Highlighted
Beginner

I also saw this recently, it turned out to be due to still having an SFTP session open to the switch.

It seems when you connect via SFTP, it places a "lock" on the filesystem - e.g. maybe you are still uploading/deleting files?

I'm guessing a similar "lock" is created when you copy or SCP files, but the connection/session closes once the transfer is complete.

This "lock" causes the "show install all impact" check to not be allowed to extract files to verify them, as it also tries to "lock" the filesystem so it can extract the images without having them changed/deleted while it is processing them.

Logging out of SFTP resolved it for me.

Brian