cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10564
Views
10
Helpful
9
Replies

3750-E baud rate issue

fabian-idrissi
Beginner
Beginner

Hi

Having trouble resetting the baud rate to 9600 on a 3750-E.  Basically the device cannot be set to anything other than 115200 baud rate.

I have changed this via startup-config (which lost connection) reconnected and saved config but after reload was back to 115200.

Tried via bootloader to 'set 9600' but the termial program paused for a bit then the switch prompt returned.

Tried the same to 'unset baud' but the same thing as above happened.

I have erased and reloaded flash etc but this does not help.

all other operations are ok

Any ideas??

9 Replies 9

shailesh.h
Beginner
Beginner

Did you manage to set IP address to switch?

I was referring to getting started of 3750-E and it's confirmed that default IP address allocated to switch in 10.0.0.1

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750e_3560e/hardware/quick/guide/14507.html

Can you share why you want to set the console port spee?

Hi Shailesh

Thanks for your reply.

I can configure an IP address on the switch manually - but generally I don't go through Express Setup to do this.  Do you suggest I should start again and go thorugh Express Setup ?

We need to use the standard baud rate throughout the organisation.  Plus, not being able to set it permanently may indicate further issues.

Regards

Fabian

I would suggest you to go ahead with express setting and setup router to the configuration you want. Once you have visibility then check the hardware, version and go for specific commands to set the console speed.

Usually console port speed is 9600 BAUD and to access through any terminal emulation program. Once you are in the router config you have good flexibility to analyse and set configuration to your wish

Thanks again, but this didn't work.

Setting the line console speed via 'bootloader' or 'express setup' or 'running/startup-config' does not hold the setting upon reloading.

Are there any other options to try or should the device be declared faulty?

Regards

Fabian

Startup config should retain even after re-loading the router. If it's not happening then certain

ly you treat the equipment as fault and ask for replacement.

But usually this fault is very rare.

With regards,

Shailesh

Thanks for your input - I am not going mad after all!

I had and fixed the same Issue, it seems setting the baud rate in rommon does not work with "SET BAUD 9600", but instead configured under line con 0

After a reload, the switch returned to a baud rate of 115200

Switch#show run | beg line con 0 

line con 0

speed 115200

line vty 0 4

login

line vty 5 15

login

!

end

The change below, persisted the configuration through reloads.   The "feature" will need to be remembered, so keep it in mind if the equipment is repurposed and you write erase the startup-config

Switch#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#line con

Switch(config)#line console 0

Switch(config-line)#speed 9600

Switch(config-line)#end

Switch#wr mem

Building configuration...

[OK]

Switch#reload

dennishyde
Beginner
Beginner

I know this is a little old but just went through some of the same scenarios.

I have a 3750G with the same problem.  I had sped up one last week to 115200 to copy over a *.bin and then set it back to 9600 with no problems.

Today I found a switch in our spares that is set to 115200.  I tried to change the speed at the Console port and after reboot found it went back to 115200.

So, I tried what BlackHawk08 suggested, in another post, by going into ROMMON by holding down the mode button during boot.  The set BAUD 9600 did not work.  But the unset BAUD did work.  I then did flash_init waited and then type boot and waited.  The switch rebooted and came up at 9600.  I then did a show run and the Console port is no longer at 115200. 

So, I've been able to change the speed on a switch to copy the IOS over and set back successfully and fix a switch that had been changed to 115200.

Dennis

FlorianCokl
Beginner
Beginner

I have had the same issue.

 

From ROMMON tried the so often mentioned common suspicios - without success. In ROMMON it said that the BAUD was set to 9600 - but - once it booted it was back to 115200.

 

So I thought that it must have something to do with the startup-config, right? And I found it. I did a show run all after the switch was fully operational and there it unfolded:

line con 0
 exec-timeout 0 0
 timeout login response 30
 privilege level 1
 no media-type rj45
 logging synchronous
 modem answer-timeout 15
 modem dtr-delay 5
 data-character-bits 8
 exec-character-bits 7
 special-character-bits 7
 length 0
 width 80
 history size 20
 monitor
 databits 8
 stopbits 2
 start-character 17
 stop-character 19
 speed 115200

 

So - the only thing I did was to got to conf t, line con 0, and use speed 9600. Save the running-config to startup-config, reload and - tata, BAUD is at 9600.

 

Obviously the BAUD from ROMMON gets overwritten once the startup-config is loaded? And if the startup-config contains a different setting - it's applied.

 

I would suggest the following when recovering a 3750 from the "no (working) OS on board"-situation. Within ROMMON (and flash initialised) set the BAUD to 115200 (to accelerate the file-transfer, 9600 is just very slow), do the file-transfer (xxx.bin), and after transfer is finished set BAUD back to 9600 before booting the switch.

 

Cheers

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: