cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1116
Views
0
Helpful
4
Replies

3750 mac-address-aging timer

ccobtn
Level 1
Level 1

Hi,

i'm trying to change mac-address timers but having problems, i.e the change I’m trying to change mac-address-aging timers but having problems, i.e. the change only applies to existing active vlans. if i add new vlan after changing mac-address-aging timer it will have default value 300. Is this way it works or I’m missing something?

3750-sw-1(config)#mac-ad aging-time 1300

3750-sw-1#sh mac-ad ag

Vlan Aging Time

---- ----------

10 1300

20 1300

30 1300

3750-sw-1#! Now adding a new vlan

3750-sw-1#conf t

3750-sw-1(config)#vlan 40

3750-sw-1 (config-vlan

3750-sw-1#sh mac-ad ag

Vlan Aging Time

---- ----------

10 1300

20 1300

30 1300

40 300

New vlan 40 has default value????

4 Replies 4

glen.grant
VIP Alumni
VIP Alumni

If you don't want the default then yes you will have to specify everytime you create a new vlan what you want the timer to be .

lgijssel
Level 9
Level 9

Just checked the command reference. In the usage guidelines it states:

Usage Guidelines

If hosts do not send continuously, increase the aging time to record the dynamic entries for a longer time. Increasing the time can reduce the possibility of flooding when the hosts send again.

If you do not specify a specific VLAN, this command sets the aging time for all VLANs.

The last sentence is relevant to your question. The command may also be issued on a particular vlan.

New vlans are created after setting this parameter globally will hence be using the default values.

The key issue to check if this is a bug or not is to check whether the global command is reflected in the config. If it was, I would call the issue a bug.

As it is not, you must approach this as a parameter that can (and should) be set per vlan. After creating a new vlan, you may add this line in the script or re-issue the global command.

Regards,

Leo

It does appear to be a bug in 3750(tested in 6500 and 4500 and did not see this behavior). I did a quick search and did not find one. So I suggest that you open a TAC case and email me the TAC SR Number.

Hi,

Cisco TAC have confirmed this as Bug.

Bug ID:coCSCsc43130-3750 Cannot change default mac-address aging time

Regards,