cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1863
Views
0
Helpful
12
Replies

7204 VXR reboots into ROM mode always

c.mac
Beginner
Beginner

Hi all,

I am having all sorts of problems with my 7204. For some strange reason it rebooted itself, but into ROM mode. Everytime I tried to reset it, it would tell me that the bootflash could not load cuz of some sort of error and revert back to ROM mode. Can anyone tell me how to fix this.

FYI: The only time I get the router to be stable is if I load a whole new IOS and keep the router powered on. Even after I have the new IOS loaded and do a reload, it will automatically give me the same problem and stay in ROM mode. Please anyone..HELP....

12 Replies 12

thisisshanky
Advisor
Advisor

Can you paste the error message, exactly as it reports. Probably your boot flash image is corrupt.

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

deilert
Frequent Contributor
Frequent Contributor

sounds like your box is crashing and when it is recovering the boot statements are incorrect. Paste in a sh ver and a sh run and a sh flash /dir slot0:

When I do a show flash I get

Open device slot0 failed (Device not ready)

For show version I get

Cisco Internetwork Operating System Software

IOS (tm) 7200 Software (C7200-IS-M), Version 12.2(11)T, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Fri 02-Aug-02 10:51 by ccai

Image text-base: 0x60008940, data-base: 0x61850000

ROM: System Bootstrap, Version 12.1(20000710:044039) [nlaw-121E_npeb 117], DEVEL

OPMENT SOFTWARE

JEH7204 uptime is 15 hours, 8 minutes

System returned to ROM by reload at 00:02:04 UTC Mon Mar 1 1993

System image file is "disk0:c7200-is-mz.122-11.T.bin"

cisco 7204VXR (NPE225) processor (revision A) with 114688K/16384K bytes of memor

y.

Processor board ID 23658225

R527x CPU at 262Mhz, Implementation 40, Rev 10.0, 2048KB L2 Cache

4 slot VXR midplane, Version 2.1

Last reset from s/w nmi

Bridging software.

X.25 software, Version 3.0.0.

2 FastEthernet/IEEE 802.3 interface(s)

20 Serial network interface(s)

125K bytes of non-volatile configuration memory.

46976K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).

4096K bytes of Flash internal SIMM (Sector size 256K).

Configuration register is 0x100 (will be 0x0 at next reload)

I think I have to change the confreg back to the normal setting. But need a second opinion.

This will happen only because of 2 reasons :

1) bootflash image not compatible with your flash image.

2) as shanky said, your bootflash might be corrupted.

DONT CHANGE THE BOOTFLASH IN ANY CASE, AS YOU MIGHT NEED TO CHANGE THE ENTIRE I/O CONTROLLER if anything goes wrong.

Thanks

Hmm..okay I just tried a reload and this is exactly what I get.

System Bootstrap, Version 12.1(20000710:044039) [nlaw-121E_npeb 117], DEVELOPMEN

T SOFTWARE

Copyright (c) 1994-2000 by cisco Systems, Inc.

C7200 platform with 131072 Kbytes of main memory

System Bootstrap, Version 12.1(20000710:044039) [nlaw-121E_npeb 117], DEVELOPMEN

T SOFTWARE

Copyright (c) 1994-2000 by cisco Systems, Inc.

C7200 platform with 131072 Kbytes of main memory

Checksum failed on c7200-fslib-m

Expected checksum: c32b, calculated checksum: 235b

open: file "c7200-fslib-m" not found

open(): Open Error = -1

loadprog: error - on file open

cannot load the monitor library "bootflash:%c7200-fslib-m" from device: boot fla

shboot: cannot open "bootflash:"

an alternate boot helper program is not specified

(monitor variable "BOOTLDR" is not set)

and unable to determine first file in bootflash

loadprog: error - on file open

boot: cannot load "cisco2-C7200"

System Bootstrap, Version 12.1(20000710:044039) [nlaw-121E_npeb 117], DEVELOPMEN

T SOFTWARE

Copyright (c) 1994-2000 by cisco Systems, Inc.

C7200 platform with 131072 Kbytes of main memory

string is disk0:c7200-is-mz.120-26.bin

Self decompressing the image : #################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################## [OK]

*** Coprocessor Unusable Exception ***

PC = 0x87ff7820, Cause = 0x2000002c, Status Reg = 0x3040d003

monitor: command "boot" aborted due to exception

System Bootstrap, Version 12.1(20000710:044039) [nlaw-121E_npeb 117], DEVELOPMEN

T SOFTWARE

Copyright (c) 1994-2000 by cisco Systems, Inc.

C7200 platform with 131072 Kbytes of main memory

Checksum failed on c7200-fslib-m

Expected checksum: c32b, calculated checksum: 235b

open: file "c7200-fslib-m" not found

open(): Open Error = -1

loadprog: error - on file open

cannot load the monitor library "bootflash:%c7200-fslib-m" from device: boot fla

shboot: cannot open "bootflash:"

boot: cannot determine first file name on device "bootflash:"

System Bootstrap, Version 12.1(20000710:044039) [nlaw-121E_npeb 117], DEVELOPMEN

T SOFTWARE

Copyright (c) 1994-2000 by cisco Systems, Inc.

C7200 platform with 131072 Kbytes of main memory

I have no idea how to stop this madness..

deilert
Frequent Contributor
Frequent Contributor

This error

string is disk0:c7200-is-mz.120-26.bin

Self decompressing the image : #################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################## [OK]

*** Coprocessor Unusable Exception ***

PC = 0x87ff7820, Cause = 0x2000002c, Status Reg = 0x3040d003

is telling me that either your image does not support your NPE or your image is corrupt

What kind of NPE are you running

it's a 7204 VXR with NPE 225

deilert
Frequent Contributor
Frequent Contributor

thanks , do you have a PCMCIA card on the box or do you have another box close that you can move the PCMCIA card from to get the box up ?

You can try to remove the PCMCIA card from slot0; then reboot the box will load the first valid file it sees in flash , if it can not find one it should load to bootflash.

I have tried that...it reverts back to this line

monitor: command "boot" aborted due to exception

System Bootstrap, Version 12.1(20000710:044039) [nlaw-121E_npeb 117], DEVELOPMEN

T SOFTWARE

and after 3 tries it goes into ROm ..

Now when I put back the card, which has the 122.T image it loads fine but I lose all my configs. When I force it to load from an image that i saved with all the configs on it gives me this error

string is disk0:c7200-is-mz.120-26.bin

Self decompressing the image : #################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################################

################################################################## [OK]

*** Coprocessor Unusable Exception ***

PC = 0x87ff7820, Cause = 0x2000002c, Status Reg = 0x3040d003

I am really lost for words...have no idea what the fix is

deilert
Frequent Contributor
Frequent Contributor

Ok What is going on is you boot statements are bogus if you notice on the sh ver above it it loading disk0:c7200-is-mz.122-11.T.bin" from disk0: your boot statement is looking at slot0:

This leads me to beleive the image 12.0(26) is not high enough rev for an npe 225 . From the compatability matrix

What you can do here since there is a good image on the box is power cycle the box , when you get the ###### going across the screen break in to the box

then set your config register to 0x2142 this will ignore NVRAM and your boot statements. It should load the image on disk0:

rommon> confreg 0x2142

rommon> reset

after this you should get to

router>

router >en

hit enter

router # copy start run

router # conf t

router#(conf) no boot system

router#(conf) config-register 0x2102

router#(conf) end

router# copy run disk0:

router#wr

router# reload

7200 NPE-225=

Minimum Supported Software Release(s) per release train

12.0(5)XE6, 12.0(7)XE1, 12.0(9)S, 12.1(1)E, 12.1(1)T, 12.1(1), 12.1(14)E, 12.2(1), 12.2(2)T

JEH7204 uptime is 15 hours, 8 minutes

System returned to ROM by reload at 00:02:04 UTC Mon Mar 1 1993

System image file is "disk0:c7200-is-mz.122-11.T.bin"